Stuck on config screen


Unable change on shake config. The problem was happen after re-imaging my sd card and rebooting on Action. I think the server is working well. Any idea how to resolve?

RSH…2021-02-04T13 59 45.logs.tar (1.2 MB)


looking at the log files, it appears the SD card is corrupted. i would re-image a different SD card and try again.


Hello zairy, welcome to the community!

In case you need it, here’s the procedure for a from-scratch installation of our OS:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

You can try to do it on the same microSD card, or if you have another MLC or SLC cards around, you can use those too.


I just got my raspberry shake and have the same issue as zairy.
These are my log files:
RSH…2021-02-05T09_31_58.logs.tar (473.5 KB)
I tried to create an image in a different SD card following the instructions above and in this case I am not even able to load the rs.local page. Is it possible that it is in the process of updating the software?
I both cases, with the original SD card and with the one created by me, the blue light on the shake turns on.
I am using a Raspberry pi 4 model B 8GB ram.
Best Regards,


Hello again,

It seems it was in fact updating the software. Now it is up and running. The only odd thing I noticed is that it does not identify the Pi model I am using, it just says Unknown Model and it is not yet connected to the server.

Best Regards,



good to hear the first problem resolved itself, sorry to hear you have a new one. your model number is a recent 4ModelB release that the system doesn’t know about yet. (this lag within the system is being addressed in the next release.)

in the meantime, you will need to make one slight adjustment by hand to get the system to work for you. please log in to the Shake’s Pi and issue the following commands:

> sudo rm -f /dev/ttyAMA0
> sudo ln -s /dev/ttyS0 /dev/ttyAMA0 
> sudo reboot

after the reboot, the data will be read off the correct serial port and everything should work as normal.

please let me know if you experience any other issues.



Thanks for your answer Richard. I also noticed I was in Stand-Alone mode. I changed that and now it is connected to the server. I still don´t see my device in the netwrok though. I´ll wait and see and let you know

1 Like


I’m having the same issue (sorry for the poor language). I’ve tried re-imaging the SD card several times and tried the “sudo rm -f…” commands and it doesn’t work as expected. With older images of the OS the data of the raspberry shake displays correctly but with the latest release I cannot get the same result and also can’t find any file under “/opt/data/archive”

Thank you in advanced for any possible help.


RSH…2021-03-13T15 41 14.logs.tar (849.5 KB)

Hello @alexander132, welcome to the community!

Thank you for the logs. I can see the issue from them, it’s clear from some of the file reports.

The first thing you can do is to check (if you can) if the power source is providing the required 2.5A and between 5.0V and 5.2V. Any less than these values will cause malfunctioning.

If the power source is operating as it should, have you tried the commands suggested by my colleague in this post on this same thread? Stuck on config screen - #6 by ivor

The guide to SSH into the Shake is at this address on our manual: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake

A post was split to a new topic: Config screen is blank