Config screen is blank

I am setting up a RBOOM and seem to be having similar issues. The rs.local page has everything blank like the OP screenshot except “stand alone: off” and “server connection: not connected”. I am able to enter my name and location, and toggle ‘forward data’, reboot, etc. but nothing else. Clicking helicorder button goes to a 403: forbidden page. Nothing shows up in “My Shake”. I reformatted the card and reinstalled the software as suggested here, and tried the terminal commands found in this thread, without any apparent change.

RSH…2021-06-29T07_11_38.logs.tar (350.5 KB)

Hello zdQktyRA, welcome to the community!

I have moved your answer to a new topic, so that we will not be reopening discussions on an old one.

Thank you for the logs. From them, it appears that indeed, the Shake can find an internet connection and that the DNS and IP addresses are properly assigned. So, on that front, everything should be ok.

On the blank screen issue, I see that your Pi revision code is b03114, which is assigned to a 4B board. We are working on this issues with some Pi4 boards that cause the problem you are experiencing, and likely, the next ShakeOS version will solve it.

Can you confirm that you are using a Raspberry Pi 4B board, and that you have already tried the commands listed by Ivor in this message Stuck on config screen - #6 by ivor?

Thank you.

Thanks, sorry I wasn’t sure if I should start a new post or not. Yes this is the one I bought (everything else was backordered):
Raspberry Pi 4 Model B - 2 GB RAM[ID:4292]

I was able to ssh and log in via terminal, then I entered the commands from the previous post- nothing noticeable happened but the final reboot command made it reboot so I assume they went through. When it reboots the config screen is still blank

It is no problem at all, no worries.

Thank you for confirming that. I have written to our software team, and I’ll get back to you as soon as I’ll have an answer from them.

As stated, this update is still in the work, and the Pi4 boards are the latest that are being added to our Shake OS. Thank you for your patience.

In the meanwhile, could you please check that all the connections between the blue Shake board and the Pi board below are solid, and that the Shake board is sitting on the pins 1 to 26 as indicated in our manual? Technical Specifications — Instructions on Setting Up Your Raspberry Shake

This is just to be sure that the hardware is where it should be. Thank you.

Just checked, the board is on completely on the correct pins, all the lights are behaving as specified: red and blue solid, green on the pi board flashing, ethernet orange solid and green flashing

Other posts mentioned power, I’m using the raspberry pi branded power adapter:

Hello again,

Thank you for your report, we can now say that the Shake is behaving as expected (from the lights) and that there are no likely issues with the power supply.

We now need to take a look at the logs from the Shake itself to understand what may be happening. Since the rs.local/ page is not available, the only way to acquire them will be via the command line.

Can you please log into the Shake via ssh, as shown on this page How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake and navigate to the


folder? The logs are all in there and you can download with scp and zip them together and post them here on the forum.

If you are not familiar with this, you can use a windows program to access the Shake and download the logs, a list is provided here: How to download your data — Instructions on Setting Up Your Raspberry Shake

With them, I’ll be able to analyze the situation in a better way, maybe the cause of the issue will jump out!

Oh to clarify I can get to rs.local (well not specifically sometimes rs.local doesn’t bring up anything but going to the ip address that I found with fing brings up the page), it is just that all the fields on that main screen are blank-

Using this interface I was able to add my location information, and toggle data forwarding, etc. and all those settings seem to stick. But that main page stays the same, and nothing relating to the station shows up in the outside world

A fresh batch of log files from there-
RSH…2021-07-01T18_01_34.logs.tar (361 KB)

Perfect, thank you!

Yes, this is a case where the ShakeOS is not recognising the Pi board and creates this error. As said, it will be corrected in the next release, and for now, we have a manual fix in place.

Since you said that you have done what ivor showed here Stuck on config screen - #6 by ivor let’s now check if this has created the softlink in the /dev/ directory with this command. Can you please ssh into the Shake again, and execute

> ls -l /dev/tty*

and confirm that data is being received off the port:

> cat /dev/ttyS0
> cat /dev/ttyAMA0

If everything works, one, or both of the shown cat commands will show an output like the following:

FFA2DF5","FFFA3184","FFFA30F3"]}{"MSEC": 8329000,"LS": 0}{"MA": "RS4D-5-4.1","DF": "1.0","CN": "EH3","TS": 0,"TSM": 0,"TQ": SI":  5000,"DS": ["2108","166C","1048","23C7","2793","256B","2A34","21D1","1F0D","1B60","1D00","16CE","F57","1374","12EA","187C","1150","85A","188C","1FB5","1CD5","1D51","1D29","2A6C","1F7B","183C","24AD","1F6F","1B9D","1B62","1E41","1F60","17B2","1E92","2A46","1CD2","1136","1F68","2754","16EF","1577","199A","2665","265D","1E2F","24C2","2596","1E0A","238C","29C4"]}{"MA": "RS4D-5-4.1","DF": "1.0","CN": "EN1","TS": 0,"TSM": 0,"TQ": 45,"SI":  5000,"DS": ["FFFD8094","FFFD844B","FFFD8548","FFFD867B","FFFD849E","FFFD866A","FFFD873B","FFFD8A17","FFFD8D19","FFFD8777","FFFD834F","FFFD7F9B","FFFD8971","FFFD8590","FFFD7CB5","FFFD7F0A","FFFD80F5","FFFD8439","FFFD845A","FFFD7FC9","FFFD8254","FFFD82CA","FFFD811C","FFFD8870","FFFD7FBB","FFFD7D64","FFFD7D2A","FFFD80E8","FFFD8021","FFFD8146","FFFD85EF","FFFD853F","FFFD841D",

Hope I’m doing this correctly (also I am using Terminal on a mac dunno if that matters), the first command-

The cat commands, the second one didn’t output anything

Hello again,

Thank you for the outputs, and no, when you connect to the Shake the terminal that you have used to do so is not an issue.

From the second screenshot, there is clearly some kind of connection problem that creates that kind of jibberish output. I will ask for advice from our software team, and I’ll report back to you as soon as I can. Thank you for your patience.

No problem!

Oh just one other thing, do you know if these were still supposed to come with the second filter tube with the yellow band? The parts list mentions it but there wasn’t one in the kit. I’m not sure when or if I would get the chance to use it, but curious if the package changed or something

Hello again,

Sorry for the question, but I cannot refer to what you mean with if these were still supposed to come with the second filter tube. Could you please rephrase the sentence? Sorry for that.

The issue of the blank page appears instead to be somewhat tricky. If you have another Pi board available, preferably not a Pi4, could you please re-assemble the Boom with this different board, to check that the sensor and the blue Shake board are both working as they should?

It is the only way to eliminate the possibility that, for some reason, the Pi4 board is having some issues that we cannot replicate, and that are thus more difficult to solve.

I was asking if the RBOOM package should have two choices filter tubes in it- a red one and a yellow one, as noted in all the technical documents. Mine didn’t come with a yellow one, I was not sure if that was a mistake or if that wasn’t being included anymore as it kinda sounds like they don’t expect anyone to use it.

I only have one other Pi but it is also a Pi4, I would have to disassemble the ADSB setup it is being used for but I could try it, but again it is the same model purchased this year. Its been hard to find anything but a 4 model lately that wasn’t part of a marked up package, and the website seemed to indicate that it would work with a 4 so that’s the only reason I purchased it. The only other Pi’s I have are extremely old and don’t have the same pin setup at all, I think its one of the very first models probably close to 10 years old

Good morning @zdQktyRA :slight_smile:

Thank you for your message, your support and for joining the Raspberry Shake Community!

Yes, a yellow filter should have been included with your RBOOM. In the end, this is really only included for the benefit of clients who use the RBOOM professionally and, even then, it would be rarely used. We ship with the red filter because, in all likelihood, this will be the most appropriate filter for most users in most cases. That said, we would be more than happy to ship a yellow filter out to you. Just let us know by sending an email to sales[at]raspberryshake dot org.

I will let @Stormchaser engage with you on the Pi4 issue.

Kind regards from Panama, Branden

1 Like

Thank you @branden for your input! :slight_smile:

Hello zdQktyRA,

I understand the situation. Then I can recommend to fully disassemble the Shake, check that every contact is clean and in a good state, then reassemble everything taking care of checking that all the connections are good.

At this point, re-burn the microSD card to eliminate all issues and start from a fresh install.

These are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Finally, since you are using a Raspberry PI4 board, remember to execute the commands illustrated in this post after the re-burn is done: Stuck on config screen - #6 by ivor

This will give us a clean slate to work with, and to proceed with our troubleshooting if the page continues to be blank.

Finally had some time so I went ahead and disassembled the BOOM and rebuilt with the other Pi4 board I have, formatted the card and reburned the image, followed the setup instructions, and then ran the sudo commands from the other post, far as I can tell same result-

RSH…2021-07-16T22_20_22.logs.tar (1.1 MB)

Hello zdQktyRA,

Thank you for having re-done everything from the start. It is actually the first tiime that the sudo commands from our soft-link solution seems to be failing.

Coul you please re-execute the commands I suggested in the seventh message of this topic (here Config screen is blank - #7 by zdQktyRA) and post again their results? Thank you!


the problem is that the data from the Shake board, being sent to the serial port, is being received on a different-named device than what the Shake-OS is expecting.

until the next update, which will solve this problem forever, this is easily handled by identifying the named serial port and creating a soft-link from what the Shake-OS is expecting to the actual port where the data is being sent to.

to handle this, we need to 1) identify which port the data is being sent to, and 2) create a soft-link to it:

  1. identify which port the data is being sent to:
    we know /dev/ttyAMA0 is not correct, so most likely is one of the other two possibilities. please log in to the Shake Pi and run the following two commands:
> cat /dev/ttyS0
> cat /dev/serial0

one of these will return nothing, while the other should return human-readable data.

  1. create a soft-link from /dev/ttyAMA0 to the one returning data, and then reboot.
    for example, if /dev/serial0 returned data, the soft-link command would be:
    > sudo ln -s /dev/ttyAMA0 /dev/serial0

hope this helps,

Both of those returned similar gibberish-
Screen Shot 2021-07-20 at 12.58.46 PM


thanks for the output. binary data coming off the serial port usually means that the connections between the geophone and the Pi are somehow compromised. for example, connections between geophone and board are reversed or not fully connected, or that the pins between the board and Pi are possibly compromised.

if you think this is not the case, please contact me directly for possible next steps.

sorry for the troubles,