Server connection - not connected after reboot


I rebooted my shake on the weekend and when it came back up it has not been able to reconnect to the server. I’ve read through several related posts and have tried almost everything (reboot modem, static IP ) but it still will not re-connect to the server. Locally on my PC and swarm everything is fine.

Attached is screenshot and log file. The first time I rebooted was around 2 days ago and looking at the logs, there is some Python 2.7 please upgrade message appearing. Not sure if this is related to my issue. Help would be appreciated.

RSH.RE4AA.2021-09-26T22_30_52.logs.tar (3.5 MB)

I wonder. Please try unchecking data forwarding and then rechecking it. After that, click save and restart. Then wait a min or two and see if your stream appears…

Please let me know if that changes anything.


That worked!! Great. Thanks for the fast reply and suggested fix, much appreciated.



I’ve ran into the same problem recently too. Rebooting didn’t help. Turning off data forwarding, waiting 3 minutes, and turning it back on hasn’t helped me. Are there any other suggestions?

1 Like

Hello BlackDiamond,

can you please provide the logs from your Shake so that I can take a deeper look?

The instructions on how to download them are here: Please read before posting!

Note: I had the same problem as 7kapai and was able to get the connection by doing what BHSN suggested. For those that might have the same problem.


I just noticed that the version was updated to 0.19. It looks like that version was released around the time that it stopped working. I’ll have to get the logs a little later when I have some time available.

Hmm… so following @BHSN’s instructions precisely seems to have brought it back. I have to save after checking and unchecking. I can’t save between checking and unchecking.

1 Like

Thank you for your feedback BlackDiamond.

It is very valuable information, and I have passed it to our software team, so that they will be able to take a deeper look into it and see what can be done to solve the issue.

Glad to hear that your Shake is online again!

A post was split to a new topic: Shake unable to connect

My shake was accessible locally, but could not connect to the server. This seems to be corrected by unchecking data forwarding, checking then saving as suggested. Thanks

Whoa! Spoke too soon. Shortly after reporting that it was connected to the server, the pie went down and has disappeared from the local network. Cannot connect with the browser or ssh.

Okay, after a trip to the basement to power cycle the pi, it’s back, but not connected again.

RSH.R85DA.2021-12-14T20 47 12.logs.tar (1.2 MB)

Drama! It’s connected again! Yay!
Shake seems to be online and fine now. Thanks for your patience.


Dear Tech Support :
1A: I experiences the same problem. After proper shutdown: I reconnect the RS1D to power, it turns back to “Data Producer ON”, also “Data Consumer ON”, also “Data Forwarding ON”, but “Server Connection” is NOT connected. I need to go to Settings, Data, unselect then re-select “Forward data”, and then press SAVE and RESTART. Then it works.
1B: The problem appeared right after the first shutdown.
1C: my RS1D is connected to a home network.
2: log file: please see attached.
3: very likely the same problem occurs in several school sites with which we work in Switzerland. Once the solution is found here I’ll contact them to see if that also solves their problem. Please let me know when you know how to proeed.
RSH.R73E5.2021-12-20T19_50_53.logs.tar (1.4 MB)

Hello hetenyi, welcome to our community!

Thank you for the logs from your Shake and your detailed answer. From them, it seems that there are no particular issues. The Shake boots up properly, can see our servers, and I can also see live data streaming here: RS StationView

The procedure that you have done is the correct one (for now) to overcome a bug that will be fixed in the next v0.20 Shake OS release. Until then, that is the method that we recommend to try and solve the “Not Connected” problem visible in the rs.local/ page.

You can recommend the other schools to try it. If the status doesn’t change to “Connected” then I will have to see the logs from those other Shakes to try and understand where the problem may be.