Wifi dongle that worked

Hi everyone -

This is not a post with a question but a post to share how I got my first RS4D working with a USB Wifi dongle. Please feel free to move or recategorize.

The TP-Link TL-WN823N N300 USB dongle works with the current (April 2023) Raspberry Shake 4D (Raspbian Buster).

[Some lengthy background]
In search of a silent spot on my home lot, I set up the Shake in my garage, first along the corner where the garage door is, and the other under my large toolbox. The first position was good but every time the garage door opens and closes, not to mention the car moves in and out, there is some noise. The other location, while further away from the car and door, is 1.5-2 meters away from a deep freezer (which is really quiet), a water heater (that is elevated on a 2ft platform) and a water softener, which is about 6 ft away but only really recharges once every 2 weeks, Part of the challenge of testing in different locations, I would have to keep creating and extending long lengths of ethernet wire. So, there are a couple more spots I want to test but figured, it would be a pain to keep making longer cat6 cable. I need a USB wifi dongle that would work… Cue, the topic.

I tested the Canakit and Edimax Wifi Dongles but I just could not get their drivers to successfully load after following the instructions. For the Canakit, which is a Ralink chipset, I even tried compiling the driver but that got complicated pretty fast. I followed the posted list from the manual, and searched for drivers that specifically worked with Raspbian Buster, and did notice commentary in the forums about the tp8188 chipset usually being very compatible.

The product I went with that eventually worked for me was the TP-Link TL-WN823N N300. It didn’t work right away and I had to follow the steps on this link to get it to work.


  • Insert dongle with device running
  • This dongle uses the tp8192eu driver. Run the install-wifi script: link
  • Enable wifi and eth: link
  • Configure the wpa_supplicant.conf file to have my wifi info. Do the steps at the top of the link.
  • Disable the onboard wifi: link
  • reboot
  • While it is rebooting, remove the ethernet cable so that the Shake will power up the wifi

And that worked. Now I am looking forward to testing out the shake in other parts of the house with the added challenge of finding a power and ethernet source.

I hope this helps someone in the future.
Sorry it was lengthy and if it is in the wrong section.


Thank you @mehershad

Can you post some photos of your final setup?


1 Like

This was very helpful, thank you! I ended up getting the same dongle…it was just small enough (not a millimeter to spare) to fit in the Outdoor enclosure. You can’t really see the dongle here (the one shown is actually a flash drive for more space, wifi dongle is below), but it I am now using the dongle with a hotspot (not connected to the internet, just for a local network) to connect to the Shake with a tablet that I can use to quickly shutdown the Shake in the field (we are using it as something of a mobile seismometer). For whatever reason I could only get it to work with a 2.4GHz network, even though both the router and the dongle claim to work with 5GHz.