Swarm causing signal?

I’m not sure how this is happening, or why, but when I start swarm I get a signal that shows up on my shake in 0-1hz visible in the image. It took me a while to figure out where it was coming from. It only happens when I run swarm on my PC and connect to the pi to view the live data streams. If swarm is not running this signal goes away. Any idea why this would show up only when swarm is running?

Setup is a pi3, RSB, hardwire to a metal enclosure outside.

Hello AsteroidDave, welcome to our community!

You have keen eye, that’s for sure! I am trying to replicate your issue with my SWARM installation on my PC connected to my RS3D, but as of now (I left it running for about 10 minutes) I am not noticing this spurious signal appearing on my Shake spectrogram. My RSUDP is also not showing it, unfortunately.

It is the first time that we are seeing something like this. It seems some kind of strange interference that, as you describe, is only present when SWARM is active.

I don’t know if they will be useful, but could you provide the logs from the Shake for a period of time when SWARM was off, and then another set of logs for when SWARM was on?

Maybe, comparing them will help in shedding some light on this matter.

Thank you!


I’ll see if I can get some logs for you. I have done further testing and it is definitely only when swarm is running that this signal shows up. I got rsudp up and running and the issue is not present with a udp stream. I’m not sure if there is a difference in how swarm connects and gets data. It is directly related to the swarm update. If I increase the cadence of the update 1s to 5s, the signal spikes are 5s apart. I also just realized that it will show up in rsudp as well when I load the local webpage for the shake, rs.local, while running rsudp. So there is some strange interference happening for sure, annoyingly right in the range for faint/distant earthquakes.


Thank you, as said, I don’t know if they will be useful, but it’s worth a try.

This is fascinating, even if annoying, I agree. I have tried the same experiment that you did, changing the update interval, but these spikes are not present in my spectrograms, on any Shake.

SWARM connects via what they call a “Winston Wave Server” and I don’t think it uses the same UDP protocols that RSUDP uses. I will also ask our teams if they were aware if this issue, and for their opinion, they could provide more insight in the matter.

Thank you again for bringing this to our attention.

1 Like

@AsteroidDave A question that I forgot to ask, are you connecting to the Shake via LAN or WiFi?

Also, does this happen with every PC/laptop (if you have tried more than one) or with just the one that you have highlighted? How many meters and walls are between the Shake and the PC running SWARM?

Thakn you again.

I’m not sure how to isolate logs just from when it’s on swarm and not.

The RSB is not using wifi at all. I have it connected to my LAN with PoE. I connect to the network over wifi on my laptop, but have also tried plugging into the router directly and it has the same issue.

It doesn’t matter which PC I use to connect to the pi, the signal shows up if swarm is running.

The RSB is outside in a concrete enclosure with a metal lining about 30 feet from my house.

Thank you for the further details AsteroidDave.

Could you please download the logs from the Shake and post them here? So that we can have more elements to try and understand this phenomenon.

Instructions on how to do so are here: Please read before posting!

Thank you!

I wasn’t sure how to isolate the logs based on if Swarm was on or off. Here are the most recent logs.


RSH.RC1C0.2022-03-16T21_10_09.logs.tar (2.3 MB)

After doing extensive testing, I have narrowed it down to the long ethernet run out to the enclosure. Something about that cable / distance is causing the issue. It is high end cat6a cable. No idea why it would be doing this.

1 Like

I also installed a lightning arrestor I had planned to install. I reclamped the ends of the long ethernet cable and put a patch cable between the arrestor and the pi. This seems to have made the interference go away for now.


I am following this thread with interest.


This is very interesting @AsteroidDave, and a well thought idea.

If you have one, you could try to see if one of the newer CAT8 LAN cables to see if there is any difference. Or, maybe, this could be a test for later.

Thank you for your constant updates, they could be very helpful to other users that may encounter a similar situation in the future.

I would think about using a fiber connection rather than a long (ethernet) cable.
No more difficult to install the physical fibre, a bit more investment in the transceivers for each end, but they don’t have to be expensive for the length I am guessing that you are talking about. Once you get into the very high-end ethernet cable, it’s probably pretty much even.

I’m familiar with running networking using fiber. You can’t run PoE over fiber though and I don’t have power at the remote site where the RSB is installed. I’ll probably upgrade the ethernet cable to something more robust. I just purchased a cat7 cable that is double shielded and rated for outdoor use.

I was thinking that you probably were using PoE in that environment … I would still consider laying fiber alongside the existing cable, leaving the existing PoE injector and extractor in place and just switching the ethernet connection to using fiber. I think it might be a more stable solution in the long run.

I suppose it really depends upon whether you have a reasonably priced source of shielded, low crosstalk (whatever they want to call it … cat6e, cat7, cat8, cat-whatever) cable to try out.

That would require upgrading a lot of other equipment. The ethernet is probably sufficient for now. I think the cable just needs to be shielded.