Station offline AM.RBCC7

Good day;
my station used to be on the network. at some point it fell off (and I did not notice till now).

the ShakeNet Web App: Raspberry Shakes' Community Portal shows that the station is still in the database, but it is marked offline.

looking through the forum I found a suggestion to check the internet connections:
giovanni@giovanni-dualboot:~/applications/swarm-3.2.0$ nc -zvw5 53
Connection to 53 port [tcp/domain] succeeded!
[1]+ Done sh
giovanni@giovanni-dualboot:~/applications/swarm-3.2.0$ nc -uzvw5 123
Connection to 123 port [udp/ntp] succeeded!
giovanni@giovanni-dualboot:~/applications/swarm-3.2.0$ nc -zvw5 55555
Connection to 55555 port [tcp/*] succeeded!
so it appears that the internet is OK.

I cannot open the page rs.local/ (blank page “server not found”)

Fing does not find the shake unit in my local network.

what should I try next?
thanks for any suggestions.

1 Like

Hello gdeamici, welcome back to the community.

Yes, from what I can see too the station is indeed offline. To know more about what is happening I would need the logs from the Shake (instructions on how to download them are here Please read before posting!).

However, as you have said that rs.local/ is not accessible, I would advise (unless you have already tried) to shut down both the Shake and your modem/router. Then start the modem/router again, wait for it to regain internet connection, turn on the Shake, wait for ~30 minutes from this point, and try to see if now rs.local/ is accessible via this address, or via the IP address of the Shake on your local network?

If neither option works, then the fastest way to solve this would be a fresh microSD re-burn. I will leave the burning instructions here for your convenience:

I will wait for your updates.

wrote this top part last night and sent as email:
good day;

well, some luck (kind of).

tried the on/off cycle for the shake and the modem/router. no change

reformatted the microSD, downloaded the OS image, copied and installed, re-booted the shake (light are solid red, solid blue and flashing green), and yet rs.local/ does not find the station. nor does fing.

connected the shake to the modem via ethernet cable and that made the shake visible to rs.local and fing. however, the ‘my shake’ page still reports my station as being offline and the station is not visible in the ‘station view’ map.

log file is attached; will let it run ‘wired’ overnight before trying to remove the ethernet cable.

but shouldn’t the OS be well past rev 0.20 ?

suggestions are always very welcome.


Giovanni De Amici

now the update:
the station is still working, at least according to the rs.local and the helicorder view (attached) shows data.
however, both the station view (attached) and the my shake (attached) pages still shows “offline”.

So, just in case it helps with diagnostics, I am attaching also the most recent log file.

Lastly: if I disconnect the shake unit from the ethernet cable, rs.local says the ‘system has been shut down’.

It does not seem to be normal/expected behaviour, is it?

[RSH.RBCC7.2023-02-08T05 40 54.logs.tar|attachment]
(upload://31vVubt95atKaA4rhQswq0ru9J5.tar) (57 KB)

RSH.RBCC7.2023-02-08T18 20 35.logs.tar (152.5 KB)

1 Like

Hello again gdeamici, thank you for your fast answer.

From what you describe, the LEDs on the Shake appear in the right sequence, and the fact that you can see data on the local helicorder is definitely a good sign.

From the logs (thanks for attaching them), it seems that some steps in the configuration of the Shake are missing. In particular:

Station Info

Data-Sharing Mode : OFF
Data Server Conn : OFF

Could you please reboot your Shake again and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

The station should now be able to connect again.

From the logs, it appears that the Forward Data box is not checked, so this should solve the problem you are experiencing and make the Shake appear again on StationView and on ShakeNet. If not, please re-send the new logs to see if there have been any changes that could point us towards a solution.

Another element that appears out of place is this:

Geophone : NOT YET SET

Could you please check fromrs.local/ page, Settings (the gear icon high on the left), and then check the General tab, that . Make sure that the question Did you receive the geophone... is marked with Yes, and, if not, select that option, and then click Save and Restart?

Thank you.

Regarding this:

Lastly: if I disconnect the shake unit from the ethernet cable, rs.local says the ‘system has been shut down’.

It is indeed unexpected behavior, but let’s tackle one issue at a time and solve the connectivity problems for now.

getting there.
had to reset all the info for the geophone (my name, email, location, …) plus check off those boxes, but now the station appears on the network.
the logfile is attached.
the problem with wired/air setup persists. I suspect it is because the shake has forgotten about the local wifi. but when I go under re.local>setting>network>wifi setting and try to connect to wifi the station needs the router password and firefox shoots me a warning that this (your) connection is not safe.
do you have an https way to set the wifi on the shake?

RSH.RBCC7.2023-02-09T22 01 01.logs.tar (381 KB)

Hello gdeamici,

Great job! I can see the Shake online again on all our services, streaming live data.

I have one of my Shakes connected via WiFi, so I’ve tried resetting that one to replicate the issue you are experiencing via both Firefox (v109.0.1) and Chrome (v109.0.5414.120), but that error has not appeared.

We have an advanced guide to setting the WiFi connection manually, How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake which, however, requires you to connect to the Shake via SSH (How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) and operate via command-line.

I think this problem is solved. it took a little more editing that I planned, and still cannot get the shake to accept dual-mode connection (wifi & ethernet at the same time) but that is a small inconvenience.
Although it is hinted, you might want to spell out in bold that, as long as a ethernet connector is inserted into the shake body, the shake expects to see the network via the cable and will not try the wi-fi route. and this even when the ethernet cable is left floating at the other end.
thanks for your help and patience.

just in case the logfile from today is attached.
RSH.RBCC7.2023-02-10T23 36 01.logs.tar (624 KB)


Happy to hear that the issue has been solved gdeamici!

Thank you for your further feedback and for the new logs. No problem at all, you’re welcome!