Shake unable to connect

Just received a Shake 3D yesterday, it did load the latest software (.19), and is generating data, but is not connected to the server. Tried methods described above, still doesn’t connect to the ShakeNet Server. Station ID is RD07C.

Hello fester, welcome to our community!

I’ve moved your post to a new topic so that we can discuss your issue without too much confusion.

Thank you for contacting us about this problem. Could you please send me the log files from your Shake? The instructions on how to do so are here: Please read before posting!


I’ve attached the log files. Config looks OK, getting data to the Helicorder and to jAmsSeis app. Log seems to show attempt, but no connection to the Shakenet server.


Mike D.

RSH.RD07C.2021-10-13T13 33 (64.5 KB)

1 Like

Hello Mike,

Thank you for the complete logs from your Shake. Yes, the configurations seems all right, and the issue can be identified via these lines in one of the log files.:

2021 285 21:07:42: Network detection failed, unable to curl or ping common sites
2021 285 21:07:42: No internet connection found
2021 285 21:07:42: Network detection failed, unable to curl or ping common sites

This results in:

Oct 12 21:07:35 raspberryshake systemd[1]: ntpdate.service: Failed with result 'timeout'.
Oct 12 21:07:35 raspberryshake systemd[1]: Failed to start Network Time Service.
Oct 12 21:07:35 raspberryshake ntpd[907]: kernel reports TIME_ERROR: 0x41: Clock Unsynchronized

And thus there is no data transmission to our servers, since the clock has to be synchronised for communication to happen.

The fact that you can see the data via jAmaSeis and the helicorder display of the Shake tells me that the local connections are working fine, and that there is something preventing the Shake’s communications with our servers.

To cross-check if the Shake can see our server, could you please log in (instructions here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) into the Shake via command prompt with

ssh myshake@rs.local or ssh myshake@shake_local_IP_address

and execute the following command from the command line?

nc -zv []( 55555; nc -zv []( 55556

This will return ‘success’ or ‘connection refused’, which will at least be a direct indication if the unit can see the server and ports it needs to or not.

If the return is a connection refused, please check that if the following ports

port 55555 [TCP]
port 55556 [TCP]

are open, and if not, please open them on your modem/router/network.

In any case, also check that

port 123 for [TCP] and [UDP] traffic in both directions

is also open. This last one is the port needed for the NTP time service, and it is required to keep the data synchronized with our network.

Thank you for your collaboration in this!


Did some preliminary testing using the links provided to None would connect, a port scan of my LAN does of course show the Shake and the open ports are 21, 22, 80, and 111 for FTP, SSH, HTTP, and sunrpc. My LAN to the shake is a Spectrum Cable Modem, into a Tp Link 16 port switch.

Computer is an M1 Mac mini running Big Sur. I’m pretty good on the hardware side of things, but totally inept at coding/programming, but it does seem that the problem is with the connections to the server. Anything else I can check?



Hello Mike,

Thank you for the tech specifications of your local network. Have you tried shutting down the Shake, connecting it directly to the modem, momentarily bypassing the Tp Link switch, and turning it on again?

It’s just a test to see if the switch was causing the “no connection” issue, or if there is something else that is working against the Shake reaching our servers. From the looks of it, it seems that we are in a local connectivity issue, where something is blocking the Shake from communicating to the outside.

Hi Stormchser

Just reconnected to the cable modem ethernet port (of course I can’t see it on the Network now…), I’ll run it there for the day or so and see if it shows on the station list/map.