Shake off line

For some reason my shake is offline but reading connected on RSlocal.

Hi Labrina, sorry for the inconvenience. Your Shake is now back online:
https://raspberryshake.net/stationview/#?net=AM&sta=R359E

Hi, I have the same issue: RB972RSH.RB972.2020-09-23T17 47 53.logs.tar (4.0 MB)

everything looks fine to me:

https://raspberryshake.net/stationview/#?net=AM&sta=RB972

your unit was having DNS issues, preventing successful connection to the server, but this seems to have resolved itself now.

cheers,

richard

1 Like

Thanks Richard,
It still says station offline on ‘my shake’ on shakenet and on the shakenet app. Am I missing something?
Apologies for the newbie type questions, it only arrived today!

hi,

propagating a station coming on-line throughout the system can take a few hours, patience is key.

your shake is online now in the mobile app, and should also be on-line on the ‘my shake’ page.

cheers,
richard

Hi, our station AM.R7BF6 is also offline. The station has been already on and sending data to swarm for a week and it appears as activated and connected in rs.local, but it still doesn’t appear in the station map, and in the mobile app appears as offline. Any idea about which might be the problem?

Cheers,

Pablo

Hello Pablo, welcome to the community!

Could you please post the logs from the Shake?

They are downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local address in your browser, then by clicking on the “Download Logs” button.

Thank you.

hi,

seems to be working for me:
https://raspberryshake.net/stationview/#?net=AM&sta=R7BF6

richard

Me again!

My skake ran for a couple of weeks but then whilst away with work, it seems to have disconnected from the server (around the 30th September).

Data Producer : ON
Data Consumer : ON
Stand-Alone : OFF
Data Forwarding : ON
Server Connection : Not Connected

I’m not clever enough to decipher the logs, can anyone help me diagnose?

Thanks

MattRSH.RB972.2020-10-12T15 31 32.logs.tar (4.0 MB)

Hello Matt,

From the postboot.log file, these lines explain the issue as a DNS problem, where the Shake cannot reach our servers:

2020 286 14:49:51: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2020 286 14:49:51: No internet connection found
2020 286 14:50:02: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

The first thing you can try (if you haven’t already) is simply to shut down your Shake from the rs.local web interface, then your modem/router, wait a couple of minutes, and then turn on again the modem first and the Shake second, to see if it was a simple issue with the modem/router itself.


If this does not happen, then you can also try to change the DNS on the Shake, as explained in this page on our manual, https://manual.raspberryshake.org/firewallIssues.html#how-to-manually-change-dns, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is 208.67.222.222, is a good choice. You can also use Cloudflare DNS service by entering 1.1.1.1 or Google by entering 8.8.8.8.

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: https://manual.raspberryshake.org/ssh.html)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=1.1.1.1 1.0.0.1' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart
    

    Now make sure those changes took hold:

    nano /etc/resolv.conf
    

    The file should look like the following:

    # Generated by resolvconf
    nameserver 1.1.1.1
    nameserver 1.0.0.1
    

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

Sorted after a few headaches. Turned out my router had gone haywire & decided to only route internal traffic on some sockets, so I could look at it locally but it couldn’t see the outside world.

Very random! Thanks for your assistance, I would have just been chasing my tail for weeks!

Matt

1 Like

Unusual and random indeed, but glad that you could solve the problem!

Can you tell us the brand and model of your modem/router? So we can have a reference for eventual future users. Thank you.

It was a router provided by Plusnet in the UK (not entirely sure what it was). Now slung in the bin and replaced with a Draytek 2862.

Thanks

Matt

2 Likes

I have the same issue, station not showing up on StationView, with R532B. It’s been a few days.
RSH.R532B.2020-10-21T04 29 56.logs.tar (1.3 MB)

Hello jeffersonite, welcome to the community!

Thank you for posting your logs, from them I am seeing that the boot procedure seems to work fine, and your Shake is properly working after that. So the issue has to be on the connectivity side.

The first thing you can try (if you haven’t already) is simply to shut down your Shake from the rs.local web interface, then your modem/router, wait a couple of minutes, and then turn on again the modem first and the Shake second, to see if it was a simple issue with the modem/router itself.

If this doesn’t work, then shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

After checking this, and opening the ports, if needed, please start your Shake, wait for around 10 minutes, save the logs again, and then send them back to me, so I can see if there are any differences in them compared to the original ones.

Now it’s best to check that your unit can reach our servers so, can you try to SSH into the Shake by entering this command in a prompt (with admin authorization)?

ssh myshake@rs.local

If during the configuration you have changed the password, you should input that one, and not the provided default (which is shakeme).

Once you are in, can you try and ping the following addresses?

  • ping 8.8.8.8 -c 10
  • ping 104.200.16.60 -c 10

The first one is the Google server, while the second is our data server. The two commands will execute the exchange ten times, and your expected result is a 0% packet loss for both instances.

I’ll wait for you to try this and your new logs before going forward.

Hi @Stormchaser,

Thank you for the detailed reply, but I did all of that before I sent the logs the first time. This unit can ping 104.200.16.60, has open firewalls, and is recording data fine.

I got an automated email saying that the RS server hasn’t seen this unit in 3 days (the day I first turned it on), so it must have communicated successfully at some point.

I might have another unit that is also having the same issue, but I haven’t heard back from the enduser yet.

I have a few more of them to deploy, some at not so accessible places, so it’d be nice for it to just work the first go-around. What are the server-side issues that might result in this behavior?

Thanks,
Jefferson

Hello again Jefferson,

All right, thank you for that. I will ask our server team about this, and as soon as I’ll get details from them I’ll update you.

It is totally understandable, and normally they work from the get-go (as mine did). I’ll get back as soon as I can.

Hello Jefferson,

I just got back an answer from the team, and they were able the solve the issue.

Now your station transmits successfully, and it is visible bot on StationView and our ShakeNet app.

image

Excellent! Thank you! What was the issue?