Shake not responding - using my own RPi4

I have purchased the Rasp Shake 1D without the RPi.. I have set it up using my RPi4 and using the SD card provided by Rasp Shake.

Do I have to do something to configure other than using the provided SD card in my RPi4 . I followed instructions at the following link and at Step 3 I don’t see any communication between the RPi and my laptop.

Quick Start Guide — Instructions on Setting Up Your Raspberry Shake

My laptop is unable to communicate with the Rshake – pings are not working between them though both are on the same network and can individually ping the router and reach the internet.
I have a monitor hooked up to the RPi and it does boot up, obtain an IP and can ping the router.

Hello Girija,

So, to understand the situation: both your Shake and your laptop are fully connected to the network, your Shake gets an IP from your router in the correct way, but you cannot ping the Shake from your computer.

I assume that you have tried accessing the rs.local page, with details of the Shake. Can you try to see if you can find it in the list of the devices from your modem/router admin panel? Or, can you find it with an app like Fing (

In this case, have you tried to access the Shake by entering its IP address in the browser window?

We’ll start from here and proceed onwards.

Yes. Both the Shake and laptop are connected on the network. I have disabled the firewall on the laptop – and yet I cannot ping between them. Both of them can ping the router and an external IP address. Yes; I have tried using the IP address as the URL on the web browser. I am using Chrome as suggested.

Rs.local does open up; but the details are not populated. When I press the restart button; nothing happens to the Shake – basically I don’t think there is any comms between the two units.

I could try fing – but given that I cannot access the Shake even after using the IP address directly; I’m not sure it will help.

I was browsing through the other issues reported on the forum and there seems to be a suggestion to burn another SD card with the software. I was planning on trying that out as soon as I get hold of a second card – don’t want to overwrite the SD card that came with the kit


Hello Girija,

thank you for the extensive information that you have provided.

Yes, there have been cases where the rs.local was unpopulated due to corrupted files in the microSD card, and a re-burn was all that was needed to make it work properly.

Another thing that you can try is to check the power supply. Sometimes we have encountered issues with underperforming ones, which did not provide enough power to the Shake. Please ensure that the output voltage of the one you are using is between 5.0V and 5.2V with a current of at least 2.5A.

Also, if you haven’t tried already, please disable the screen output and disconnect the external monitor, which in some cases may have disrupted the setup process of the Shake, and try pinging/connecting to the Shake again from your laptop.

Will try out all the options over the weekend and update you by Monday.




I wanted to give an update about the status since I am stuck.



Hello Girija,

Which of my suggestions have you tried? One? All three?

Can you please describe what you have done before that screen appeared? It doesn’t tell us, unfortunately, much about what the issue can be.

I disconnected the external keyboard and monitor and verified the power supply rating. It is a brand new one that came with the rpi4.


Thank you, we know that it wasn’t a power or screen issue.

I can then advise you to try and re-burn the microSD card, it should eliminate the corrupted files/processes and give you a fully working OS.

Here’s the procedure for a from-scratch installation:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

You can try to do it on the same microSD card, or if you have another MLC or SLC cards around, you can use those too.


I reburnt a couple of brand new 32GB micro SD cards and get back to the same status I had with the card that came with the RShake………with the only improvement being that I can ping the shake from the laptop on the same network.

However the front dashboard still does not populate most of the info like before. It only populates the info about Stand Alone mode operation.

When I go to the data page and enable forwarding and finish all the other fields and press reboot……….it does not reboot the shake nor does it ask me for the password.

However if II reboot from the Actions page, that works.

If I disable and enable stand alone operation from the settings page that reflects on the main page of the dashboard.

Even after enabling data forwarding, I don’t see my unit on shakenet.

However I do see a couple of units near my location on the stationview page with the unit numbered AM.R1109 being the closest one. How do I check this name on my unit – I don’t see any such alphanumeric name on the dashboard or in any of the log files I downloaded.

Also, rs.local/download/ is the link I am forwarded to when I click on SWARM under downloads. That returns a 404 not found…

Apologies for the delayed response. I am using vibration sensors for an innovation project to monitor and analyzed data from traction motor bearings. I have 3 other cheaper sensors that worked right out of the box. Needless to say the Shake is taking a lower priority now with all these issues.

I am hoping the problems I am seeing are independent of the sensor’s ability to actually measure and log vibration data. I will use a USB stick to log data locally and see if that works once I am done with the other working sensors that I have.

Do you have the ability to do any remote debugging if I enable port forwarding to the Shake on our router?



Stand alone mode operation: Since I’m unable to stream the data, I decided to enable stand alone mode operation. Followed the instructions from here: How to mount a USB to store the waveform archive — Instructions on Setting Up Your Raspberry Shake

I tried going to the rs.local/heli page through the helicorder tab and get a 403 forbidden. Does this operation need access to the Rasp Shake server?

During standalone operation should I be seeing data files generated in the /opt/data/archive folder while the USB is mounted? How long will it take for files to get generated?

Is there any information on the data format for these files? Are these flat files with comma/colon/tab separated values?




Hello Girija,

thank you for the extensive answer, and don’t worry about the time, it’s is of no consequence. Your project sounds very interesting, and I hope that I will be able to help you in completing it!

First things first. Even if the rs.local page is not displaying anything, could you please download and attach the logs from the Shake?

They are, in fact, downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local (or the Shake IP) address in your browser, then by clicking on the “Download Logs” button.

In this way, since it seems that with the new microSD cards we have made some small steps ahead, I can see in more depth what it is happening with your unit.

All the other issues that you are listing, that, rest assured, are completely independent from the sensor(s) performance, seems to be related to some kind of miscommunication between the Raspberry Pi board and the blue Shake Board, with the OS stopping at some point in the process.

This appears clearly from the fact that you are not even getting the name (or code) of your Shake. For documentation purposes, this is how our units name themselves: Raspberry Shake Naming Convention — Instructions on Setting Up Your Raspberry Shake

I had sent a link to the logs earlier. Am sending them again. Hopefully this helps

Following is link related to the SD card that came with the Shake

Following is the link to the logs from the latest SD that I have burnt


Hello Girija,

unfortunately, I cannot seem to access those files. The page keeps telling me “Access Denied” and I cannot even ask for authorisation, strangely.

Can you try to attach them to a message here on the forum as a zipped (or .rar) package? Thank you.

Stormchaser Technical Support
February 8

Hello Girija,

unfortunately, I cannot seem to access those files. The page keeps telling me “Access Denied” and I cannot even ask for authorisation, strangely.

Can you try to attach them to a message here on the forum as a zipped (or .rar) package? Thank you.

RSH…2021-02-03T09_07_22.logs.tar (942 KB)

RSH…2021-02-07T11_46_49.logs.tar (389 KB)

Resending logs one at a time since the email bounced back due to size limits. Attached logs using the original SD card


RSH…2021-02-03T09_07_22.logs.tar (942 KB)

Since the shake board was not being recognized by the Rpi4, I dusted off a very old pi I had and tried the shake on it. I burnt an SD card from scratch and am currently showing up on station view. The heli view is also working and am able to download swarm.

Looks ok do far. Dashboard shot is attached.

Has anyone used the shake on the Rpi4?


Hello Girija,

thatnk you for the logs, I am now able to see and examine them.

It appears that your model is not listed among the compatible RPi4 boards here on our manual: Technical Specifications — Instructions on Setting Up Your Raspberry Shake so that could be the cause.

Many other users have used a RPi4 without issues, so we know that for those modules the Shake OS performs as expected.

However, we also have had other users with your same issue of the rs.local page not populating correctly. You can try a solution that my colleague has shown last week, here: Stuck on config screen - #6 by ivor

Thanks. I will try out the fix. Meanwhile, I got it working on an old rpi and have sent you an email.

Thanks for your help. I will eventually be logging motor vibrations locally. Is there any information available about the format of the data in the archive folder? Does it log time series signals? Are separate logs made for the x, y and z axes?

1 Like

Hello Girija,

The data that the Shake will record is in a timeseries miniSEED format, more information here: IRIS: miniSEED

Here’s the page on how to download the data from the Shake in various way, if it can be useful for you: How to download your data — Instructions on Setting Up Your Raspberry Shake

And yes, there will be logs divided by each channel of the Shake, so you will be able to access them separately. You can navigate our manual for more info: Quick Start Guide — Instructions on Setting Up Your Raspberry Shake