Shake not booting, green light flashing in repeating pattern

Hi all, I recently assembled an RS1D, using a Raspberry Pi 4 Model B (2 GB RAM) as the computer board. I can’t access the Pi at rs.local and it doesn’t appear in Fing. The blue light is on the shake board, and the red light is consistently on indicating that it’s getting power.

The green light on the Pi board however is flashing 4 long flashses, followed by 4 short flashes. This repeats every 15 seconds or so. Reading online, it looks like this might indicate that the Pi board is “not supported” (see here). I’m not sure why this is the case given that the board is one of the recommendations for the DIY setup.

For testing purposes I tried two different SD cards (one that shipped with the DIY kit and one consumer-grade one I had lying around). I also tried both copying the files from the file onto the SD card and burning the disk image onto the card via the Raspberry Pi Imagery, both result in the same green light flashing pattern.

The resolution might be that the disk image needs to add support for my particular Model B board? I guess there are different revisions out there? Any ideas?

Edit: I downloaded the 0.20 image from here and verified the MD5 matches.

1 Like

Hi, I think Pi4 is not yet supported. You should use Pi3 board…

1 Like

Hello guillochon,

Thank you for contacting us about this issue you are experiencing between the Shake and the Pi4 board. From what you have written (blue light on, red light on, green light blinking in that particular way) it indeed seems that the board revision is still not supported by our Shake OS.

This is the complete list of supported RaspberryPi board revisions for each one of our Shake models, could you please check if yours is in this list? Technical Specifications — Instructions on Setting Up Your Raspberry Shake

If it is not, we will need to wait until we can acquire one of these newer units to be able to get our image updated to work with the latest versions of rPi, and with the current shortages, this could, unfortunately, take a while.

However, another user has experienced a similar issue, and has managed to solve it with a bit of a creative approach. You can see it here Support for Raspberry Pi 4 Model B (d03115) - #6 by Uxyll and maybe this procedure will be of help.

@Stormchaser Brilliant, the instructions in the thread you linked worked perfectly! Up and running.

In case it’s helpful I got the board from the Pi Hut in the UK, in case your team needs one of these boards to add official support. I used to snag one.


That’s fantastic to hear guillochon! Great to have you online!

Thank you for the tip about PiHut, I used it a couple of times too, but I hadn’t thought about this.

Enjoy your Shake!