RSUDP issue's

I finally got it to work after a few hours using a 3B and a 16Gb MLC card, [default settings] but getting these errors on loading.

pi@raspberrypi:~ $ conda activate rsudp
(rsudp) pi@raspberrypi:~ $ rs-client

Qt import failed. Trying Tk…
detail: No module named ‘PyQt5’

2021-03-24 20:15:24 [Main] Logging initialized successfully.
2021-03-24 20:15:24 Using settings file: /home/pi/.config/rsudp/rsudp_settings.json
2021-03-24 20:15:24 Output directory is: /home/pi/rsudp
2021-03-24 20:15:24 [Init] Initializing.
2021-03-24 20:15:24 [openSOCK] Opening socket on localhost:8888 (HOST:PORT)
2021-03-24 20:15:24 [Init] Waiting for UDP data on port 8888…
2021-03-24 20:15:26 [Init] Available channels: [‘EHZ’]

2021-03-24 20:15:26 [get_inventory] WARNING: No station name given, continuing without inventory.

2021-03-24 20:15:26 [conn_stats] Initialization stats:
2021-03-24 20:15:26 [conn_stats] Port: 8888
2021-03-24 20:15:27 [conn_stats] Sending IP address:
2021-03-24 20:15:27 [conn_stats] Set station name: Z0000
2021-03-24 20:15:27 [conn_stats] Number of channels: 1
2021-03-24 20:15:27 [conn_stats] Transmission freq.: 250 ms/packet
2021-03-24 20:15:27 [conn_stats] Transmission rate: 4 packets/sec
2021-03-24 20:15:27 [conn_stats] Samples per second: 100 sps

2021-03-24 20:15:27 [Plot] WARNING: Running on armv7l machine, using Tk instead of Qt

2021-03-24 20:15:27 [Plot] Plotting 1 channels: [‘EHZ’]
2021-03-24 20:15:27 [Plot] Seismogram units are channel-specific
2021-03-24 20:15:27 [Plot] Starting.
2021-03-24 20:15:27 [Alert] Alert stream units are counts
2021-03-24 20:15:27 [Consumer] Starting.
2021-03-24 20:15:27 [Producer] Starting.
2021-03-24 20:15:27 [Producer] Receiving UDP data from
2021-03-24 20:15:27 [Alert] Starting Alert trigger with sta=6s, lta=30s, and threshold=1.7 on channel=EHZ
2021-03-24 20:15:27 [Alert] Earthquake trigger warmup time of 30 seconds…
2021-03-24 20:15:28 [Plot] WARNING: Failed to set PNG icon image, trying .ico instead
2021-03-24 20:15:57 [Alert] Earthquake trigger up and running normally.
2021-03-24 20:17:22 [Alert] Threshold: 1.7; Current max STA/LTA: 1.5709

No module named ‘PyQt5’
using Tk instead of Qt

It works so I assume these don’t matter,
Lastly, I can’t save the edited the settings json file, I get permission denied, hence no station name etc

Any help much appreciated as I;m total newbie on raspberry os.

Thanks goes to hcintronBeta Tester

Post was a great help.


Just tried editing the settings again and it saved the file, that’s strange has it would not do it last night. Permission denied.

Hello smokie,

is your RSUDP installation now working properly then?

Hi Stormchaser,
Its working but still get these errors on start of $ rs-client

Qt import failed. Trying Tk…
detail: No module named ‘PyQt5’

Plot] WARNING: Running on armv7l machine, using Tk instead of Qt

Plot] WARNING: Failed to set PNG icon image, trying .ico instead


Hello Phil,

we are aware of those warnings, that appear when one runs RSUDP on a Raspberry armv7I machine, and hopefully, they will be fixed in future releases.

Especially the second one states that it is using the Tk module instead of the Qt module because on a Pi only the first module is present.

Enjoy RSUDP then!

Thank you for the update

One quick question UK goes summertime tomorrow do I change anything on the raspberry as it will be UTC+1, from 02:00 tomorrow.
Set up was all defaults

No problem.

No, you will not have to change anything regarding that. Here at Raspberry Shake we use the standard seismological international convention, and all the times will be in UTC format every day of the year.

This is done so the entire world has a time of reference in UTC format that can be converted and adjusted as needed by the single users/organizations.