RS3D Turnkey regular "No Data from MCU" and "input overrun" data gaps

Bought a new RS3D Turnkey, preassembled. Within a few hours of setup, started getting regular data gaps (~30s on, 30s off), which have persisted for many days now. Looking into log files, each is associated both with a “no data from the MCU” error in the odf_SL_plugin.err, and a “input overrun” error in the system.log. The odf_SL_plugin.err also has intermittent lines of, for lack of a better term, binary gobbledygook. Logs attached.

Installed indoors in a home/office setting (no temperature/humidity issues), with regular power and network access. Reading through previous forum posts, it seems the prime suspects would be an internal connection issue or a bad board/SD card. However, since it came preassembled with both Pi and SD card, I’m hesitant to take it apart/reformat the SD card to start debugging (that was the whole point of buying a preassembled one in the first place).

Suggestions for appropriate next steps, and/or how to go about getting replacement components if needed?

RSH.R9A9A.2021-05-12T14_46_58.logs.tar (5.7 MB)

Hello kluttrel, welcome to the community!

Firstly, I am sorry for the time it took for me to answer your topic. These have been busy days and some tasks have been delayed.

Thank you for your logs. I can confirm what you have already seen. The booting process is working fine and also all the resources that need to be deployed are deployed when and where they are needed.

When this error appears

2021 132 14:46:57>> No Data has been received from the MCU in 12 read attempts.It appears the MCU is not transmitting data. This is a fatal condition and should be investigated if this condition persists!

it usually means that there are transmission issues between the sensors and the boards of the Shake. The ‘gibberish’ that follows only reinforces this thesis, because it is showing data that is not understandable by our OS.

I know that the Shake was pre-assembled, but could you please check that all the connections between the sensors and the blue Shake board are solid, and that the Shake board is firmly fitted on the Raspberry Pi board?

Sometimes a simple loose fitting can cause what you are seeing. I’ll wait for your check before we can proceed forward. You can attach pictures if you want.

Thanks for your response, I understand, everyone is busy.

At your suggestion, I opened the case and used a multimeter to check the connection between both the geophones and their board pins and pins at the top of the shake board and bottom of the pi board. Everything seems to be well connected as far as I can tell, everything else seems secure to light hand pressure.


Then, if the connections are ok between all hardware elements, the other possible issue could be, as you imagined, the microSD card.

It’s possible that the Shake OS on the microSD card is not properly working anymore. I then advise you to

  1. re-burn the ShakeOS on your current microSD card
  2. or get a new microSD (to erase the chance that this one got ruined) and burn the Shake OS there. We recommend MLC or SLC-grade microSDs: microSD card topics — Instructions on Setting Up Your Raspberry Shake

In both cases, these are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Thanks for the suggestions. I tried both reformatting the existing microSD card, which it turns out was 8 GB and formatted as FAT16, and tried with a new 32 GB microSD card, formatted as FAT32 and with the Shake OS image copy-pasted on, as per directions. After restarting and letting it run for a few hours, it seems to be giving the exact same behavior with the exact same errors. Attached are the new logs from the last few hours of operation with the new microSD card.

Suggestions for what’s next?

RSH.R9A9A.2021-05-18T21_53_46.logs.tar (3 MB)

Hello kluttrell,

Thank you for the new logs. Unfortunately yes, I can see that the formatting has not solved the issue like I had hoped.

Now that we have checked connections (which are good) and software (which is good), are you able to check if the power supply is working as expected?

It should provide between 5.0V and 5.2V and at least 2.5A. If not, some users have reported what you are seeing, among other issues with our Shakes.

Thanks for the suggestions, this may have solved the issue. I ultimately tried 3 different power adaptors:

The first described its output as 3.6-6V at 3A, 6-9V at 2A, or 9-12V at 1.5A. This is the one I’ve been using originally that produced data gaps.

The second described its output as 9.0V at 1.67A or 5.0V at 2.0A. This also resulted in data gaps, though their length and spacing were a little different from the prior pattern.

The third described its output as 5.0V at 2.1A. This seems to be running with no data gaps and none of the same “No Data” or “input overrun” errors.

I’ve attached pictures of all 3 below. Afterwards there were a few new data/network errors that appeared, so I once again reformatted and re-burned the 32GB microSD card for a fresh start. It’s been running for ~20 minutes now and seems to have no issues. I’m going to let it run for a full day before I declare it healed.

In the meantime I’d like to understand why the other power supplies didn’t work properly, or more importantly what range of voltage/current outputs are acceptable? The first one offered (more than) enough current, is the shake unable to regulate itself and draw only what it needs? I might expect the difference between 2.0 and 2.1A at 5V to be negligible, but apparently it made a difference? Is the variable charging options a problem in and of itself? Are there pi-specific chargers that would work better/more consistently?

Thanks for your help debugging.


Hello kluttrell,

This is great news! Happy to hear that the Shake now seems to perform as it should.

We use the standard Raspberry Pi power supply, pictured below:

The issues that we have encountered, both from our user information and from our tests, are that if the voltage is above 5.1V there is the risk to permanently damage the Raspberry Pi board, while if the current is below the required amount, our Shakes start to continuously reboot, or do what you have experienced.

There are, however, many other good power supply cords, even specifically made for the 3b version of the Pi, and they are available on many websites around the internet. Nonetheless, we always recommend our users to check if their power supply provides exactly what is stated since in some situations it has happened that this was not the case.

Thanks much, this helped alot. I was able to find a dedicated power supply, and meanwhile the instrument seems to be behaving stably on the timescale of days. Thanks much for all your efforts!


It’s great to hear! I will reroute your words to our hardware guys!

It’s no problem at all, me (and all the team) are here for this too! Enjoy your Shake!