RS won't show as IP

#1

Hi , have a new RS which I built. All the lights are on and it shows as connected on my ethernet connection on my modem, but i cannot find the IP address using bonjour or Advanced IP .
I am using chrome on a windows 10 puter.
I took it to my screen and keyboard and it didn’t show on the screen either?
Help
graham

#2

Get a copy of Angry IP Scanner (https://angryip.org/download/#windows) and run a scan of all of your network (eg 192.168.0.1 to 192.168.0.254). Set the ports to look for in Tools->Preferences as 22 and 80. (enter 22,80 in the box). If the unit is on your network it will find it and show the IP address and Hostname (rs.local).

At the console you can check your Internet connectivity by typing: “sudo ping bbc.co.uk

On the Rpi console you should type: “hostname -I” (it’s a capital i). The IP address of your Rpi will be the first one on the line. The others are internal and can be ignored for the purpose of this exercise. If it does not have an IP address then maybe your router is not offering DHCP service although this would be unusual.

Any finally, check the amber led on the Ethernet socket is flashing. If not then you are not connected to an Ethernet port.

2 Likes
#3

Hi Graham,

The Shake won’t display anything on a screen if it’s not booted with a the HDMI already plugged in. So if you haven’t already, try plugging the HDMI in before booting it.

Also, try using the Fing app, it’s the best thing out there for locating IPs.

If neither of those show anything, how did you burn the OS to the SD card?

Ian

#4

Hi. I got a mini Sd card with my order.
I took it out and put my other raspberry pi sd card in it and i could detect the ip on fing and advanced IP
But the ip address wouldnt let me in. Is there a way to download the shake software by wifi onto a card ?

#5

Hi Graham,

You can re-burn the card using the instructions and archive available in this repository: https://gitlab.com/raspberryShake-public/raspShake-SD-img/

Our apologies for the inconvenience.
Ian

#6

Hello, I burnt a new copy onto a new SD card, and I had the green light flashing, plus the constant blue and red lights, and my raspberry pi is seen by my modem as a device but it is not producing an IP address. The LAN and IP is blank when I go into my connections, and it is not being found by either Advanced IP scanner or bonjour or Fing. It says device then LAN- blank and no IP address?

Help please

Graham

#7

Hi, I put a brand new Sd card in a card reader, downloaded the zip file on my windows 10 computer and exported it to the card, then put it in the raspberry Pi. I will try Angry IP.
I have tried Fing.

#8

Reading through your posts, I wonder if you are trying to use wifi on the RS before configuring it? That would explain the problems you’re getting. It would also explain why it worked when you plugged an RPi SD card into it - the wifi was already configured on that card.
What happens if you plug an ethernet cable into the RS?

#9

When I plug the ethernet cable into it, the light flashes on my modem/ the blue light and the red light are on on the pi and the green light flashes also- (since putting the software on the card). This card was brand new so not used and the pi was only connected via wifi on a different card formatted with raspbian. I assume the OS would be on the card only?
I tried configuring it a number of times via the ethernet before giving up on the card that came with it.

#10

Re-burning the SD card is unlikely to solve this - I counted 3 times you’ve done that.
You need to think laterally. What else could be wrong? Is the ethernet cable faulty?
Have you tried rebooting the modem?
Can you get into the modem using 192.168.1.1 or similar and have a look for an device starting b8:23:37… That’s a RPi.

#11

Nope. Have only burnt a card once, and that was a new card, brand new out of the packet when I gave in trying to connect the one that came with it. Yes I have tried rebooting the modem and no I cannot find any that start with b8. 23. I have tried 3 different cables (ethernet) , I am pretty tech savvy so not dumb about this.Am exasperated that a plug and play machine is not so however. I can only conjecture that maybe it’s being blocked by a firewall?

#12

Do you mean B8:27, the Pi’s MAC manufacturer code?

It is possible you ended up with a blank SD card by mistake; if so that’s our fault. The SD card will still work, but will need you to burn the OS to it.

That’s good, that means the OS is running normally and attempting to communicate with the modem.

This is possible but it still should get an IP from the router as long as DHCP services are working on your network.

Given what you’ve described here, it seems like the modem and the Shake do not want to talk to each other. Can you try connecting the Shake directly to your computer (cutting the modem out entirely) and navigating to http://rs.local? If that works, and you are able to download the device’s logs, please post them and we can take a look at what’s happening from the Shake’s point of view.

Ian

#13

Either that or SSH-ing/pinging to the same address.

#14

Hi, thanks for the help again. I have just plugged the raspberry shake into my ethernet port on the back of my Toshiba think center. The blue light is constant as is the red, the green is flashing, so I will wait for half an hour and see if it is working. I have not been able to get to RS local any any attempt and I don’t understand what SSH -ing pinging means

#15

This is a good sign. How about the ethernet lights on the Shake’s ethernet port?

#16

Both the green and amber ethernet ports are on when I plug into the back of computer

#17
  1. Both on and solid, or is one blinking?

  2. Are you able to try another ethernet cable?

  1. With the Shake plugged into the modem again, can you send me a screenshot of the routing table where you saw what you describe above? You can send it to me as a direct message if you prefer.
#18

both lights were on solid

#19

That may mean that something is wrong with your Ethernet cable. Are you able to try another one?

#20

Hi Ian, my new shake came today so I have been playing with that- it works fine with all the goodies packed with it. Should have done this first!
My only thoughts are the card has not written properly and or the ethernet cable is faulty. Will try my DIY shake with the cable supplied with my new shake but am antsy to take the card out.Might just buy a new card from you guys.
PS how do people power these machines when they are on site?

1 Like