Rs.local is empty

Hi RS Forum,

unfortunatelly, same issue here

Already tried to modify the /boot/config.txt but no success. I’m also enclosing my log files
RSH…2021-07-05T15_29_59.logs.tar (924 KB)

Thanks for any support!

Hello david, I’ve moved your post to a new thread, so we will be able to discuss it here freely without reopening an old topic.

Thank you for your logs. From them, I can see that the time syncrhronisation service starts correctly, but that the Pi board is not seeing the blue Shake board above it.

2021 186 15:18:50: Unable to read Firmware version number off of Serial Port /dev/ttyS0 after trying for 15 seconds, cannot continue!
2021 186 15:18:50: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

Can you please check if all the connection between the sensor and the Shake board, and between the Shake board and the Pi board, are solid? If you have assembled it yourself, and you need a reference for the required GPIO pins, here’s our dedicated manual page: Technical Specifications — Instructions on Setting Up Your Raspberry Shake

Thank you.

Hi Stormchaser,

thanks for your quick response! The Shake board seems to be tight and properly connected to the RPi. It is a model with an outdoor case assembled already a few years ago and everything worked fine.


1 Like

Hello David,

You’re welcome, no problem at all! Since the board is properly set, and the Shake was pre-assembled when you received it, could you please turn it off, wait for a couple of minutes, and when you turn it on again check if the LEDs on it behave as indicated here? Technical Specifications — Instructions on Setting Up Your Raspberry Shake

Thank you.

Hi Stormchaser,

Here is a recording of the LEDs behavior shortly after powering up.


Hello David,

thank you for the video. Yes, there is definitely something that is not going as it should, especially with that red light blinking.

There are now three things that you can do, one after another:

  1. If you can, please check if the power supply is providing the required 2.5A and between 5.0 and 5.2V, if you can. Sometimes, this issue was caused by similar reasons, so it is worth testing it.
  2. Re-burn the ShakeOS on your current microSD card or get a new microSD (to erase the chance that this one got ruined) and burn the Shake OS there.

These are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

  1. Change the Raspberry Pi board with a new one and see if this operation solves the issue. Be aware that by doing this, the code of your Shake will change (accordingly to our naming convention Raspberry Shake Naming Convention — Instructions on Setting Up Your Raspberry Shake).

The first two are relatively easy compared to the third, so I suggest trying them first.