RS doesn't connect

I’m having the same problem. I can successfully ping but no response from your server. Also, the RS shows up on an IP scan as two consecutive IP addresses, but same MAC. Can’t set a static IP address.



Hello swstone,

I moved your answer to a new topic so that we are not pulling out a thread that’s more than a year old.

Can you please download the logs from your Shake and attach them here? Instructions on how to do so can be found on this page: Please read before posting!

Thank you.

Here’s the log file.
RSH.R19A5.2021-12-30T16_11_19.logs.tar (1.5 MB)

Thank you for posting the logs. From them, it seems that the Shake can see and communicate with our servers, but is not connecting for some reason.

Could you please reboot the Shake and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

If this procedure works, and the Shake displays a “Connected” status, can you then try to set your fixed IP address?

Thank you for your cooperation.

Data Forwarding was selected and indicates so in the dashboard. I turned it off and restarted then turned it on–same as previous results–Data Forwarding ON, Server NOT CONNTECTEDRSH.R19A5.2021-12-31T17_38_03.logs.tar (1.7 MB) . Tried static IP with REBOOT–no change, same status as previous.

This system worked previously – should I reload the SD card and start from scratch?

Hello swstone,

Thank you for the update and the new logs. Nothing seems to appear out of place, which is strange since you are not managing to connect, so I would recommend the same.

Let’s see if, after re-burning the microSD card, the Shake manages to connect (even with the use of the procedure listed above if necessary), and then we will move on the fixed IP issue.

I will post the burning instructions here for your convenience:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Looks like that did it as far as connection to your servers. Also, there is only one local IP used (two was pretty weird, they both had the same MAC). I don’t see it on the map yet, but I’m hoping that’s only a delay. I’ll let this run for a while before I try to set a static IP address.

Thanks for your help.

1 Like

Hello swstone,

It was pretty strange yes. The only way for two IP address to appear there would have been like having both the LAN and the WiFi connected, which was not your case.

There’s no problem at all, happy to hear that now your Shake works as intended and connects!

It may take up to 24 hours before appearing on our services, but usually, the required time is way less than this.


Looks like I’m no longer connecting to the server. I’ve rebooted the system and power cycled it. RSH.R19A5.2022-01-05T13_02_23.logs.tar (947.5 KB)

Hello swstone,

Thank you for the new logs. From them, it appears that your Shake is not ablew to find any network or internet connection. These lines show the problem:

2022 004 22:34:31: Network detection failed, unable to curl or ping common sites
2022 004 22:34:31: No internet connection found
2022 004 22:34:32: Network detection failed, unable to curl or ping common sites

I am not sure what has changed since the last time. Can you please check that every cable is connected properly, and that the Shake power supply is working as intended, maybe switching it with another one if you have it around, to be sure that everything works.

You can also try to reset/reboot/shut down-turn on again your modem/router, and to see if, after this, the Shake is seen on your local network. You can try to change the LAN cable that connects the Shake to the modem/router, or also try to change the port where the Shake is attached, if you haven’t already done so.

I checked the cables and switched ports on the router–no change. I ssh’d into the RS from my Macintosh on the same network. Ping to did not connect. I was successful in pinging into the RS from my Mac. So the RS is alive and connected. I looked at the latest logs and the RS is still failing to connect to the the server.

I did an IP scan on my LAN with the following results:

I’ll reset the modem and router and report back. If that doesn’t work, I’ll re-flash the SD card (again) as that temporally solved the problem before.

Rebooted the modem, router and RS. ssh’d into RS and pinged my Mac on LAN with good results, but failed on ping to on WAN.

Linux raspberryshake 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l


Developed by:
Raspberry Shake:
Boaz Consultancy:


Last login: Fri Jan 7 00:43:38 2022 from
myshake@raspberryshake:/opt $ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=8.30 ms
64 bytes from icmp_seq=2 ttl=64 time=3.80 ms
64 bytes from icmp_seq=3 ttl=64 time=19.6 ms
64 bytes from icmp_seq=4 ttl=64 time=3.86 ms
64 bytes from icmp_seq=5 ttl=64 time=63.10 ms
64 bytes from icmp_seq=6 ttl=64 time=3.87 ms
64 bytes from icmp_seq=7 ttl=64 time=110 ms
64 bytes from icmp_seq=8 ttl=64 time=27.5 ms
— ping statistics —
8 packets transmitted, 8 received, 0% packet loss, time 18ms
rtt min/avg/max/mdev = 3.802/30.086/109.730/35.615 ms

^Cmyshake@raspberryshake:/opt $ ping
PING ( 56(84) bytes of data.
From icmp_seq=1 Destination Host Unreachable
From icmp_seq=2 Destination Host Unreachable
From icmp_seq=3 Destination Host Unreachable
— ping statistics —
6 packets transmitted, 0 received, +3 errors, 100% packet loss, time 245ms
pipe 4

myshake@raspberryshake:/opt $

Long reformat of SD card, then installed RS software. Restarted system–ping to was successful and server connection successful. Nothing on Station View yet, but the night is young.

Hello swstone, good morning,

It seems that the last reformat has worked fine! The Shake is now connected and streaming live data to our services. Here’s StationView: RS StationView

I am not sure why the Shake wasn’t pinging trough the WAN, probably some mis-assignment of DNS from the router that was solved when a freshly formatted system re-connected to it? Thank you for providing details of the steps you have done anyway, they could be useful to other users in similar situaions!

(P.s. Happy to see another person with an Air Quality Monitor on their network!)

Yes, great to see the RS working again.

When I attempted the ping to google I used the IP address, so I believe there shouldn’t have been a DNS issue. I don’t know, I’m not a network engineer.

The PurpleAir is interesting, along with the AIS tracker (we’re on Tampa Bay, so we get a fair amount of ship traffic), the ADS-B plane tracker (lots of air traffic here). My weather station is at a different site (HOA restrictions here) as well as some amateur radio gear. The RS is just another piece of citizen data collection and sharing.

Thanks again for your help. --Stan

1 Like