Reinstallation Woes

I am attempting to reinstall my RS1D (AM RFEA.00.SHZ) and have connection failures. I used Advanced IP Scanner software to verify the IP address for my shake. When I attempt to use that IP address, I get a timed-out failure message.

The Red and Blue LEDs are lit, but the yellow (next to the red) does not light, nor do the lights adjacent to the WiFi cable connecion.

I need to access the configuration page to get back online!


1 Like

You mention WiFi and a cable … are you connecting to the network via the ethernet port?
If so, then you should see an orange light and a flashing green light.

If you have neither of these you do not seem to have a good connection to your router/switch/whatever.
The IP you thought it had was almost certainly incorrect in that case.

Verify that the cable connectors are properly seated at each end.
Try taking the SHake end of the cable and plugging it into a lap (with wifi turned off) to verify that the connection is working.


Thank you, Phillip. Earlier in the day, I was able to connect to the shake and obtain the IP. Now, no joy!
I suspect that the card may have been fouled up. I have had this RS1 since3 2017 and probably bit the dust.

I have changed different cables that ARE known to be ok and did not help. I cannot find how to troubleshoot the memory card or what the blank lights mean. The red and blue light correctly.

Thanks again for input.

1 Like

Probably worth buying/burning a new card before going too much further.

LED behavior: Technical Specifications — Instructions on Setting Up Your Raspberry Shake

Burning new card: microSD card topics — Instructions on Setting Up Your Raspberry Shake


Forgive me Philip, but are you one of the Technical Staff? I’ve been away from the group at least since February and don’t know who the “players” are.

Quoting from the manual: (If any of these LEDs is not behaving as described in the above list, the Shake is not working as it should, and the issue can be solved with our Technical Support assistance.)

I’ll have to really soak in the “burning”, since I have never done this before. Would the SD card need formatinf first? BOY, I hate taking that jig saw case apart to get to the card. Ha Ha

1 Like

Nope. Not technical staff. I do have a bit of experience with Raspberry PIs.
It sounds from your description that the R-PI is not starting up correctly (since you have verified network connectivity). Given the age, I would bet (a small amount) that the card is the problem - not guaranteed, but a good place to start. You could just try re-burning the existing card. That may just work, but it is probably old enough to consider replacement even if it does.

@Stormchaser is tech support, and he will be along once daylight hits his home location.

Most new cards come pre-formatted. So that shouldn’t be an issue - even if it was, it’s not difficult to do.


Sounds like a project for tomorrow. Thanks for the suggestions.

1 Like

Hello JerryP, welcome back to the community!

As Philip, whom I always thank for the provided technical insight, said, it appears that the Shake is not booting properly or, at least, has some issues during the connection phase. The missing LEDs on the LAN port, and the missing light next to the red one on the Pi board are proof of this.

Unfortunately, since we cannot access the Shake, and thus download the logs to try and understand a bit more about what is going on, the recommendation of re-burning the microSD card is the one that I would give too.

I’ll add the instructions on how to do so below for your convenience:

If, after the procedure, you meet the same problems as before, then I would recommend trying the same burning with a different microSD card that you may have at home, to discard the possibility that the microSD card hardware is the element at fault.

BIG BIG Thank You to you and Philip. I’ll get breakfast and enough coffee down and then start this project.

BTW Do I have to format the old card before the process? If the current card is beyond repair, what size replacement card would I need? ( I have a 32G card laying around if it is not too large."


1 Like

I apparently Bumbled my way to copying the file to a new card and the device is booting up with the LEDs lighting as advertised. IMAGINE THAT!

We’ll see if it continues to “play” correctly and I’m able to configure.

Thanks again Philip & Stormchaser!!!

1 Like

The configuration window says that I am not connected to the server. How do I correct that?


1 Like

Download the log files, unzip the file and take a look at the “myshake.out” file - that is a good place to start. The system info part should show everything running:

System Info

heli_ewII : Running
      OWS : Running
 SeedLink : Running
      ODF : Running
slarchive : Running

Check that the station info section shows the same as the web interface (no good reason why it shouldn’t but look anyway):

Station Info

Data-Sharing Mode : ON
 Data Server Conn : ON
   Save Data Days : 7
       Heli Scale : 0.5
     Station Name : AM.R309F.00.[EHZ][HDF]
         Geophone : OSOP

Now look at the clock info part. You shouldn’t see any errors there, and it should end with something like:

     remote           refid      st t when poll reach   delay   offset  jitter
 SHM(0)          .GPS.            0 l    -   16    0    0.000    0.000   0.000
 SHM(1)          .PPS.            0 l    -   16    0    0.000    0.000   0.000
+   2 u  272 1024  377  196.675    4.981   1.040
*    2 u  385 1024  377   90.345    1.627  35.887
+ (       2 u  413 1024  377  166.656   -3.244   0.505

The server with the * nex to it has been selected as the best quality clock source for you.

Next, the network info. It should all be ok since you can connect to it.:

Network Info

  Stand-Alone Mode : OFF
       Ethernet UP : YES
           WiFi UP : YES
     DNS Available : YES
Network Accessible : YES
       Nameservers :,,

Next are the connections to the R-Shake servers:

=== Shake Data Server ===
 Port 55555 : YES
 Port 55556 : YES

Somewhere along he line, you will probably see some sort of problem. That will tell you where to go next.

Oh, and post the logs zip file here - If you don’t find/fix the problem, that will be the first thing that @Stormchaser asks for.

1 Like

Thanks, Philip.

There were several differences between my download and this list:

Data Server Conn : was OFF

In the “clock Info” section I do not have Offset and Jitter columns.

In the Network Info:

Stand-Alone : was ON
WiFi: was NO
Nameservers were different, but I’ expect that. Everything else was OK.

In the configuration part about “Datacast” is a mystery to me. Target IP and Target Port are a new item to me which I cannot find any information…

Here ae my log files:
RSH.RFAE6.2022-06-21T23_40_29.logs.tar (202.5 KB)

1 Like

Cancel that comment about missing Offset and Jitter columns. MY SISTAKE.

1 Like

Hello JerryP,

Firstly, good job on the burning of the microSD card, it can be tricky when done for the first time!

Secondly, thank you for your logs. From them it appears that the Stand Alone mode (which does not allow internet server connections) is turned on, as this line shows:

2022 172 21:20:32: STAND-ALONE Mode ON, not checking for an internet connection

To turn it off, you can do the following:

To turn it off, you can click on the Actions icon high on the left (hammer), then go to the Actions tab and click on the Turn off-line mode OFF button.

If the Shake still does not connect, then please reboot it, and after it has turned on again, please check that the Forward Data box is checked. You can find this box by clicking on the Settings icon high left (gear) and then on the Data tab.

Thank you. It is working now.


That’s great to hear JerryP!

Enjoy your Shake again!

MAN!!! I hate to keep bugging you, but everything is showing ON except “Off-line Mode” shows OFF.
I thought all should show ON.

I’ve double and triple-checked your instructions and all are changed or checked as requested. My station has not appeared on the map yet, I understand that takes time to happen.

Jerry2022-06-22 09_30_21-Raspberry Shake Config

1 Like

No. You want the Off-Line mode to be OFF (if you want it connected to the Internet).

The normal automatic boot sequence requires an Internet connection so that it can synchronize the clock using NTP – there is no batter backed-up realtime clock on the R-PI.

If it can’t set the time using NTP, which requires a network connection, it hangs.

The Off-Line mode allows you to use the device without a network connection - it changes the boot sequence to bypass time setting and checking on the Internet connection. You have to set the time manually, but it allows for use with no network - E.g. classroom settings.

Anyway … for you use, keep it off.

1 Like

Philip, I’ve had it.
I went to a doctor’s appt. and came back and the RS was “DOWN” RS LOCAL has never worked for me and I use the IP address to get to the setup window, whatever it is called).

I cannot access it at all to do anything! I can’t BOOT or RESET…nothing.

1 Like