Please help "Server Connection:Not Connected" issue

I received a mail from you about “Raspberry Shake: We have not seen you in a while!”.
And I found that Server Connection:Not Connected in http://rs.local/

ping to is OK.

Hello Taka, welcome to our community!

Thank you for the logs from your Shake, and also for checking that the ping to the Google server gives a positive result.

Could you please reboot the Shake and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Try unchecking the Forward Data box and, after ~30 seconds, recheck it. Then,click save and restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

Thank you for your cooperation.

1 Like


Thank you very much for your reply.
Uncheck “Forward Data” + save and Check “Forward Data” + save solved the “Not Connected” issue.

But I still have another issue about “Station is not online.” in My Shake page of ShakeNet.
I checked data upload by tcpdump.
And I saw many many upload as following

17:35:23.398536 IP > Flags [P.], seq 1:1351, ack 0, win 229, options [nop,nop,TS val 581164306 ecr 1421783942], length 1350
17:35:23.704959 IP > Flags [.], seq 1351:2753, ack 0, win 229, options [nop,nop,TS val 581164613 ecr 1421783942], length 1402
17:35:23.757180 IP > Flags [.], ack 1351, win 726, options [nop,nop,TS val 1421784301 ecr 581164306], length 0

So, your server received my station data.

1 Like


After reboot my RaspberryShake, the Not Connected issue occur again.
So I needed to uncheck/check again.

1 Like


I checked several hours later without any operation.

Now, I have no issue about “Station is not online.” in My Shake page of ShakeNet.
I can see a graph of my RaspberryShake in My Shake page of ShakeNet.
And I have no issue about StationView page also.


1 Like

Same issue here.
Hopefully Your “trick” will do the trick!

Just checked-unchecked-restarted… now for waiting.
Finger crossed.

Thanks Taka

1 Like

Hello YT1XN,

I hope you to solve your problem.


1 Like

Problem solved!
Somehow, switching to Static IP on Dashboard, Raspberry decided to write TWICE on dhcpcd.conf file proper sentencing:

interface eth0
static ip_address=192.168.1.x/24
static routers=
static domain_name_servers=

Properly, but twice! No surprise, some master confusion at router!

Some nano and everything back on track!

TX again


Hello Taka,

I can see that this station is now operating normally and uploading live data to our servers, here: RS StationView

It seems that it took a bit more than expected, but the data transmission has resumed successfully.

1 Like

Is there a timeline when the version 0.20 will be released? I keep on getting this issue, and the workaround only works sometimes.

1 Like

At the time, there is no estimated release date to my knowledge.

I know that the testing phase is continuing and I will provide an announcement as soon as this step is complete.

We are sorry for the inconvenience that this issue is causing for many users, and thank you for your patience.

After some down-time for house remodeling, I tried bringing my three seismometers (2 1D and a 4D) and Boom back up and online. The two 1Ds and the Boom have no issues, but the 4D is not connecting to the server. It is station AM.R87F8. I’ve tried the checking/unchecking the Forward Data box, as well as restarting and rebooting. It is collecting data onboard and shows a good helicorder from the config page.

Hello rock_jockey,

Thank you for contacting us about this. Could you please provide the logs from the Shake? Otherwise, I cannot be of more help.

Instructions on how to retrieve them are here: Please read before posting!

Thank you.

Here are the logs:

RSH.R87F8.2022-01-26T04_27_06.logs.tar (3.9 MB)

1 Like

Working now! Not sure if it was on my end or not.


Hello again rock_jockey,

Thank you for posting the logs. Indeed, the station is now live transmitting data to our network, here: RS StationView

I am not sure what caused the issue, since the logs report no problem, but I am glad that it has been solved!

1 Like