No realtime data from a stand-alone RS

An RS1D (3 Model B) is connected to a Windows PC through the ethernet cable in the offline mode.

On Swarm, the helicorder is successfully retrieved and displayed, but the realtime wave data cannot be retrieved. The realtime wave windows says: No wave data for [my RS name].

On jAmaseis, in the steps of “Add Source,” it retrieves station information, but when I hit OK on the “RaspberryShake source” prompt, it returns the message, “These values do not specify a valid source. Please try again or use the explorer to find your source.”

I have tried turning off and on of the offline mode as well as rebooting the RS, but not luck. Any suggestions?


The same thing happened to me too.
I got realtime to work by connecting RS and PC through a router (without internet)


That’s good to hear. However, it’s difficult to use a router in my use environment.
It’s nice to find a fundamental solution.

Hello d_koba, Alejandro,

A possible cause for this behavior is that, since the Shakes are in offline mode, the clock is not synchronized properly against the computer clock to which the Shake is connected to.

To solve this, we have a procedure to manually set the clock for offline Shakes, here: Offline and stand-alone applications (like classroom demos) — Instructions on Setting Up Your Raspberry Shake

You will be able to find it in the section that starts with: “If you need the time to be close to current time, take the follow steps:”

If the issue persists, then adding an external router can provide help, as Alejandro has shown. Also, it could be worth checking if all the necessary ports (listed here: Firewall issues? — Instructions on Setting Up Your Raspberry Shake) are open in your computer firewalls, as they could be blocking the live-streamed signal.

Thanks. I set the clock and checked the ports, but it still does not work unfortunately. I have not tried an external router yet…
What is weird is that it was working offline correctly without using a router, and it suddenly stopped receiving the realtime data.

Yes, it is indeed an unusual behavior.

Could you please download the logs from the Shake and send them here? I want to check if there may be other issues (internal ones, maybe) that could be causing this problem.

If you need, the instructions on how to do so are in this topic: Please read before posting!