No connection to server

I have installed the Shake and in the process, I wanted to relocate it to the detached garage. There were some changing of the settings to see it I could go on the wireless I have. I beleve in this process of disconnecting and reconnecting, changing settings, and rebooting, that the host server blocked my IP address. The other options are green (ON) with the Off-Line mode as red (OFF)
At one point it was showing a connection, but this was before I wanted to move it after initially turning it on

Please see attached log file

1 Like

RSH.RD11A.2022-06-10T19_13_12.logs.tar (244 KB)

I was able to get it back online, however I have to have the ethernet AND WiFi connected. See atachement.

I have tried disabling the wifi, and no connection, I tried just ethernet and no connection. but when both are connected it shows connection to server. I am not sure if this is a setting in the software than be changed because I dont want to have to use both all the time.

RSH.RD11A.2022-06-11T04_01_37.logs.tar (488 KB)

Hello Rich, welcome to our community!

Thank you for the logs, both the LAN and the WiFi result, in fact, configured and ON at the same time and we also recommend to not have that, and have only a single connection enabled.

You can turn the WiFi off from its configuration file, by SSHing into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) and then, once in, execute:

sudo nano /opt/settings/user/enable-wifi.conf

modifying the last line from ON to OFF.

Then, reboot your Shake with:

sudo reboot

Now the WiFi will be turned off with the restart, and your LAN should provide the necessary connection. If you still have no connection, instead, we can then try different solutions.

Hi. I’m having the same issue. I cannotseem to change DNS settings. After restart it will still revert to even if set to static.

I haven’t yet tried but I’m sure that will work, is the command similar for lan? I want to move it somewhere not near a lan cable, even though I could run one at some point.

As for the DNS settings, I was able to change the lan on the first page but it seems a bit finicky with restarting and applying the settings.

@Rich2871 If you disconnect the LAN cable (and operate via WiFi only) the system will disable the LAN connection automatically and move forward from there.

@benoxph Welcome to our community!

Could you please download and post the logs from your Shake, so that I can take a more in-depth look? Instructions on how to do so are here: Please read before posting!

Thank you.


Thank you for your reply. I got it connected by setting static network details following this link
Thanks again :slight_smile:




Excellent, thank you fir the link too! Like seeing the ssh commands and online manual


Thank you both!

And happy to hear that the Shakes are working! Enjoy!

I just turned the WiFi off, as you mentioned, and it is connecting via LAN. I am able to see the live data on shakenet now with only using the lan :slight_smile: