No Browser access to rshake

I have issues with my rshake
what I can is:

  • see my station over stationview “RA78B” and see data (including live streaming and 24h plot)
  • ftp to rshake and off load data
  • ssh to rshake and login as user myshake
  • use browser to access rs.local/heli to get list of helicorders

What I not can is:

  • access any of the helicorders (gives rs.local refused to connect)
  • access rs.local (gives first only the initial page with connection not connected, followed immediately with popup “Raspberry shake is down,” which is not correct as rshake generates and sends data, and I’m connected to)
    Obviously I cannot press the download logfile button as popup inhibits this.

Any suggestion?

Hello wmxz, welcome to our community.

Thank you for the detailed report. Have you tried to access the Shake local page via the IP address that your modem/router has assigned to the Shake itself?

You can find it with the app Fing, as illustrated in this post: Please read before posting!

Does the popup “Shake is down” (which is quite strange, I admit) still appear?

Regarding the logs, if you can SSH into the Shake, could you please copy the entire content of the folder /opt/log, zip it, and attach it to your answer? These are all the files I need to get a deeper look into what could be causing this.

Thank you.

OK, attached the log zip file (I hope)
Yes independent of using IP address or rs.local, the web browser (edge Win11) opens the connection (I get the overall frame) but then when filling out the content, the popup shows up saying the rshake is down. (361.3 KB)

Thank you for the logs, they were exactly what I needed.

I assume that you have already tried, but have you tested if other browsers (even in incognito mode) are displaying the same popup, preventing access to the Shake rs.local/ page?

The logs appear absolutely fine, and the Shake is currently connected and uploading live data to our servers, so the issue must be somewhere else.

Just to crosscheck, could I please ask you to shut down both the Shake and your modem/router, start the modem/router again, wait for it to regain internet connection, turn on the Shake, wait for ~30 minutes from this point, download the logs and send them to me again?

I want to check if, after a fresh start from both units, there are some changes compared to what I have available now.

Thank you for your cooperation.

OK, I got some time and installed Firefox.
With Firefox is is working correctly but not with Edge
(I just updated to latest Version: Version 103.0.1264.49 (Official build) (64-bit), but still the same)
Windows 11 V21H2 : OS build 22000.739

1 Like

Just as an experiment, I tried using Edge (I have never used it, always use Chrome/FireFox) on Windows 10.

All the other pages (Helicorder etc.) work fine too.

No real idea what is going on with your Edge browser … this sort of thing is why I try to avoid using Windows if at all possible…

1 Like

Never had an issue with Windows and I have my Rshakes since they I got a kickstarter one.

1 Like

Well, looks like you just got your first :slight_smile:

Yes that was 2016, but I lost contact (not the Rshakes), when they changed the discussion forum.

Happy to hear that!

I am not aware of other reports where Edge is causing this issue, but now that we have your feedback, I can make a note to remember this and advise using a different browser as a test.

If you have any other issues, you know where to find us.