My 1D not seen on line

You are right my Shake doesn’t seem to b e working. I did the usual power off, wait, power on no effect .It normally has 2 lights, one blue continuous on, one green flashing. its now has the blue, the green has turned yellow and an adjacent red is now on.

Hello BillR, welcome to the community!

From what you describe about the behaviour of the Shake, it seems that something has happened that is preventing the station from properly turning on and working as it should.

Have you tried to see if you can connect to the rs.local/ configuration page? If so, could you post the logs from the Shake itself, as explained here? Please read before posting!

Thank you.

If instead the page is not accessible, you can try to check if the power supply is still providing the required between 5.0V and 5.2V and 2.5A, maybe switching it with another one that you have around.

The last resort is to re-burn your microSD card. These are the instructions on how to do so:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Hi, thanks for the response and apologies for my delay in responding.
I haven’t been able to get into the system to access the log page.
Supply voltage as measured on GPIO pins is 5.29 Volts, and the two pics show which lights come on. With the shake sub board hanging then applying power red light comes on immediately, and green light flashes yellow couple of times then goes out.

It’s no issue BillR, thanks for getting back to me.

Sorry to ask, but since you didn’t mention it on your last message, have you tried to re-burn the microSD card with the instructions provided in my post here My 1D not seen on line - #2 by Stormchaser?

If not, then please try to see if this solves the issue, and the problem was caused by some corrupted file in the SD card itself.

If you, instead, have already tried this, can you try to see if the Shake appears, when connected to your LAN, in the list of the devices from your modem/router admin panel? Or, can you find it with an app like Fing ( )?

If Fing manages to find them, can you try to connect to the unit using its IP address?

Oh, I thought I had covered that.
No, the Shake does not appear on Fing. It used to though.
My SD card is only 8Gb. Now might be a good time to upgrade!
Now, do I need another pi to get into the system to set up a new SD card?

Hello BillR,

Thank you for confirming that, it is what I had in mind. Then, yes, a good microSD re-burn could be what you need to start from a new Shake OS installation.

You can still use the 8GB card that you received with the Shake, or you can upgrade it to a 16GB commercial-grade (MLC) or industrial-grade (SLC) microSD card.

No, while you could use another Pi, you simply need any computer and an adaptor that will allow you to read/write microSD cards on that computer. They can be easily found in any store or online, maybe you already have one at home!

Once you have that, follow the instructions in my post (My 1D not seen on line - #2 by Stormchaser) and, hopefully, everything will go back to normal once you restart the Shake with the new system on.

Right. I obtaine a new ssd card, formatted it then loaded all the files from the download as per the instructions.
Put it in the pi, plugged in the lan cable then the power and it looked good.BUT. The red light is still on, and Fing says it knows the pi is there but it is off line.
Pretty much the same fault.
Should the pi have a MAC address ?
Over to you Red Leader!

Ah, following on from my last email.
Since the same fault exists after loading new software into a new SD card. It looks like the fault might lie in the pi itself.
Now, I do have a pi 3B, but the shake runs off a pi 2.
So, are the two versions of the pi compatible, or do I have to seek out a pi 2?
Any ideas on this given that I think I read somewhere that programs for a pi2 were not suitable for a pi 3B.

Honoured to be Red Leader Bill!

Yes, since the problem seem to be exactly the same, it may be worth to change the Pi board with a newer (or just a different) one.

Our Shake OS, that you have put on the microSD card, is compatible with most of the Raspberry Pi 3 boards. To check if what you have is all right, you can sort through the list in our manual: Technical Specifications — Instructions on Setting Up Your Raspberry Shake

Also, Pi 3B+ and Pi 4 boards are compatible too, so you shouldn’t have issues in finding a new one to use!

Hi Stormchaser, small disaster.
I put the newly programmed SD card into the new pi3B.
Disconnected all the leads and daughter board from the pi2 in the shake,
then installed them on the 3B, being careful not to Stuff it up. Internet connected, powered up.
Blue light then red light. No sign of activity on the green/yellow light.
Does the 3B have the green/yellow light?
So it would appear that the only things left are:-
The daughter board, or the geo phone or the interconnecting cable(unlikeliest?)
Not sure where to go from here.
Any ideas?

I have just discovered, with aid of a magnifying glass, that the shake had a pi 3B version 1.2.
If that helps.

Hello Bill,

Yes, every Pi board (except for the Pi Zero and similar) will have a LAN port with the green/orange lights. The fact that the red and blue lights are on is a good sign since it means that both the Pi board and the Shake board are powered up, but the lack of other lights is an issue.

If they are not working, as you described, you can try again re-burning the microSD card and then try to start the Shake with the newly fresh microSD, or you can do the following to verify that the Pi board is working properly:

  1. Disconnect it from the blue Shake board
  2. Burn the microSD card with the latest Raspberry Pi software (you can find it here:
  3. Once done, connect power, internet, keyboard and mouse, and a monitor, and see if the Raspberry OS boots up well and if you can navigate in internet.

If yes, then the Pi board is working as expected, and it is possible that the blue Shake board will have to be replaced then. But, before we come to this, let’s try these two procedures and see what comes out.

Hi I seem to have lost your last email. Probably because I have upgraded to an iPad Pro.
However, I do believe that the pi is OK because, I removed the shake SDcard and replaced it with a NOOBS card.
I was unable to get my monitor to work but when powered up the system booted, then the green light flashed intermittently which indicates that the pi was communicating with my internet. I was also able to see the pi on Fing.
So, this seems to suggest that the fault lies in either the geophone or it’s interface board. How to determine which?

Hello Bill,

All right, even without a monitor if the green light on the Pi was flashing we can assume that the OS on the NOOBS card was working.

The output of the geophone is in volts, so it is possible to test if it is in working conditions with a multimeter by measuring its output at the two contact points where the cables are connected.

However, I would suggest (as it has happened twice or thrice, maybe more) to re-burn again the microSD card with a fresh installation of the Shake OS and make another try at turning on the Shake. Sometimes, it has worked in getting everything booting again.

Hi storm chaser, now I’m completely baffled.
Shake OS renewed after doing a scrub and reformat of thE SD card.
No effect. Blu and red light ON.
Green lights under Internet sky flashing green, and Green light near Red also flashing Green.
Geophone voltage “0” V dc.
Swapped to Pi 3B+.
0Vdc on Geophone

Red and Blue lights ON, Light near RED, flashing Green, Light near Internet sky flashing Yellow!
Why would an apparently stuffed Geophone affect Internet?
Oh, voltage measured with a HIOKII Electronic multimeter Analogu type.
Maybe the colour of the. Light under the internet sky is a red herring!
Perhaps a replacement Geophone interface board is required.

Hello BillR,

Thank you for the feedback and all the details. The fact that we have more lights working seemed to be a good sign, because the green one near the read one means that the OS is being loaded and running, and the network ones also were good.

Have you tried to connect to rs.local or to the IP address of the Shake when, in the first case you described, the

Green lights under Internet sky flashing green, and Green light near Red also flashing Green.

or, was the Shake still invisible in your network?

Hi, the Shake is invisible to the network, even though Fing knows it is there but is identified as being off-line and hence is greyed out.
I am puzzled though, how could a possibly dead Geophone disrupt the internet access?
AND, how come the Geophone which is a coil on a spring surrounding a permanent magnet be labelled with a + sign which implies DC? Surely when the Geophone gets a thump, the coil bounces on it’s spring and produces an evanescent, essentially AC signal.
Incidentally, I plugged the Shake into my modem via the cable I normally use reliably with a computer. I.e. It is a reliable connection.
So, I’m not at all sure where to go from here. A circuit diagram might help!

Hello BillR,

Thank you again for the feedback, it gave me a better understanding of your situation. All right, what we can do now is the following.

  1. Turn off the Shake and let it stay like that for half an hour (if it’s already off, all the better).
  2. With the last Shake OS burned microSD card in, turn the Shake on and let it run for an hour or two, no matter which lights are on or off.
  3. Once this time has passed, please turn the Shake off again, and extract the microSD card.
  4. Insert the microSD card (via an adaptor) in a computer, and copy the following two folders: /opt/log and /var/log. Paste them anywhere on your PC.
  5. Now zip everything you have downloaded together, and please attach it to your next answer.

These files will contain all the logs that the Shake has recorded. It is possible that, after trying all the other solutions, they could give us further insight on what is not working as it should and why the Shake remains unconnected and invisible in your local network.

Thank you for your assistance and time.

Hi, I can’t find anything even vaguely like either of these files. Don’t forget, the Shake has not been running since I installed the new op sys.

Thank you BillR, it was nonetheless worth a try.

Unfortunately, we cannot do anything else from remote, so, if you want, you can send your Shake back to us to be checked and we will send you a replacement one in the meantime. You can write to to organize this with our sales team.

Otherwise, you can try acquiring a new board+geophone sensor from the shop, and hope that that was the cause of the issue (which seems still strange, but it could be).