Gpsd missing, not started at boot

Hi Richard,

I have received the new GPS antenna, thanks !

I connected it today : the serial port was recognized immediately. /dev/ttyUSB0 was present.
I restarted ntpq, but I had a problem with gpsd daemon : gpsd is missing !
I started gpsd manually, and it recognized GPS informations.
gpsd is not started at boot, but I don’t know why…


RSH.RC78F.2020-02-03T04_46_02.logs.tar (3.8 MB)
logfic logfic2 logfic3

We are aware of this problem and it will be fixed in the next release, which will be out soon. In the meantime, you can edit the file /lib/systemd/system/gpsd.socket and comment out the following line like so:


Then reboot. After a minute or so the GPS will lock satellite signals and ntpq will adopt it as its preferred source.

2020-02-03: edited to refer to the correct file, not a link to the file

Hi All,

We passed by this same issue here and after several time testing and trying to figure out what could be the problem we found out that this happened after the automatic update of the system from 0.15 to 0.16 version.

Then, we discovery that in the /etc/sysctl.conf were introduced two lines in the end. There, we changed the values from 1 to zero. I thing this could be just commented, but I not sure…


After that, we reinstalled with the command sudo gpsd-mgr -i and rebooted the system.

Well, this was enough to make the GPS be used by the system again.

Best regards,

hi darlan,

your solution will fix the problem, but the reason this was modified in v0.16 was to fix another problem when assigning multiple units on the same subnet to rs.local, rs-2.local, …; where the assignments could change due to a startup timing issue difference between ipv4 and ipv6. so, ipv6 was disabled and inadvertently made gpsd program fail to start.

version v0.17 (released as a hot-fix to address a few issues introduced in v0.16) will correct the gpsd problem using the solution described by ian. if you have more than one unit, you will want to revert your sysctl.conf file change to how this was modified in v0.16.

apologies for the inconvenience,


Hi Richard,

We would like to suggest add some field in the GUI informing the status of the GPS. This will be very userfull.

Thank you.


1 Like

hi darlan,

funny you should suggest this: this is currently in development.

stay tuned!


Hi Ian,

The line has been commented, and the system rebooted.
gpsd is now present, and the GPS time is correct (with cgps -s)
But ntpq ignore the GPS time, even after re-start.


Ok. Can you re-post your logs?

Hi Ian,
Here are the log files.

RSH.RC78F.2020-02-03T05_54_17.logs.tar (3.8 MB)

bonjour olivier,

from the log files, it looks like you have your unit plugged directly into a computer, in which case you probably want to turn on stand-alone mode. this can be done via the front-end configuration page ACTIONS::ACTIONS::Turn On Stand-Alone button. or, this can be done from the command line, a complete explanation and instructions to do this can be found here.

as it is, your unit is failing to start some services due to lack of a DNS server.

as for GPS, something is amiss, though i’m not quite sure what. can you send along the file /etc/default/gpsd, i’d like to see its contents. as well, please send the output from the following commands:

> sudo systemctl status gpsd.socket
> sudo systemctl status gpsd

thanks in advance,


Hi Richard,

I have change to stand-alone mode, and this is the same issue.
I send you the log of the two commands.
gpsd (159 Bytes)

RSH.RC78F.2020-02-03T06_19_08.logs.tar (3.8 MB)

Hi Oliver,

Can you send the output of rsh-stand-alone?


Hi Ian,



I’m a poor lonesome Shake
I’ve a long way from home…