GPS Configured But Not Connecting

#1

Hey all,

I have a (hopefully) simple question about the GPS module and NTP. So I have a RS 1D and the recommended GPS module and had previously booted it all up in the correct order and got the RS ostensibly getting its NTP from the GPS. I double checked with the ntpq -p command and it had the asterisk by the PPS and everything. My understanding was that now that that was all set, I could boot up my RS without being connected to the internet and it would just get its timing from the GPS from here forward.

However, that does not seem to be the case and when I rebooted the RS it started up as if it was being turned on without a connection (Case 1 from the NTP and GPS page of the RS manual) and resumed with the UTC time beginning from the time it was at when it shut down. Using the ntpq -p command again, I was able to see that while it is configured to see the GPS it is no longer being used for the time or is not connecting for some reason and the asterisk has vanished (see below for results of the ntpq -p command now).

Capture

So my question is essentially, why does the Raspberry Shake not automatically connect to the GPS when it has been previously set up and how do I remedy this for when the GPS may need to be rebooted or shut down in the field and I will not have a router to plug it back into?

Thanks so much for any and all help!

#2

hello,

when expected that the unit will not be connected to the internet, whether you have a GPS module connected or not, please put your unit into stand-alone mode, described here. (n.b. setting the time will not be necessary in this case.)

your suggestion that if a GPS module is connected then the unit should assume stand-alone mode will be considered. on the other hand, it is not universally true that if a GPS module is connected, the software should assume no connection to the internet; it is a perfectly valid scenario to be using a GPS clock while connected to the internet (and, for example, sending data to the server).

cheers,

richard

#3

Oh yeah, I totally get the use case for both, I wasn’t trying to suggest it should be standard. I was just confused because that page you linked explicitly says that it is not for users that have a GPS antenna so I did not consider it relevant. Either way, I’ve followed those instructions and rebooted the Shake and double checked and offline mode is now going, but it is still not picking up the accurate time from the GPS. Is there some other step that I’m missing? Thank you for the advice so far!

#4

Good morning.

If this problem still persists, please send along the log files.

Thank you!

Branden

#5

Hey branden,

Thanks for getting back to me! Yeah, unfortunately the problem is still persisting.

Here are the logs from today.

RSH.R7F0A.2019-06-30T13_15_46.logs.tar (1.6 MB)

I just left it running for an hour and a half or so, not sure if that impacts anything. Also just to communicate things that might play into this problem I’m having, this RS was originally booted up without connection to an internet source when I was just playing around with it, so maybe that has something to do with it? The first time it was directly connected to my router was when I was trying to set up the GPS antenna

Also, I again disabled stand-alone mode on it, which had been suggested as a solution above, because it did not seem to solve the problem. Additionally the page on the manual directly states, “This section of the manual is not for users who have an Internet connection or GPS antenna” which seems to apply to me. Can you advise whether or not it is supposed to be in stand-alone mode when using the GPS antenna?

Thanks for your help!

#6

@ivor Is this similar to Logging without network access - data missing? Let me know how the manual can be improved to clarify how to use the GPS antenna when the unit has no Internet connection.

branden

#7

@branden in my case I havent set up the RS with this yet: http://manual.raspberryshake.org/no-network.html

…but will give it a try.

Just to clarify: I don’t have a GPS antenna or anything, it’s just the plain RS1 that I put out in the field to collect data, then I bring it back in, connect via server and try to get the log data.

Thank you very much

#8

Just a quick confirmation: Are you using a GPS antenna purchased from Raspberry Shake?

branden

#9

Hi Branden. No I don’t have a GPS antenna. All I have is the RS1 with a powerbank that let’s me run it for a certain time outdoors. Is that necessary to log data offline or is there a way around it so that I can use it as a standalone logger the way I need to?

#10

This question was for @dbehrens17.

Yes, it is. I had sent an email to Becky with you in Cc: on June 20th, “Please quote again with the external USB connection and GPS antenna. Claudio will be using the Shake in “offline” (no Internet) mode so he will need the GPS antenna for timing.”

:slight_smile:

branden

#11

Hey branden,

Yep, I am using a GPS purchased from you guys, it actually came bundled in the same package with the Shake itself.

I’ll keep playing around with stuff on my end and I’ll let you know if I accidentally fix it, but so far no dice unfortunately.

#12

Hey @branden

Just wanted to let you know I solved my problem by simply swapping out the SD card for another that I already had with the RS OS. Seems to be working fine now, not sure what was going on before. Thanks for all the help!

2 Likes
#13

GREAT NEWS! Thanks for reporting back.

branden