Error: rsudp failed to install

I have tried to install rsudp on an RS4D, what I do is:
Clon de Git https://github.com/raspishake/rsudp
CD RSUDP
bash unix-install-rsudp.sh

myshake@raspberryshake:/opt $ cd ..
myshake@raspberryshake:/ $ cd rsudp
myshake@raspberryshake:/rsudp $ bash unix-install.rsudp.sh
bash: unix-install.rsudp.sh: No such file or directory
myshake@raspberryshake:/rsudp $ bash unix-install-rsudp.sh
Looking for existing installation...
Found anaconda at /home/myshake/berryconda3
No rsudp environment found.
Starting install script.
--------------------------------------------
Raspberry Shake UDP client installer v0.2
Ian Nesbitt, Raspberry Shake S.A., 2019
--------------------------------------------
Please follow instructions in prompts.
Press Enter to continue...

This script will need to use or create a directory to store miniSEED data and screenshots.
Common choices might be /home/myshake/rsudp or /home/myshake/opt/rsudp
Where would you like the rsudp output directory to be located? You can use an existing one if you would like.
Press Enter when done (if no input is given, the script will use /home/myshake/rsudp):
/home/myshake/opt/rsudp
No directory was provided, using /home/myshake/rsudp
Using existing directory /home/myshake/rsudp
Looking for conda installation...
Anaconda installation found at /home/myshake/berryconda3
conda executable: /home/myshake/berryconda3/bin/conda
Source line already exists in /home/myshake/.bashrc
Sourcing...
Activating conda...
Found rpi channel in /home/myshake/.condarc
Found conda-forge channel in /home/myshake/.condarc
Creating and installing rsudp conda environment...
Solving environment: failed

PackagesNotFoundError: The following packages are not available from current channels:

  - matplotlib'[version='<3.2']

Current channels:

  - https://conda.anaconda.org/rpi/linux-armv7l
  - https://conda.anaconda.org/rpi/noarch
  - https://conda.anaconda.org/conda-forge/linux-armv7l
  - https://conda.anaconda.org/conda-forge/noarch

To search for alternate channels that may provide the conda package you're
looking for, navigate to

    https://anaconda.org

and use the search bar at the top of the page.


ERROR: rsudp failed to install.
---------------------------------
Something went wrong.
Check the error output and try again.

I see that there is an error in matplotlib and when I try to install it I do this:
sudo apt update
sudo apt install python3-matplotlib

myshake@raspberryshake:/rsudp $ sudo apt install python3-matplotlib
Reading package lists... Done
Building dependency tree
Reading state information... Done
python3-matplotlib is already the newest version (3.0.2-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up gpsd (3.17-7+b1) ...
Creating/updating gpsd user account...
Job for gpsd.socket failed.
See "systemctl status gpsd.socket" and "journalctl -xe" for details.
A dependency job for gpsd.service failed. See 'journalctl -xe' for details.
invoke-rc.d: initscript gpsd, action "start" failed.
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: inactive (dead)

Mar 24 02:33:03 raspberryshake systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Mar 24 02:33:03 raspberryshake systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Mar 24 13:41:33 raspberryshake systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Mar 24 13:41:33 raspberryshake systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Mar 24 13:44:20 raspberryshake systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Mar 24 13:44:20 raspberryshake systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Mar 24 13:45:55 raspberryshake systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Mar 24 13:45:55 raspberryshake systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
Mar 24 13:57:48 raspberryshake systemd[1]: Dependency failed for GPS (Global Positioning System) Daemon.
Mar 24 13:57:48 raspberryshake systemd[1]: gpsd.service: Job gpsd.service/start failed with result 'dependency'.
dpkg: error processing package gpsd (--configure):
 installed gpsd package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 gpsd
E: Sub-process /usr/bin/dpkg returned an error code (1)

If you check on GitHub - the “Issues” tag, you will see this has already been reported. Won’t do any harm to add your name to the reporters.

I did get it working by doing the sequence described in the installation document:

2.2.2. Advanced Users

Basically install conda, then use pip to install rsdup. You end up having to scratch around a bit to find the script to launch it … let me look …

This was the script I used to get it running:

bash ./bin/rsudp-1.1.0/unix-start-rsudp.sh

1 Like

I already tried all the errors by installing that, that’s why I opened another case.
The first thing I do is install the RS O.S, downloading the file from this link: raspberryShake-public / Raspshake Sd Img · GitLab

Then I pass this file to a 16GB class 10 formatted SD, I unzip the file and then I pass it to RS4D, I wait approximately 15 minutes, when it finishes and I can finally enter http://rs.local, where I configure and share the data.

I make my connection through SSH, I install miniconda3 from this link: Install Miniconda 3 on Raspberry Pi · GitHub

Later I do the video tutorial:
git clone https://gist.github.com/simoncos/a7ce35babeaf73f512be24135c0fbafb

cd rsudp
bash unix-install-rsudp.sh

It tells me that I have a miniconda error and that it cannot create the environment, then what I do:

conda create --name rsudp python=3.4.3 #Is the version that installs rsudp

This says that the address does not exist: /home/myshake/.config/rsudp/rsudp_settings.JSON

I create it manually:

cd /home/myshake
mkdir .config
cd .config
mkdir rsudp
cd rsudp
sudo nano rsudp_settings.JSON

And right there I copy this data:

{
"settings": {
    "port": 8888,
    "station": "Z0000",
    "output_dir": "/home/myshake",
    "debug": true},
"printdata": {
    "enabled": false},
"write": {
    "enabled": false,
    "channels": ["all"]},
"plot": {
    "enabled": true,
    "duration": 90,
    "spectrogram": true,
    "fullscreen": false,
    "kiosk": false,
    "eq_screenshots": false,
    "channels": ["all"],
    "deconvolve": true,
    "units": "CHAN"},
"forward": {
    "enabled": false,
    "address": ["192.168.1.254"],
    "port": [8888],
    "channels": ["all"],
    "fwd_data": true,
    "fwd_alarms": false},
"alert": {
    "enabled": true,
    "channel": "HZ",
    "sta": 6,
    "lta": 30,
    "threshold": 3.95,
    "reset": 0.9,
    "highpass": 0.8,
    "lowpass": 9,
    "deconvolve": false,
    "units": "VEL"},
"alertsound": {
    "enabled": false,
    "mp3file": "doorbell"},
"custom": {
    "enabled": false,
    "codefile": "n/a",
    "win_override": false},
"tweets": {
    "enabled": false,
    "tweet_images": true,
    "api_key": "n/a",
    "api_secret": "n/a",
    "access_token": "n/a",
    "access_secret": "n/a",
    "extra_text": ""},
"telegram": {
    "enabled": false,
    "send_images": true,
    "token": "n/a",
    "chat_id": "n/a",
    "extra_text": ""},
"rsam": {
    "enabled": false,
    "quiet": true,
    "fwaddr": "192.168.1.254",
    "fwport": 8887,
    "fwformat": "LITE",
    "channel": "HZ",
    "interval": 10,
    "deconvolve": false,
    "units": "VEL"}
}

From there I try the command again:

cd rsudp
bash unix-install-rsudp.sh

Then I have errors with gpsd and saw that error is fixed by what stormchaser says here: Gpsd missing, not started at boot

#ListenStream=[::1]:2947

Then I no longer get errors, until almost at the end, it says that scipy is missing something, I fix it, and it shows me the same thing but with another code, I saw that it is not compiled and that is why I have error after error, try:

python3 -m pip install scipy
udo apt-get install gfortran

and it got to a point where it got stuck running pcipy from wheels.

The only other thing I can suggest was that I ensured that everything was completely deleted from the previous failed install(s) before following the manual install path.

I should probably also mention that after playing with it for a few days, I have never fired it up again…
But that is just me. Much too much python for my liking. Been bitten by python one too many times to want to play with it again.

1 Like