Connection Issue : Not Connected

Ive seen the DNS server tab cause some issues for my shake Even on a home network, Just a little tip as it seems it chose the Incorrect DNS as i think my router has it on Dynamic Mode

2 Likes

Using Home Network


RSH.R7C21.2024-03-15T10_37_26.logs.tar (759.5 KB)

3 Likes


School Network

3 Likes

Thank you for the two separate tests, Refrain.

They confirm what I was thinking: something is still clearly blocking Shake from accessing our servers from the School Network.

Could you try to ping, from the School Network, a standard server like Google with ping 8.8.8.8?

1 Like


ping 8.8.8.8 form school network

2 Likes

In case you might be wondering, the school network has static IP address 222.127.31.237

3 Likes

RSH.R7C21.2024-03-16T08_46_28.logs.tar (702.5 KB)
Latest logs, connected to school network

3 Likes

Thank you again for the new test and the updated logs Refrain.

Both confirm that, while the Shake is unblocked from general internet access (proven by the successful Google ping and time server connection), something is still blocking transmission to our server.

I would go back to your IT department, present these results (even ask them to replicate the issue so that they can see it with their eyes), and ask them to unblock the connection to 144.91.66.87, particularly on ports 55555 and 55556 on [TCP].

It is possible that exceptions have to be added to the School firewall for this, as it has already happened in other similar cases. Until you ping and zc commands from the School network output the same result that is shown from the home network, there is still something interfering with data transmission to the Shake network.

Thank you again for your collaboration.

1 Like

I am having a similar issue. Our RS3Ds stopped being connected yesterday around 11:45 UTC. There was no change in the firewall rules of our 4G router. Our raspberries are accessible through http, I can ping 8.8.8.8 from one of our raspberries, but when I try the command
myshake@raspberryshake:/opt $ nc -zvw5 144.91.66.87 55555
I get
nc: connect to 144.91.66.87 port 55555 (tcp) failed: Connection refused

I would be grateful if anyone could help us out.
Thank you very much.

1 Like

Hello kostantinos,

The test output of that command, nc -zvw5 144.91.66.87 55555, indicates that, for some reason, the port 55555 appears to be closed to TCP traffic now, and thus the Shake doesn’t manage to transmit data.

This has happened on a couple of occasions in the past, where IPs would close this port (and the associate 55556) due to the data traffic on those. I recommend checking your router settings and then opening those ports anew. Once done, the result of the command above should return positive, and the Shake should start transmitting data again.

Also, when you can, could you please collect all the files inside the folder /opt/log, zip them, and send them to me? I would like to have the complete set of logs so that I can have a broader perspective on what is possibly going on.

Thank you!

1 Like

Dear Stormchaser,

Thank you very much!
I am sending the zip file.

Thanks once more.
I appreciate it very much.

1 Like

We called the IP, they said that there was no port blocking on their side, but that they would look into this and get back to us. In the mean time, I did again
nc -zvw5 144.91.66.87 55555
and this time the port was open.
Right after, the IP called us and said that they did not find any blocking on their side.
Now, our Shakes are connected and transmitting.

1 Like

Hello kostantinos,

No problem at all; you’re more than welcome.

It seems that something was indeed done, as the Shake is now transmitting without issues. In any case, if that command (for any reason) comes back as negative again, then you can focus directly on a port issue.

Thank you also for the full logs in your previous message!

1 Like

Thank you once more! Much appreciated!

2 Likes

Hello,
We are having again connection issues.
The commands nc -zvw5 144.91.66.87 55555, nc -zvw5 144.91.66.87 55556, both tell us that they succeeded.
How could we figure out why we are having this issue?
Thank you very much

1 Like

Hello kostantinos,

Could you please:

  1. Shut down the Shake
  2. Disconnect power and LAN cables, wait for 5 minutes
  3. Reconnect LAN and power cables (in this order) and turn on the Shake again
  4. Wait for ~30 minutes, download the logs from the Shake (if needed, instructions here: Please read before posting!) and attach them to your next answer?

They will help in checking what is going on in more detail.

Thank you!

1 Like

Hello Stromchaser,

The problem I mentioned in my previous post went away without us knowing why.

Currently our shakes are Not Connected:
|Data Producer|:|ON|
|Data Consumer|:|ON|
|Off-line Mode|:|OFF|
|Data Forwarding|:|ON|
|Server Connection|:|Not Connected|

We can ping 144.91.66.87, but the ports 55555-55556 seem to be closed
myshake@raspberryshake:/opt $ nc -zvw5 144.91.66.87 55555
nc: connect to 144.91.66.87 port 55555 (tcp) timed out: Operation now in progress
myshake@raspberryshake:/opt $ nc -zvw5 144.91.66.87 55556
nc: connect to 144.91.66.87 port 55556 (tcp) timed out: Operation now in progress

There was not change of the configuration on our devices. The ISP says these ports related to the IP of our device are open on their network.

Therefore, I would like to ask your help.
Thank you very much once more.

logs (2.9 MB)

1 Like

Hello konstantinos,

Thank you for the new details and the logs from the Shake. It seems that, at first, the Shake cannot find any internet connection:

2024 165 07:13:06: Network detection failed, unable to curl or ping common sites
2024 165 07:13:06: No internet connection found
2024 165 07:13:17: Network detection failed, unable to curl or ping common sites
2024 165 07:13:20: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

However, this seems to solve itself later, as the Shake can find a NTP server for time synchronization without further hassles.

From the results of your port test, it appears that ports 55555 and 55556 are closed. Have you checked if, for any reason, your router configuration has been reset or if the ports have been closed by whatever protocol the router has (there was a case like this in the past)?

Have you also tried turning off the Shake, restarting the router, and then turning on the Shake again to see if anything changes?

As a last resort, you could try to bring your router back to factory settings (there should be a way to do so via the admin panel) and then re-add the port exceptions to see if they now remain.

1 Like

Dear Stormchaser,

Thank you very much for your help.

The router still has the same settings as when the Shake was connected. The router is also programmed to reboot automatically a few times per day. Moreover, I have manually rebooted the Shake (through its web interface) a few times over the last few days, but it remains Not Connected.

Somehow, today, I get this
myshake@raspberryshake:/opt $ nc -zvw5 144.91.66.87 55555
Connection to 144.91.66.87 55555 port [tcp/] succeeded!
myshake@raspberryshake:/opt $ nc -zvw5 144.91.66.87 55556
Connection to 144.91.66.87 55556 port [tcp/
] succeeded!

It is difficult to find out what closes and opens these ports. Perhaps there are parts of the network between the Shake and the server that are out of the control of the ISP.

Also, the router often loses the mobile internet connection. Perhaps we can assume that this is why the log has that entry.

Would you recommend programming our Shakes to reboot automatically? Would this help?

Thanks once more.

We appreciate very much your support.

2 Likes

Hello konstantinos,

Yes, the situation appears quite erratic, which generates the service connection discontinuities that you are seeing.

I think that the loss of mobile internet connection you describe could be the reason the ports are “closing” and “opening” again. You could also set up the Shake to reboot daily, and see if this fixes your problem. Here’s a guide on how to do it:

To use a more familiar crontab editor in sudo, execute this after logging into the Shake:

sudo EDITOR=nano crontab -e

You will then get an empty file; this is OK. Copy and paste the following (after copying, a single right-click on the black screen should be enough):

0 2 * * * /sbin/shutdown -r now

Then save and exit the crontab editor with Ctrl+X , then Y to confirm, and finally Enter .

To check that the crontab has been modified successfully, you can see its contents with:

sudo crontab -l

Also, in case you’re not familiar with cronjob syntax, here’s a summarized explanation:

Each part has a specific meanig, allowing you to schedule tasks on a recurring basis.

  1. 0 2 * * * - This part of the line specifies when the cron job will run.
  • 0 - Minute (0-59)
  • 2 - Hour (0-23, where 2 refers to 2 AM)
  • * - Day of the month (1-31)
  • * - Month (1-12)
  • * - Day of the week (0-7, where both 0 and 7 represent Sunday)
  1. /sbin/shutdown - This is the command that is being scheduled.
  2. -r - This is an option for the shutdown command and it stands for reboot.
  3. now specifies that the shutdown and reboot should happen immediately.

So, the entire line 0 2 * * * /sbin/shutdown -r now schedules a reboot at 2 AM every day.