Connecting two RP Shakes to the same router

Hi all,

Just a quick question. Is it possible to connect an RPi Shake 3D and an RPi Shake & Boom to the same router and have them both record and display data? Presumably the second unit that is added will be detected and given new ID and be independently configurable.

Thanks & regards

1 Like

Hello Steve, and welcome back to the community!

You surely can connect more than one Shake to the same router, there is no issue about that. I have four here (all different models), and they all work fine.

You have two possible options regarding having multiple shakes connected to the same local network. They both will record, display, and stream data as usual.

The first is to access them via their different IP addresses (you can read those via the admin panel of your router, or via the Fing App (Fing App | Network toolkit and scanner | Fing ); just write those into the address bar of your browser instead of rs.local/, and you will be set.

Otherwise, the first Shake connected to the network will always be rs.local/, then the second will be rs-2.local/, the third rs-3.local/ and so on.

You can choose what method is the best/easiest for you to access your Shakes.
If you have any other questions, I remain available.


Many thanks Stormchaser.
I am now up and running with both units.


You’re more than welcome Steve, happy to help!

I made some small changes to my Shake 3D and Shake & Boom installations recently (the only thing I did was to extend the power cables for both Pi’s. No other changes were made.)
On reconnecting everything, ony the Shake 3D appears to be working. The Shake & Boom says not connected. Both IP addresses have been checked with the Fing app. Network connection to the S&B have been checked too.

Any idesa why the S&B is not connected?


1 Like

Hello Steve,

Could you please download the logs from both Shakes (instructions can be found here, if needed: Please read before posting! ) and post them here?

They will give me a more in-depth insight into what is possibly going on.

Thank you.

Hello Stormchaser,

Attached are the logs for both instruments

RSH.RAB7B.2023-09-26T14_39_35.logs.tar (2.8 MB)
RSH.R78B1.2023-09-26T14_37_10.logs.tar (2.7 MB)

1 Like

Hello Steve,

Thank you for the logs from both units. It is an unusual situation for sure, as the configuration for both is exactly the same, so the different behavior is confusing, as you said.

Could I ask you to do the following only for the Shake that is not currently connecting?

  1. shut down both the Shake and your modem/router
  2. disconnect the Shake power and LAN cables
  3. start the modem/router again and wait for it to regain internet connection
  4. reconnect the Shake power and LAN cables (try the LAN cable to a different port on the modem/router)
  5. turn the Shake on again
  6. wait for two/three hours, download the new logs and send them here?

I would like to have freshly started Shake logs to compare with the logs you’ve just sent me.
Thank you!

Hello Stormchaser,

Here are the log files for the two Shakes after shutdown and restart, per your instructions…

I also changed the LAN ports as you instructed.

Both devices are connected to a wifi extender that Fing identifies as a tri-band wifi mesh extender. Both devices have been connected in this way for the past few months, without any connection issues.

And, as we know, the Shake 3D is connected and still working normally with this configuration. So I think we can rule out any problems associated with a wifi extender (just in case you were wondering…)

Thanks for the continuing support

RSH.R78B1.2023-09-30T11_21_34.logs.tar (2.7 MB)
RSH.RAB7B.2023-09-30T11_25_57.logs.tar (2.9 MB)

1 Like

Hello Steve,

No problem at all; here to help!

Thank you again for providing the new logs (and taking the time to go through my bullet point list) anbd also for checking the mesh extender operations. The situation is a bit baffling because:

  • Both Shakes boot up normally, without any issues.
  • Both Shakes manage to find an internet connection, and synchronize their clocks
  • Both Shakes manage to see our data server

However, only RAB7B displays this message 2023 273 08:01:43>> Connection attempt #1 ( failed with error code: No route to host together with other errors.

Could you check if the new power supply cable is delivering the required 5.0V to 5.2V DC and at least 2.5A for Raspberry Pi 3B models, and 3.0A for the 4B models? Maybe if you revert to the old power supply cable (or use another power supply adapter you have around) you can do an easier check?

If this comes out as positive, and the Shake is receiving all the power it needs, then at this point, I would recommend a microSD card re-burn to remove the possibility that some corrupted file is causing this for RAB7B. I’ll leave the burn instructions here for your convenience:

Thank you again for your collaboration.

Thanks for your continued support Stormchaser. I am currently absent for the next few days but I will try these recommendations next week upon my return.

Will let you know the results afterwards.



You’re more than welcome Steve!

HI Stormchaser,

Problem solved! The power supply cables were all delivering correct voltages and current, as I expected.

I burnt a new SD card according to your instructions, this time using a 32GB card. (Previously, when I purchased the Shake&Boom several years ago, it came with an 8GB card.) But it was working fine with that capacity of card.

Only conclusion is that there must have been a corruted file(s) somewhere.

Thanks for all the support.

Best regards


Hello Steve,

At this point, yes, there definitely was something that was solved by the re-burn.

In any case, happy to hear that both of your Shakes are now working as they should!
You’re welcome!