Connecting to network

Hello,

I recently had to reimage my SD card due to problems with the shake. Now, the settings and other items seems to be working correctly, but it will not connect to the network. I tried resetting the Shake and the modem; made sure that the stand alone is set to OFF; and tried some of the DNS and IP settings I saw in other help forums on this topic. The latest log file is attached. What can I try next to fix this problem?RSH.R417B.2021-01-20T03 16 20.logs.tar (132 KB)

Hello EB1,

Thank you for the logs. From them, it appears that even you input the DNS address ‘8.8.8.8’, this is not getting a connection to our servers. These lines make the issue clear:

2021 020 02:59:11: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2021 020 02:59:11: No internet connection found
2021 020 02:59:22: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

Since restarting the Shake and the modem/router hasn’t worked, then please shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

After checking this (sometimes the modems close them without prompting) and opening the ports, if needed, please start your Shake, wait for around 10 minutes and then let’s check that your unit can reach our servers. Can you SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) and try and ping the following addresses?

  • ping 8.8.8.8 -c 10
  • ping 104.200.16.60 -c 10

The first one is the Google server (which seems to not work, so it will probably give you a bad result) while the second is our data server. The two commands will execute the exchange ten times, and your expected result is a 0% packet loss for at least the last instance.

I’ll wait for you to try this before going forward.

Thank you. I am traveling now through Saturday but will check this workflow as soon as I return.

1 Like

You’re welcome, no hurry at all.

Both servers shows as unreachable. Please see attached screenshot. The ports are open.

What shall I try next?

2021-01-26_15-53-08.jpg

hello,

i see in your output that the IP address is 169.254.236.186. this is typically the IP address range assigned to a computer when it is connected directly to another computer.

however, in the log file myshake.out file contained in the log files you provided in your orignal post, the IP address assigned to the Shake is 192.168.0.17, which is a typical IP address assigned by a router to a device connected to it.

would you happen to know what could explain this difference in IP addresses? to be clear, when connecting the Shake Pi directly to a computer, you will definitely not be able to gain access to the internet at large, this will not work.

cheers, hope this helps,

richard

Interesting.

The shake is not connected directly to the computer. The shake is connected to the internet with the following adapter using an ethernet cable: https://www.amazon.com/gp/product/B06WP2ZT5N/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1 My computer is connect via wifi.

I’ve attached the current log file.

Is there anything else I can do to get up and running again? As mentioned, the shake was working on the network before I updated the SD card with the new image. So something about that update fixed one problem (that I couldn’t update its location) but caused the current problem (that it won’t connect to the servers). Nothing else in the configuration has changed, including the connection described above.

Esther

RSH.R417B.2021-01-24T17 06 25.logs.tar (1.38 MB)

Also I just noticed that the system time is off by 3 days.

hi esther,

this explains the 169 address, which is the address of the adapter. what i now think is happening (or not, as the case may be) is that the adapter itself no longer has a connection to the internet.

i’m not sure how this is done, but you should try to confirm that the adapter is connected to the internet. if it isn’t, what you are seeing with the Shake is exactly what would happen.

another test, in regards to confirming the Shake software, is to connect the Shake to your router directly using a direct ethernet cable and reboot the Shake. when your router is able to access the internet, the Shake will also have access.

and, the reason your Shake’s clock is off is exactly because it has not been able to connect to an NTP server. once internet access is again working, the clock will be reset to the correct time.

let me know your findings,
richard

1 Like

The shake still does not connect when connected directly to the router using an ethernet cable and rebooted. Same problem.

I have tested and confirmed the adapter is for sure connected to the internet.

Any new ideas?

hi,

can i get the logs again after you connected it to the router directly, please.

and can you detail the test you made to confirm the adapter itself is connected to the internet?

thanks,

richard

It is currently connect to the router, and here are the log files.

Testing the adapter:

  1. Turned the wifi on my laptop off, plugged the laptop into the same ethernet port on the adapter as the Shake was, with the same cable, and the laptop was connected to the internet via the ethernet cable.
  2. The wifi on the Shake is off, so I would not be connected to the Shake if the adapter weren’t working, ie the Shake must be on my local network using the adapter since I can control it via my computer which on the network via wifi. I also changed my computer to a different network than the adapter is on, and confirmed that I was no longer able to connect to the Shake.

Thank you!

RSH.R417B.2021-01-24T19 48 40.logs.tar (1.42 MB)

hello,

with the shake connected directly to the router, please try the ping commands again. and this time try to ping google using the machine name:

> ping google.com

this will tell us if the DNS functionality is working as well.

i am going to guess that this will again fail, and that the problem is not the adapter, but that traffic is not making it off the router itself.

thanks for your perseverance, we will figure this out,

richard

With the shake connected directly to router:

For “ping google.com” I get “temporary failure in name resolution”

For “ping 104.200.16.60 I get “Destination Host Unreachable.”

Thank you for the encouragement and help!

hi,

so, this means that traffic off the router, originating from the Shake Pi computer, is not making it to the outside. nor is the DNS server specified, 8.8.8.8 (google), is also inaccessible.

next test would logically be:

  1. can you plug a different computer into the same router, using an ethernet connection, and run the same commands from a command line?

if this isn’t possible, another test would be to plug the Shake Pi into a different router, one you know is connecting successfully to the internet-at-large, and run the same test commands there.

to be clear: there is no configuration on the Shake Pi that disallows connection to the internet through a router. these tests, so far, have confirmed that communications off the Pi are successful (original ping through the adapter returned the address of the adapter). not to mention that you are able to remotely log in to it, communications rarely are permissioned to happen only one-way.

without being there myself, i can’t absolutely say since i am not privy to your entire network’s setup and configuration details, but my conclusion at this point is that traffic off the router to the WAN is not working. on the other hand, this seems unlikely since i will also assume you have other devices using this same router to access the internet, and those other devices are not suffering this problem?

try the other tests, make certain to use a router you know accesses the internet okay, and let us know the outcome.

cheers,
richard

Yes, I plugged my computer into the same router with the same ethernet cable and ran the commands successfully with 0% loss. Also, yes, traffic must necessarily be working off the router to the WAN since my other devices on this router are connected to the internet just fine.

So this seems to narrow down the problem to the Shake. Any more ideas for troubleshooting?

hi,

thanks for the info, as i thought.

since the connection to the router works fine, i’m still not sure it can be attributed to the shake. the only time i’ve ever seen this is when the device has been expressly forbidden by the router itself to communicate to the outside. i will have another set of eyes look at this and get back to you.

and i’m not sure it’s possible, but if trying this with a different router is an option, this test would remove the router from the list as the possible culprit. annoying as it is, the sources of some problems can only be found through a process of elimination of possibilities.

richard

I just tried the shake with a different router – same response, “destination host unreachable.” The new router tested good with the computer.

I totally get troubleshooting through elimination! No problem. Just hope we can solve it in the end.

Hi

Could you post the contents of the following files here:

  • /etc/resolv.conf
  • /etc/dhcpcd.conf

Also the output of the following command:
traceroute 8.8.8.8

These could help with the figuring out what’s going on.

Thank you.

New problem – when I tried to use Putty to access the shake, I keep getting “access denied.” I have not changed anything since the last time I logged in to it a few days ago. I’m relatively certain I’m not doing anything different, and of course there’s always the chance I’m screwing up. What should I do though – is there a way to reset the login? I rebooted the shake a couple times with the same result.