Wireless Raspberry Shake

Hello, I have a question how can I insert the IP and DNS to have my Raspberry Shake wireless?

Hello jboutet,

First, you have to verify that your Raspberry Pi has a WiFi module. If your Shake was bought as a Turnkey version (so, the whole package already pre-assembled) it will not have integrated WiFi, since our Pi boards are of the 3B version.

In this case, you will have to buy a compatible USB WiFi Dongle (a list is available here: RPi USB Wi-Fi Adapters - eLinux.org), and set it up with the instructions at this page of our manual: How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake

If instead, you have assembled it yourself using a WiFi-available Pi board, there are a couple of procedures to change the DNS on the Shake, as explained in this page on our manual, Firewall issues? — Instructions on Setting Up Your Raspberry Shake, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP Ethernet address (if you don’t already know what to put in that field), then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then WIFI SETTINGS.

    Fill in the IP field as your local network requires.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

    Save and Reboot.

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart

    Now make sure those changes took hold:

    nano /etc/resolv.conf

    The file should look like the following:

    # Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.