Unable to access RS FDSN server via ObsPy

Hello, I’m trying to access RS data via FDSN through ObsPy.

The following Python code:

from obspy.clients.fdsn import Client
c = Client('https://data.raspberryshake.org')

Raises this exception:

FDSNNoServiceException: No FDSN services could be discovered at 'https://data.raspberryshake.org'. This could be due to a temporary service outage or an invalid FDSN service address.

I’ve also tried Client('RASPISHAKE') and Client('https://data.raspberryshake.org/fdsnws/'); all raise the same error.

However, navigating to Raspberry Shake FDSNWS Implementation in my browser returns a seemingly valid web page.

Any help trying to figure out how I can access RS data via ObsPy/FDSN would be much appreciated. Thanks in advance!

Hello sdg, and welcome back to the community.

I have just tested this client = Client('https://data.raspberryshake.org') with my Python script, and no error appeared.

Have you tried to restart the Python kernel and see if, after that, the script now manages to connect to our FDSN service successfully?

Hi Stormchaser, thanks for the quick reply and for checking. This is really strange–I noticed that I’m able to connect to the client from my local computer, but not from the remote server I was working on. I wonder if it has something to do with the firewall on the server or something like that. Note that I am able to connect to other FDSN data providers from the server, and I was previously able to connect to the RS server as well. I’m not sure what has changed, do you have any recommendations for trouble shooting? I understand this isn’t an issue RS has control over, but any thoughts you might have would be really helpful.

1 Like

Hello sdg, no problem at all!

Is it possible that you need to add all raspberryshake.org domains as exceptions to your remote server connection protocols (if there are firewalls, or similar)?

Or, if you’re not that server’s main administrator, ask the IT team that manages it to do the same? Maybe they can do an in-depth analysis of the issue and find why (and what) something has changed during this time that prevents you from accessing our FDSN service.

As the issue is apparently located only on the remote server, it is possible that some new rules were implemented that are now restricting access. So checking that part should (crossed fingers!) provide you with a solution to the problem.

Hi Stormchaser, after some more experimentation I think the problem is that the server’s IP address may be blocked. I deduced this by successfully connecting to Raspberry Shake FDSNWS Implementation from another server that is managed by the same organization, and thus should have the same firewall, etc. settings.

Is it possible for you to review/unblock my IP address? It may be easiest to follow up on this via email (rather than the public forum). I have downloaded a large amount of RS data for a research project, although I tried to do so in a way that would be minimally disruptive to your servers–clearly my precautions were not enough, and I’m happy to adopt any recommendations you might have to avoid getting blocked again. Apologies for this!

1 Like

Hello sdg,

You don’t have to apologize, we are here to provide 100% support! I have passed your request to our server team, and they will take care of reviewing it as soon as possible.

I have also sent you an email to the account you have here on the forum so that we can continue our conversation there in private.

We appreciate your patience while we work on this.