Two units, one name: rs.local collision

I have both a Shake (RS1D) and a Boom (RBm) on my LAN. Both of them now claim to be “rs.local” and it’s a coin flip which one actually shows up in the browser by that name, every time I try it.
RS1D (Pi Zero W) AM.R79D5.00.EHZ
RBm (Pi 2 Model B) AM.RC93C.00.HDF

The Pi Zero W with address .130 is connecting through a USB-Ethernet device, not wifi. Maybe that is the reason why the two units don’t recognize each other and one hasn’t changed to rs-2.local for example? However, as I recall it used to work some time ago. Or is this the fault of my router? Below are nmap reports for the two devices

Nmap scan report for
MAC Address: 00:0E:C6:B4:79:D5 (Asix Electronics)

Nmap scan report for
MAC Address: B8:27:EB:93:C9:3C (Raspberry Pi Foundation)

hi john,

i really don’t think it should matter how they physically connect, as long as they are on the same sub-net, which they seem to be.

can you do the following test?:

  1. power-down both units
  2. power-up only one
    2.1 wait until rs.local is assigned and working
  3. power-up the other
    3.1 confirm rs.local remains assigned to the first unit
    3.2 check if rs-2.local is assigned or not

and report back your findings.


Hi Ivor, thanks for the reply. Before doing that, I tried simply rebooting one of the devices, selecting that option from its web page. This worked. The device I rebooted now appears as rs-2.local.
A few weeks, ago a power failure rebooted them both at the same time. I presume neither one saw the other during its boot, so both assumed they were alone, and able to claim the rs.local name. I don’t know how you could easily prevent that happening in general, when all devices reboot at once.

1 Like