Time tears with RS4D

I have a RJam and RS4D running beside each other on the same network. The RS4D has small time tears, to many minutes missing, to producing no data at all. I got the instrument from a friend who had the same problem when he first received it. He bought it with the outdoor enclosure. We have tried 3 different SD cards and reformatting of card. The RJam has no problems, so I assume there are no problems with ports etc. Today I shut down the RS4D, turned power off for 1 hour then turned on again. The web interface is working correctly, but after 75 minutes there is no new data showing on the helicorder plot. I attach the log files from yesterday. RSH.R2737.2022-05-02T10_16_06.logs.tar (3.5 MB)

1 Like

I attach a gif from helicorder to show the varying amounts of data lost. I wonder if this problem is similar to “RS3D Missing and no data generated and time gaps” posted recently.

1 Like

Hello SAA, welcome to our community!

Thank you for the logs from your RS4D. Usually time-tears like this one can be associated with inability to communicate with NTP time synchronization servers, power supply issues, or transmission problems between the sensors and the Shake/Pi boards of the Shake.

In this case, we are in the last situation, with the logs showing this:

2022 122 10:16:03>>	UU?RQ?$?SÛ
2022 122 10:16:03>>	TeDBQÁXIàD?ÔEMIªQ1EIàU??Qâ?EE?U
2022 122 10:16:03>>	aEBQ?%AcM?E1?E
2022 122 10:16:03>>	ÕÊ?BQ?%Qe?
2022 122 10:16:03>>	U?RQáDYà?U??Qd?EE	U
2022 122 10:16:03>>	UQ?D?ÔUEE
2022 122 10:16:03>>	!ÙªQ*äîOk?M?eY27S??Ê?AÐE
2022 122 10:16:03>>	'AA0

This ‘gibberish’ shows that the data flowing in from the sensors of the RS4D is not understood by our OS. Could you please check that all the connections between the sensors and the blue Shake board are solid, and that the Shake board is firmly fitted on the Raspberry Pi board for all three units?

Sometimes a simple loose fitting can cause what you are seeing. I’ll wait for your check before we can proceed forward. You can attach pictures if you want.

As a last resort, if your check that the connections is positive, you can also think about sending back the instruments to us, so that we can try them in our lab and see what is possibly out of the ordinary. But again, better do some checks first.

Thanks for your reply.

I had an electronics technician pull apart and check over the unit yesterday. Nothing appeared to be wrong anywhere. I have set it running again, and at present it has no time tears. This has happened before. I will get back to you when it starts to have time tears again.


RS4D has started failing again after about 22 hours. Should I send it back? Logs attached also. RSH.R2737.2022-05-06T05_38_34.logs.tar (4.1 MB)

Helicorder attached. The failure seems to sometimes be worse if sunlight shines on the unit. Sun on ~0400UT shade~0430, sun~0500. However it is not hot. CPU temp has been 57 to 62C and room temperature is around 18-20C.

Hello SAA,

Thank you for the further feedback, screenshot, and logs.

Now that you mention the sunlight, I remember a case from a couple of years ago where an user had a similar problem. He solved it by moving the Shake in permanend shadow, do you have possibility to do the same?

Or, at least, to do the same in a temporary way, so that we can ensure that the Shake is performing nominally when not hit by direct sunlight? It seems strange that it is showing this problem with the Sun (I had one in similar conditions that continued to operate without particular issues), but this will show us if there are inner problems that need to be checked maybe in our labs.

Thank you for your collaboration.


The RS4D also fails in the shade, but the sun seems to make it worse. It doesn’t seem to go more than a few days, even in the shade, without failing.


Hello David,

Thank you for the feedback. If the Shake is failing in the shade too then there may be some kind of internal problem that we could not identify remotely.

In this case, if you want, you can send the Shake back to us, and we will review everything in our lab to try and find where the issue is and what was causing this unexpected behavior. You can write to sales [at] raspberryshake [dot] org about this, and they will be able to help you with the shipping and related procedures.