System Status: BOOTING

My device is stuck in BOOTING modus. I can ssh it but it does not generate helicorder files.

I have rebooted several times without success.

The log-files are attached.

Any help to this?

Regards from Switzerland

RSH.R3B01.2021-06-24T09 57 15.logs.tar (5.9 MB)

Hi, just for info with me status booting last at last 5 minutes. You should wait…
Marco

The booting status lasts for more than a month. The device has been rebooted (warm and cold) for at least 10 times. My last helicorder files are dated from mid May.

Hello UW1,

Thank you for posting the logs. From them, it appears that the Pi board cannot see the blue Shake board installed on it. These lines are clear about the problem:

2021 173 23:57:24: Unable to read Firmware version number off of Serial Port /dev/ttyS0 after trying for 15 seconds, cannot continue!
2021 173 23:57:24: Is the Pi computer connected to the Raspberry Shake Board?  Please confirm and try again.

Can you please check if all the connections are solid between the two boards? After this check, could you also shut down the Shake again, wait a little bit, turn it on, wait for another 10 minutes, and then send me the new logs?

Thank you.

Hello,
I have checked and all connections look fine.

I have attached the logs as you suggested.

Thank you very much for your support
RSH.R3B01.2021-08-07T20_57_10.logs.tar (5.1 MB)

1 Like

Hello UW1,

Thank you for getting back to me with the new logs. From them, it appears that the issue remains where the Pi board cannot see the blue Shake board above it, and thus the Shake will remain stuck in booting status.

You can try two different things:

  1. Re-burn the microSD card to check if some corrupted files in the booting process are creating the issue. Instructions on how to prepare the new OS image follow:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

or you can try to

  1. swap the current Raspberry Pi board with another one that you have available, and try to restart the Shake again, to see if the issue is within the Pi board.

You can also try both methods if you want, there is no issue with that.

Also, please ensure that your power supply is still in good conditions and can still provide between 5.0V and 5.2V and at least 2.5A. If you have another available, you can try to switch this hardware too.

If the Shake does not start even after these two/three checks, we will try to see what else can be done.

I have tried to use a fresh 64 GB SD card. I did format it using the SD card formatting utility:
Volume information:
File system: exFAT
Capacity: 63.20 GB (63’201’869’824 bytes)
Free space: 63.18 GB (63’184’699’392 bytes)
Cluster size: 131’072 bytes
Volume label: SB_Boot

Unfortunately nothing happens at all. The blue LED on the SB board and the red LED on the RPI stay lit forever?
All the 34 files are transferred onto the SD card.

Any help to this?

Hello UW1,

Thank you for your feedback. It seems that initialization went well, but after that something is stopping the OS from proceeding forward, thus giving you the static blue and red lights and nothing else.

It’s good that all the files have been copied inside the Shake, but it seems that this has not solved the issue. Here’s what else you can try:

  1. swap the current Raspberry Pi board with another one that you have available, and try to restart the Shake again, to see if the issue is within the Pi board.

or, if you don’t have another board available,

  • Disconnect the one you have from the blue Shake board
  • Burn the microSD card with the latest Raspberry Pi software (you can find it here: https://www.raspberrypi.org/software/operating-systems/)
  • Once done, connect power, internet, keyboard and mouse, and a monitor, and see if the Raspberry OS boots up well and if you can navigate in internet.

If yes, then the Pi board is working as expected, and it is possible that the blue Shake board will have to be replaced then. But, before we come to this, let’s try these two procedures and see what comes out.

Hello,

before I go and take the raspberryshake apart (which honestly I’d rather not want to do) I would like to try this:
Burning the Old Way
Found inside the zip file is the image formatted the same way as for previous releases.
By extracting it specifically, you are able to burn this image to disk using any
known program (e.g., etcher), or the ‘dd’ command from the command line.

The problem is that etcher could not find a burnable image in the zip file. Where would I find this?

Thank you

hello,

if you unzip the image, you will find a file named rshake_os.xz, which is the file you can provide to etcher.

etcher will uncompress this and proceed.

cheers,
richard

1 Like

Hello,

I have tried using the image. Somethings are really very odd - on the rs.local website of the S&B there is not even the RPI type and other information available.
Can I send the device to you for service and repair?
Regards

Hello UW1,

Yes, this is quite unusual.

We are releasing the next version (v0.19) of our Shake OS soon. I think we can wait until the release is gone live, to see if the upgraded software will correct the issue, and if not, we can discuss other options. There are no problems if, after this further check, you want to send the unit to us for verification.

Hello - I have tried the latest version of RS (v0.19) without any success.

So I would like to send you the unit for repair. Would it be possible to upgrade the RPI to a model 4 at the same time?

Hello UW1,

I’m sorry to hear that but now, with all that we have tried, it is a sensible choice.

You can write to sales@raspberryshake.org regarding sending back your unit for a check and eventual repar, they will be able to guide you through the process. Thank you.

As of now, we are not yet installing Raspberry Pi 4 boards on our Shakes, but you can make a note in the email you will send, and our tech department will see if it is possible to swap them.