SWARM on a Linux Desktop with Hi-DPI

Dear all,
I installed a 4k-Monitor, it is not possible to upscale SWARM with the GTK-Settings. Is there any way to use Swarm with Hi-DPI? I use Swarm 3.2.0, Linux Mint 20.2 and Openjdk version 11.0.11.
Thank you for any hint.
Kind regards
Jürgen

1 Like

Hello Jürgen,

I tried to look around, but I didn’t find a possible solution to your issue if you want to use SWARM. I would advise that you contact the SWARM development team to ask if they have a workaround for this issue.

Or, you can switch and use our newly released data viewer application which will not have any resolution upscale problems, and it will work even with a 4K monitor. You can find it here: https://dataview.raspberryshake.org/

In addition, if Swarm is running with GTK3 ( not sure of this ) then setting these environment variables might help run on 4K:

export GDK_SCALE=2
export GDK_DPI_SCALE=0.5
1 Like

Is there any manual for RS DataView?

1 Like

Not as of this moment, but documentation and visual guide is being worked on at this moment.

1 Like

I got an information from USGS, that it is not possible to upscale SWARM at this time.

Thank you for informing us of this fact jheiler. It could be useful to someone else that wanted to try the same.