SWARM MyShake error

When I click MyShake, my station does not appear under it. It is blank. But I can find my station under “Raspberry Shake”. How do I make it that I can access my shake under “MyShake”. This has only happened recently, before I could access it under MyShake.

Screen Shot 2022-08-25 at 4.12.38 pm

Thank you.


Simply copy the Swarm.config from your old swarm
directory into the new extracted directory
before running it.



Hello VS1,

As Marco said, you can copy the old .config file and everything should go back to normal.

If not, you can click right on the myShake name in the list, and see if, maybe, the connection details have been modified for some reason. If they are, you can replicate what you had in the previous SWARM installation and the Shake should appear again.

As of now, we advise using our new DataView portal, here: RS DataView BETA as SWARM will not receive any more updates from the USGS (the original developer and maintainer)

And, if you see something that is missing in DataView that you found useful in SWARM, or some functionality that you would like to have available, please let us know!

1 Like

If you haven’t fixed this yet, check the IP address of your RS on your network and then check it matches the IP address in SWARM.

Click the Edit Data Source button to check and change if necessary.

I’ve had this happen a few times when the router reassigned the IP address for the RS. I have a fixed IP address for it now.




I do find the pick option quite useful in swarm as that is able to estimate duration magnitude as well as estimating distance of earthquakes using the P and S wave picks.


1 Like

Thank you for the feedback VS1!

I will pass it to our development team, and we will see what we can do about this.