SWARM - Counts vs M/S

I have been using SWARM for several years to view my RS1D (R2DEF). I am now using v3.2.0. For whatever reason I cannot get the Wave view to show velocity as opposed to counts for my station. I have the “Use calibrations” box checked, but still only get counts.

When I load any other RS station through the Data Chooser, I can see velocity units for that station, and I can toggle between counts and m/s by clicking the “calibration” box

When I access my station through StationView, it displays with velocity units.

What am I doing wrong???

Jeff

Hello Jeff,

I have checked with my SWARM installation (v3.2.0) too, and I am seeing the same. The only explanation that comes to mind (since we have not changed anything on our side) is that SWARM developers have introduced something that is causing your Shake to not display velocity anymore.

This is an issue we have also had in the past, where some Shakes would correctly display counts (or velocity) when the “Use calibrations” box was unchecked (checked). One of the Shakes that I have still displays counts no matter which boxes I check.

If anyone in the community would like to pitch in, feel free to add your experience and/or possible solutions. The only thing I can advise you to do is to write to SWARM creators at USGS, explain in detail the issue to them and see if they already know this bug and if they can provide you with a solution since it is their proprietary software.

You can do it via the SWARM GitHub account, in the Issues tab high on the left: GitHub - usgs/swarm: a Java application designed to display and analyze seismic waveforms in real-time.

In the meanwhile, if you want, you can use our (in Beta version, but we are working hard to finalize all its feature) DataView page here https://dataview.raspberryshake.org/ to display live (or historical) data from your Shake with velocity units of measure.

Stormchaser:

Thanks for the update and I will contact USGS. The SWARM team has been very responsive in the past.

Here’s another issue I have with SWARM (this is what got me on the units crusade in the first place): I recently watched Angel Rodriguez’s excellent YouTube post about locating earthquakes with SWARM (Locating Earthquakes with Swarm - YouTube). I had never tried that before, so I tried it on a local event here in So Cal. I picked phases on 4 RS Stations plus my local station, total of 5 stations. When I ran HYPO71 it came back and said it was calculating the location using only 4 stations. I looked at the output and my station was omitted. I tried different events and station combos, but my station was always omitted from the location solution.

Any ideas?

Jeff

Stormchaser:

I received this response from USGS regarding SWARM:

From: Parker, Thomas J tparker@usgs.gov
Sent: Friday, December 10, 2021 5:11 PM
To: jefflawton@cox.net
Subject: Re: [EXTERNAL] SWARM - Station info

Hi Jeff,

Unfortunately, the primary Swarm developer has moved on. Swarm development is on hiatus and the repo archived, meaning we can’t take bug reports or feature requests. I’m not sure what the future will bring for Swarm.

That said, I’m still happy to answer any questions I can, but know it’s been a few years since I had my hands in Swarm and I’m not very familiar with the features Dianna added.

Have a great weekend,

Tom