SWARM and Windows 10

SWARM and Windows 10

I click on swarm**_**console and nothing happens. Why won’t it launch?

Any easy How To steps to follow for the non-novice PC user?

You might have Java missing on your computer. There is an installation guide here: Swarm Installation Guide — Instructions on Setting Up Your Raspberry Shake

To confirm, try starting the program from a command line and if an error occurs, it will display what the error is. If you don’t use a command line, the console just blips away

Windows button / Search "CMD / Right click Command Prompt, select Run as Administrator
Navigate to the folder where SWARM was unzipped, and run the BAT file from there

1 Like

That worked. Thank you.

JAVA is an important component to SWARM running on WINDOWS.
FYI - Raspberryshake. and SWARM should look at ways to make that information readily available. Maybe include a version of JAVA in the Swarm ZIP FOLDER.

thats for the assistance. Its launching not. BUT where is mySWARM?

Glad it helped! I’m just learning myself after receiving my Shake a couple weeks ago. I ran into the same problem so it was fresh on my mind.

For your other question, I think you need to use Swarm 3.0.1 as it is pre-configured for the Shake
image

You can download it directly from rs.local. There is a link on the bottom, second from left. Look for the green circle with download arrow.

1 Like