Station offline

Hi there,

My station has been offline and I have tried to fix this. I have checked that all the required lights are flashing properly and cables are in properly, the internet it is connected to works on other devices so I know the internet shouldn’t be an issue. I have deleted the ShakeNet app and reinstalled and the station still shows offline. I can’t seem to find it in StationView either. How can I fix this?


Hello VS1,

I, too, cannot see your Shake online on our services. Could you please attach the logs from the Shake, so that we can try to see what’s going on in more detail?

In case you don’t know or don’t remember how to do it, they are downloadable from the Raspberry Shake’s web configuration page, accessible entering the rs.local (or the Shake IP) address in your browser, then by clicking on the “Download Logs” button.

Thank you.

Hi there,

Here are the logs

RSH.R5B60.2021-02-16T11_35_43.logs.tar (2.2 MB)


Hello VS1,

Thank you for the logs. From them, it appears that every now and then the internet connection was not available, and this caused some Hard Resets that rare troublesome in getting a constant stream of data to our servers. Here you can see an example:

2021 045 06:10:54>> Time adjustment M0: HARD RESET. This will result in a one-time time-tear.
2021 045 06:10:57>> 5.0: NTP Time (Init): NTP: 1613283052.825454950
2021 045 06:10:57>> 5.2: NTP Sync (HARD): VEL Before: 1613282958.063999891 After: 1613283052.565000057 Diff: 94.501000166
2021 045 06:10:57>> 5.2: NTP Sync (HARD): ACC Before: 1613282958.063999891 After: 1613283052.565000057 Diff: 94.501000166

Can I ask what caused the Shake to go offline for the first time? Was it something like a power cut, or another reason?

Something that you can try, if you haven’t already, is to shut down your Shake first, then your modem/router. Wait for 2 to 5 minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now) if you can:

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

After checking this (sometimes the modems close them without prompting) and opening the ports, if needed, please start your Shake, wait for around 10 minutes and then let’s check that your unit can reach our servers. Can you SSH (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake) into the Shake and try and ping the following addresses?

  • ping -c 10
  • ping -c 10

The first one is the Google server, while the second is our data server. The two commands will execute the exchange ten times, and your expected result is a 0% packet loss for both instances.

Also, please download the logs again and attach them to your answer, so that I can compare any difference between the old and the new ones.

I’ll wait for you to try this before going forward.

Thank you for your response. I will try this and let you know.

As for the Shake going offline, we do get power cuts sometimes and there was a hurricane recently. However, we have a backup generator so when the power goes off the generator kicks in within a couple seconds.

It seems that it has come back online by itself.

1 Like

I was seeing the same this morning. Evidently, whatever caused the issue has likely solved itself, maybe something with your DNS provider, or a similar case.

Anyway, hopefully, you will not have to face similar problems in the future.

1 Like