Station offline, Server not connected

My Shake/Boom has been offline for days and I’ve not been able to get it back online.
RSH.R08DA.2023-01-26T13 46 05.logs.tar (3.9 MB)
I have restarted the station, router and wifi several times, set the DNS server to, tried a static IP (it would not stick), switched to Offline mode, back to Online. It continues to show “Server Connection:Not Connected”

Obviously the station can be seen via web browser on the local network and FileZilla will connect.
But no luck getting it online (Internet.) I’ve read the other offline threads and tried what I can, but no luck so far.

Thanks for any help you can give.

Your problem appears to be NTP not running. From your logs:

Clock Info

* ntpdate.service - Network Time Service
   Loaded: loaded (/lib/systemd/system/ntpdate.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2023-01-26 05:16:43 UTC; 8h ago
  Process: 454 ExecStart=/usr/sbin/ntpd -u ntp:ntp -q -g -x -t 5 (code=exited, status=1/FAILURE)
* ntpd.service - Network Time Service
   Loaded: loaded (/lib/systemd/system/ntpd.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2023-01-26 05:16:43 UTC; 8h ago
  Process: 486 ExecStart=/usr/sbin/ntpd -u ntp:ntp -f /etc/ntp.conf -p /run/ (code=exited, status=0/SUCCESS)
 Main PID: 475 (ntpd)
   CGroup: /system.slice/ntpd.service
           > 475 /usr/sbin/ntpd -p /var/run/ -g -u 106:111

Jan 26 05:16:43 raspberryshake systemd[1]: Starting Network Time Service...
Jan 26 05:16:43 raspberryshake ntpd[486]: ntpd 4.2.8p12@1.3728-o (1): Starting
Jan 26 05:16:43 raspberryshake ntpd[486]: Command line: /usr/sbin/ntpd -u ntp:ntp -f /etc/ntp.conf -p /run/
Jan 26 05:16:43 raspberryshake systemd[1]: Started Network Time Service.
Jan 26 05:16:43 raspberryshake ntpd[490]: proto: precision = 0.730 usec (-20)
Jan 26 05:16:43 raspberryshake ntpd[490]: format error frequency file /etc/ntp.conf
Jan 26 05:16:43 raspberryshake ntpd[490]: restrict KOD does nothing without LIMITED.
Jan 26 05:16:43 raspberryshake ntpd[490]: restrict ::: KOD does nothing without LIMITED.
Jan 26 05:16:43 raspberryshake ntpd[490]: unable to bind to wildcard address :: - another process may be running - EXITING

     remote           refid      st t when poll reach   delay   offset  jitter
 SHM(0)          .GPS.            0 l    -   16    0    0.000    0.000   0.000
 SHM(1)          .PPS.            0 l    -   16    0    0.000    0.000   0.000

I would normally suggest ensuring that you don’t have a firewall blocking port 123 (UDP), but this mentions a problem with /etc/ntp.conf. You might want to check to see if that file has somehow become corrupt.

For reference, here is the contents of my /etc/ntp.conf:

tinker panic 0
# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable

# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

# maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <>
server iburst
server iburst
server iburst

# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <>
# might also be helpful.
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.
#restrict mask notrust

# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth

    # GPS Serial data reference                          
    server minpoll 4 maxpoll 4 noselect     
    fudge time1 0.500 refid GPS             
    # GPS PPS reference                                  
    server minpoll 4 maxpoll 4 prefer       
    fudge refid PPS 
1 Like

Thanks Philip. I’ll dig into it to see if there is some file corruption. Hope I can fix it.
EDIT: I just noticed the system time is off by about 9 minutes. Ah ha!

1 Like

hi panoshake,

please also see the log file /opt/log/postboot.log, it is very clearly indicating that connection to the internet-at-large was lost recently, which explains no NTP connections, and no connection to the server.

FYI: when there is no connection to an NTP server, even if you are connected to the internet, the unit will refuse to forward data to the server until the NTP daemon has gotten a lock to a server.


1 Like

OK, thanks. Not sure how to fix this, but I will dig around.
FWIW I think I see no time server when I ask the rapsbishake

1 Like


this is exactly expected when there’s no connection to the internet-at-large: no NTP servers will be listed to connect to.

when your internet connection returns, all your problems will very likely be solved.


1 Like

OK. Then does this mean there is no Internet connection? Need to figure out why, since nothing was manually changed in the setup and its been connected to the Internet for months. And it is visible on the local household network.

Maybe my crappy router (ISP provided) is the problem.

1 Like

yes, the shake has no connection to the internet through the router. to test this, when possible, attach the shake to a different router (neighbor, (maybe) work, etc.) and see if you get different results.


1 Like

This may help in your testing.
There are three Internet connections that have to work. Occasionally, one or more of these may be blocked by a firewall (more likely in commercial/educational networks).

The OS on the shake has the tools needed to help diagnose any problems.
Test for connectivity to DNS, NTP and the raspberryshake server:

# Connect to DNS
nc -zvw5 53
# Connect to NTP
nc -uzvw5 123
# Connect to raspberryshake server
nc -zvw5 55555

NOTE the ‘u’ in the NTP test - NTP us a UDP service.
All of those need to report success.

If any of them fail, you can find out where it is failing using traceroute. Let’s assume DNS had problems. Use traceroute to report every system that a request passes through to the destination.
This is for my shake - your network addresses will, of course, be different:

$ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  1.431 ms  3.337 ms  3.468 ms
 2 (  5.614 ms  6.538 ms  7.500 ms
 3 (  16.875 ms  25.110 ms  25.848 ms
 4 (  25.808 ms  25.968 ms  26.218 ms
 5 (  23.204 ms  24.517 ms  25.613 ms
 6 (  23.360 ms  20.282 ms  11.298 ms
 7 (  18.343 ms  43.621 ms  43.257 ms
 8 (  52.732 ms  22.172 ms  22.083 ms
 9 (  19.702 ms  21.643 ms  19.435 ms

Seeing where the list ends (if its not at will help you (or your network engineer) to determine where the problem lies.


SOLVED. Back online again. R08DA

The shake/boom lives in the barn and is normally connected to the house via a wifi extender. I brought the unit inside and connected via wire to my router. Still no connection to the Internet and FileZilla was having trouble getting a directory listing.

Simple fix - Nuke it: Remove and format SD card, install latest Raspberry Shake image, reboot, check, place raspishake back in the barn. All good. Online and running well. Can be seen live now.

Thanks Philip and Richard for the help!

1 Like

Thanks for the traceroute and other trouble shooting info. That will probably come in handy in the future.
I should try it now, just to know what correct results look like.

1 Like

The station is online and can be seen live.
However it has disappeared from the app. It does not appear on my dashboard list nor on the map.

How long does it take to reappear?

1 Like

App is working again. I had to clear the cache on the app, which got my station to show up again.
Clearing did wipe out all my settings and saved stations, but that was easy to set up again.

1 Like