Solutions for Swarm download issue in v0.18

Hi all,

Version 0.18 of our OS suffers a problem in which Swarm is not correctly downloaded from the USGS site. This is due to the fact that they released a new version and removed the old version’s download link, which is against the protocol of what they’ve done in the past, and therefore breaks our download link.

However not to worry, there are several solutions to this.

  1. Download or copy Richard’s script (12.2 KB) to the Shake, and run it. This will have the effect of replacing the file on the Shake’s webserver with the USGS’s newer version, which will solve the issue.

    You can copy the script to the /tmp folder on the Shake using scp or FileZilla or a similar ftp or filesharing software.
    Then, while logged into the Shake, move it to the /usr/local/bin folder, make it executable, and execute it like this:

    sudo mv /tmp/swarm-fetch /usr/local/bin
    sudo chmod a+x /usr/local/bin/swarm-fetch
    swarm-fetch 3.1.0
  2. Download the latest version of Swarm from the USGS Swarm site and configure it yourself. Once you have unzipped the files, you can do this by either:

    a. Copying the following two lines to Swarm.config

    server=RS Community;


    b. Manually adding the sources from Swarm itself.

    1. First click the “New data source” button
    2. Enter the following parameters:
      Data source name: Local Shake
      IP address or host name: rs.local
      Port: 16032
    3. Press OK. Your source table should look like this now:
    4. Double click on “Local Shake” to make sure it connects. Press the + sign to expand the source. It should now look like this (the number of channels may be different, this is for a Shake 4D):
    5. Now add the Community server, the same way. The credentials you will need are:
      Data source name: RS Community
      IP address or host name:
      Port: 16022
    6. When you connect to the RS Community source, the data sources should include a long list of stations, and the map will be populated with dots representing their locations.

If you have any issues with any of these steps, let us know.
Hope you are enjoying your quarrantines and social distancing practices by browsing some interesting seismic data.
Cheers, stay safe.

It worked! Thank you!! (I was actually receiving emergency notifications on my phone to shelter-in-place for the pandemic as we were going through this process, so setting this up was a nice distraction to that stressful situation. Thank you, too, for that.)


Solution 1 work for AM.RA14E, Thank you, Paolo (Messina - Italy)

  1. When I connect to my Shake via SWARM using WInston Wave Server, it runs the temperature up to 160+ defrees Farenheit. And then the RS drops off line… This is with only one connection to my RS4D. I am using SWARM 3.1.0 with 24Gbt RAM in a new i7 PC
    I am running WIndows 10, Update version 2004, connecting to the RS wirelessly.
    ++ When I connect via Seedlink Server, no problems.

  2. When following your instructions for the RS Community using WWS, All I get is an “All” instead of a list of all the RS in the network. ALso no stations show up on the map.


Hi Gary, for point 1, can you post your logs please?

For point 2, can you post a screen shot of your configuration for the RS community connection in Swarm?

Hi Ianne, Point 2 seems to work now that I am looking at it a day later. Now it works, and I can see other stations, but just the helicorders are active. I can’t see other’s waveforms, unless I highlight a point in time on their helicorder. Then, it is a still swaveform. It doesn’t move. Only my RS will show a moving waveform, for the present live time. I have included my Swarm Config file.
Swarm.config (1.6 KB)

For Point 1, The RS still starts shooting up in temperature as soon as I display one of my EHZ waveforms. I stop it when it gets to 154F. Here is the Log FIles for R29F6:
RSH.R29F6.2020-06-29T15_42_26.logs.tar (3.9 MB)


Ianne, One other thing related to the overheating, this last time it overheated to 176 - 180 F and I disconnected all data download programs like jAmaseis, and Swarm, and it remained at 176 and would not cool down. So I unplugged it and restarted it. But before unplugging and while it was running hot, I downloaded the Log. After letting it cool and repowering it up, I again down loaded the Log, and they are both included here.
Can you tell me what is happening to make it rise so much in temperature (and then why it stays so hot.)?
That can’t be could for the electronics.
Gary, R29F6
RSH.R29F6.2020-06-29T17_51_16.logs.tar (4.2 MB) RSH.R29F6.2020-06-29T17_43_10.logs.tar (4.2 MB)

Hi Gary, I can’t reproduce the temperature rise. I can only get mine to 165 F even when I connect multiple services to it at once. Is your Shake in an external enclosure, or is it in one of ours? Is it in a particularly hot room, or in direct sunlight? I only ask because it usually takes some doing in order to get a Shake to overheat (wrapping it in a towel, placing it in an uncomfortably hot room or enclosure, putting it in the sun).

As for the data from other stations, our community data is on permanent 30 min delay except for on our web services and in our app (read at the bottom of this page in our manual: This means that we don’t support the live map display in Swarm (although it works with historical data). Apologies for the inconvenience.

No Ianne, It is bare, sitting on a marble floor in the closet, which is air conditioned if it gets warm outside.
However, using Seedlink Server, I always run a refresh interval set to 1.0 seconds, without any temperature increase.
WIth WWS, set at 1.0 seconds refresh interval, causes the RS to rise in temperature…
If I set the refressh to 5.0 seconds in WWS, the temperature drops to a little higher than normal… (Even lower with 15.0 seconds.)
So, I believe that I solved the problem myself by dropping the refresh time in WWS.
So if I understand your article, the only advantage to WWS over SS, is for helicorder mode, where the past data history is presented for a longer period of time.

1 Like

Ah, that makes sense now. I think this means that the Shake was being overloaded with data requests. Typically I don’t set the refresh value lower than 15 seconds, since that only controls the refresh rate of the helicorder. If you want to view live data, try playing around with the Wave Monitor (look for the image button in the lower left corner). This shouldn’t have the same adverse effect on temperature, I don’t think.

That’s correct, yes.

Glad you figured it out!