Software problem

I am buy DIY RS and starting with RPI 4 B. In first start and config its OK. But after change SSH password server connection is not working. After restart RS is infinit loop. Set static IP is not possible.
I back SSH password to default “shakeme”, but problem persisting.
I am very disappointing!

RSH.RB3D2.2021-01-17T19_36_40.logs.tar (347 KB)

Hello antebosnjak, welcome to the community!

Thank you for the logs. From them, it appears that the DNS address ‘’ is not getting a connection to our servers. These lines make the issue clear:

2021 017 19:18:38: Unable to resolve hostname '', most likely no DNS server available
2021 017 19:18:38: No internet connection found
2021 017 19:18:48: Unable to resolve hostname '', most likely no DNS server available

The first thing you can try, if you haven’t already, is simply to shut down your modem/router, wait a couple of minutes, and then turn it on again, to see if it was a simple issue with the modem/router itself.

If this has not solved the issue, then please shut down your Shake again first, then your modem/router. Wait for a couple of minutes, then restart your modem/router, and when it’s back online, please check from your pc/laptop if the following ports are open (do not start the Shake now):

port 55555 [TCP]
port 55556 [TCP]
port 123 for TCP and UDP traffic in both directions

If the connection still doesn’t work, then you can also try to change the DNS on the Shake, as explained in this page on our manual, Firewall issues? — Instructions on Setting Up Your Raspberry Shake, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake)

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart

    Now make sure those changes took hold:

    nano /etc/resolv.conf

    The file should look like the following:

    # Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.