Shake that keeps shutting down without any intervention from me


I just got a new Shake working, and after it connects and runs for a while (sometime 5 minutes, sometimes a couple of hours) it keeps shutting down without any intervention from me.

The only way I am able to re-start it is to visit the site and unplug/replug. So, I don’t currently have access to the site/log files - will get them as soon as I am able to.

In the meantime: Have any of you here seen this happen? Suggestions?

Hard to say without the logs, but my first guess would be the PSU.
The R-PI is really sensitive to the supply voltage. Although it is usually said to need 5 to 5.2v, my experience is that it really needs to be much more like 5.2 than 5v.

Trying to fix these problems (for non shake use) I ended up buying several PSUs, all reputedly capable of delivering 5.2v @ 2.5A. Turns out that tends to be a bit of an exaggeration for a lot of the cheap Chinese PSUs. Also, 2.5 really is minimal for the R-Pi, especially the later versions. I would call 3A really the minimum requirement.

Another problem is the quality of the USB cables to connect them. No matter how much you pay, how well constructed they appear to be, al LOT of these really are not up to carrying 2.5 or 3A. I ended up buying one of those USB voltage/current meters and a variable USB load and testing quite a few different cables before I found some that were up to the job. Once you get beyond about three feet in length, very few are.

Where longer runs are required for the power cable, I recommend thinking about using a coverter module, very close to the R-Pi (with a few feet) and running 12v (or maybe more) to deed that over the longer distance.

I used this:

There is a discussion on the results here:

All that said, my Shake-Boom has worked very reliably with the provided PSU fed from an Uninterruptible PSU.


I was also thinking that it seems to be acting like it has something to do with the power supply.

I am guessing that the log files might help RE testing that, but it’s going to be until at least later this week that I will be able to get the log files.

So far, we tested it with a good quality UPS and with directly plugged into a wall outlet - same result.

I have heard of some rare cases where something like this might be a problem with the power adapter, so I will try switching those when I can retrieve a power adapter from a different Shake.

Still have not resolved this, but here’s an update:

  1. I tried switching power adapters, and after experimenting with several different ones, the problem is the same regardless of what power adapter I use: It connects and runs for a while, and all looks right, and then after about 10 to 20 minutes it shuts down without any intervention from me.

  2. I tried burning a new SD card, and that doesn’t change anything - still acts the same.

  3. I brought it home to my home network, which I have two other Shakes on that have been working for a long time, and where I have tested other Shakes, and it still acts the same.

  4. log file attached from one of the times it shut down like this.

  5. Screenshot attached from when it was working before it shutdown.

Any suggestions?

RSH.R4E55.2023-02-27T17_30_51.logs.tar (69 KB)

Hello kafka, thank you for all the insight into the problem you are experiencing.

From the screenshot, it appears that the temperature is in the normal range, so it shouldn’t be a heat issue that is causing the sudden shutdown. The logs also show that the Shake boots with no issues, finds an internet connection, sees our servers and starts data transmission.

Two things that you can try, as you have already checked the power supply and re-burned the microSD card:

  1. if you haven’t already, try to burn the Shake OS on a new microSD card, or a different one than the one you are using now, to exclude the possibility that a damaged card is causing this problem.

  2. you can also try to change the Raspberry Pi board with a different one that you know is working well (paying attention to that, in doing so, the Shake station name will change), to see if that one was at the root of the issue.

I did try burning different SD cards, including a new one, and that didn’t help.

Changing the Pi board is beyond my technical abilities at this point. I think it’s time for me to contact Raspberry Shake sales and ask if they would replace this Shake.

Also, I’m seeing the cost of new Pi boards at ~$100 to ~$150.

Hello kafka,

Yes, the costs of new Pi boards has risen much in the last months, due to the worldwide chip shortages that we are experiencing (had to wait months for my PC graphic card to become available).

At this point I was about to suggest the same. Please feel free to send an email to sales [at] raspberryshake [dot] org, using the same address you made the purchase with, linking this forum topic so that our management can see what can be done.

Thank you for your availability and feedback.