Shake starts in Emergency Mode, no ethernet

Hi, I have an RS4D that was working just fine for a year or more and then one day disappeared from our network. The blue, red and occasional green lights are all fine. The ethernet interface lights are on (yellow and green), and our network router shows that a device is connected physically, but the shake does not pick up a network address or communicate.

I have attached a monitor to it and it reboots in “emergency mode”. eth0 shows as inactive. I have tried setting it up with an address etc manually, but although it then shows eth0 as active, it still doesn’t communicate. I have also manually configured the wifi, but neither does it connect.

Without network connection I can’t easily copy the log file to you. I have uploaded a photo of the final part of the boot up sequence in case it is any use.

Any ideas for where to go from here? Thanks.


Hello Alex, welcome to the community!

It’s the first time I’m seeing this particular issue. The lighting seems to suggest that everything works fine, but what you are experiencing is clearly not. Since it would be difficult, as you say, to send me the logs from this Shake, the fastest solution I can advise is to:

  1. re-burn the ShakeOS on your current microSD card
  2. or get a new microSD (to erase the chance that this one got ruined) and burn the Shake OS there.

In both cases, these are the instructions to prepare the new OS image:

I followed the numbered list points to burn the files on my SD cards, and I have not used Etcher or similar software.

Thank you for your detailed reply. I agree it looks more like a software issue than hardware, and SD cards are not very reliable. I am surprised at a corruption that allows the basic operating system to load and run without giving some serious errors, but it looks like that is what is happening.

I’ll get another SD card and try a fresh install - thanks again for the detailed instructions.

PS, I didn’t originally set this up, and the person who did so has gone. Two questions:

  1. I guess it will need some station ID/password to link it in to your system, or is that stored in the hardware?
  2. There was a USB key plugged in as well - it appears to be totally dead if plugged into another machine - does the shake need a USB memory key as well? (I tried putting in a replacement memory key but it didn’t help.)


Hello Alex,

You’re welcome for the instructions, no problem at all.

Regarding your questions:

  1. The Shake ID is in the hardware (it is taken from the Pi MAC address automatically), so unless you change the Raspberry Pi board, it will always remain the same. To login, these are the default username and password: Quick Start Guide — Instructions on Setting Up Your Raspberry Shake

  2. It is possible that the USB key was used to extend the archive capacity of the Shake. Anyway, it will not matter, because once you re-burn, if you want to use it again, you will have to re-configure it as an added drive, as shown here: How to mount a USB to store the waveform archive — Instructions on Setting Up Your Raspberry Shake

1 Like

Thanks again - the reinstallation process went very smoothly and the station is now active and online again.



Hello Alex,

I’m happy to hear that, and you’re welcome, it was no problem at all!

Enjoy your Shake!