Setting up problems

I have supplied my own RPI4and can access rs.local on my LAN. I have set up a static IP on my router for the RPI Shake, but when I try to input the address, after ticking Use Static IP, it rejects it saying “you have errors in your configuration”. That is problem 1.

Next when I try and set up the WiFi, it goes through all the steps and the WiFi passes then test. Then when I click to save and reboot, it never reboots to WiFi…even when I have taken out the LAN cable. Then when I reboot and go back into WiFi set up, I find that it has not saved the details! That is problem 2. Also when I try and set a Static IP for the WiFi, I get the same error as before.

What am I doing wrong or missing? Thank you for any pointers.

Ah! I think I have found the problem with the Wifi details not being stored. Firefox flags it as an insecure site…and while I can enter the WiFi password and test the Wifi…nothing is stored…as the URL is http and not https…when I enter https;//rs.local…I cannot connect. How do I overcome this little problem?

No, I am wrong …that was not the problem i.e. Firefox, I tried setting wifi up with Falkon Browser, which does not have the same security problem…and got the message that “Given credentials were not valid”…I had not noticed that message before as it flashed by so quickly. What does that mean?..I know the SSID and password are correct…



Shake Model : RS3D
Raspberry Pi Model : Unknown Model
System Status : RUNNING
System Version : 0.20
Ethernet Local IPv4 :
Ethernet MAC : dc:a6:32:e0:f8:62
Data Producer : ON
Data Consumer : ON
Off-line Mode : OFF
Data Forwarding : ON
Server Connection : Not Connected

I have a similar problem, I tried the standard turn off Forward Data for 30 seconds…but that did not work. When I first booted up it was Connected to the Server!!

Hello Dunbroking, and welcome to our community.

I have moved your other post to this thread, as I think all of these issues are related, so we can continue to focus in one place.

Firstly, could you please download the logs from the Shake and post them here? If needed, you can find instructions on how to do so on this page: Please read before posting!

Secondly, if, from the logs, we see that the problems are strictly related to setting up the internet configuration as you desire (so all the other Shake functions are operating well), we have manual procedures that could help in both establishing a WiFi connection with a static IP address.

Thank you.

RSH.RF862.2023-05-24T08 36 56.logs.tar (289 KB)
Thank you for that. Latest log attached.

Hello dunkrobin,

Thank you for the logs, they have confirmed what I thought, and also that the Shake appears to be in good status, so once the network issues are solved, you should be good to go!

Let’s try to solve this with a step-by-step approach:

  1. connection with a LAN cable
  2. connection via WiFi
  3. setting up a static IP (via WiFi or LAN, whatever you prefer)

Could you please SSH into the Shake (instructions here: How to access your Raspberry Shake’s computer via ssh — Instructions on Setting Up Your Raspberry Shake), execute the following two commands:

  1. cat /etc/dhcpcd.conf
  2. cat /etc/resolv.conf

and post their output here? Thank you!

myshake@raspberryshake:/opt $ cat /etc/dhcpcd.conf
interface eth0
static domain_name_servers=
static ip_address=
static routers=
static domain_name_servers=
# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.

# Use the hardware address of the interface for the Client ID.
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.

# Persist interface configuration when dhcpcd exits.

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
#nohook loo
1 Like
myshake@raspberryshake:/opt $ cat /etc/resolv.conf
# Generated by resolvconf
1 Like

1 Like

Hello Dunbrokin,

Thank you for the file content! Can you please try the following?

Please open again the dhcpcd.conf file with

sudo nano /etc/dhcpcd.conf

Delete all the lines that start with static, if present (as is this case), thus leaving only interface eth0. If the line interface eth0 is not present, then add it (not this case, but a useful general reminder). Do not modify anything else.

Then do:

sudo service dhcpcd restart

to make sure those changes took hold and then check the output file with

nano /etc/resolv.conf

What we have done is temporarily reset the Shake IP interface to its original setup. This should renew the configuration and possibly, solve your connectivity issue. If the Shake still doesn’t connect after this last command, try rebooting it again.

If it still doesn’t connect, please download the logs again, and post them here alongside the contents of the files dhcpcd.conf and resolv.conf. Thank you.

If it connects, then we will proceed in setting up point 2 and 3 on my previous list:

Let’s try to solve this with a step-by-step approach:

1) connection with a LAN cable
2) connection via WiFi
3) setting up a static IP (via WiFi or LAN, whatever you prefer)
Shake Model : RS3D
Raspberry Pi Model : Unknown Model
System Status : RUNNING
System Version : 0.20
Ethernet Local IPv4 :
Ethernet MAC : dc:a6:32:e0:f8:62
Data Producer : ON
Data Consumer : ON
Off-line Mode : OFF
Data Forwarding : ON
Server Connection : Connected

|Elevation|:|320 m|
|System Time|:|2023-06-01 10:39:36 UTC|
|Disk Usage|:|43% Used – 4.3 Gb Available|
|CPU Temp|:|54 C / 128 F|
|Uptime|:|0 Days 0 Hours 1 Minutes|

Tried the Wifi…again “Given credentials were not valid”…this message flashes by way too quickly!

Tried setting up the static IP address…I think this is what corrupts the config file…I have already set it on my router to be…and that appears in the information front page…as above…setting a static IP to that address using the static IP helper must be what corrupts things…so I will skip that part in future.

OK, back and connected.

Maybe there is some connection between the WiFI test and the “set static IP” box underneath the test button. Maybe I should take the 'shake off the fixed address via the router and try and set it up on the 'shake…???

Hmmmm! Now it is saying “Failed to turn on Wifi, please check your Rpi for hadware issues”???

Hello Dunbrokin,

Thank you for proceeding through the reset for the connectivity cards, and it seems that, for a while, your Shake managed to reconnect and transmit live data.

From what you have written, I think some communication issues between your modem/router and the Shake rs.local/ interface cause the WiFi problems you are experiencing. Probably also related to the static IP ones. I suggest you proceed through the following list to see if this solves your situation:

  1. Please re-do the operations listed here: Setting up problems - #11 by Stormchaser and, when finished, check that the Shake is currently streaming data to our server: Data View: Raspberry Shake Data Visualization Tool

  2. Instead of using the rs.local/ interface, please set up your WiFi connection manually following the instructions on this page on our manual: How to configure Wifi and USB wifi dongles from command-line — Instructions on Setting Up Your Raspberry Shake. The operations are very similar to the ones you have done for point 1), so they will be familiar. Once done, check again that the Shake is transmitting live data.

  3. Finally, to set up the static IP address as you desire, follow the instructions here: Static IP — Instructions on Setting Up Your Raspberry Shake and, when finished, you should have the configuration you have in mind.

We are sorry for the issues you are experiencing. With some modems/routers or internet configurations, the manual solution (described in the points above) appears to be the only solution to achieve the desired connectivity. We continuously work to improve this, and future Shake OS releases will likely contain increased capabilities.

Thank you for your patience and assistance in this.

Thank you so much, up and running on WiFi!


Happy to hear that your Shake is now connected as you wished and uploading live data!

You’re very welcome, happy to help!