Set up 2nd Shake in my home - it is "Not Connected"

I set up a 2nd Shake in my home, and it is “Not Connected” (after waiting for at least a full day). The first Shake is connected, but the new one isn’t.

Is it not possible to have 2 Shakes connected to the same home router?
Any other suggestions?

Log file:
RSH.R65FC.2020-12-15T14_58_56.logs.tar (1.3 MB)


the log files indicate that your DNS server, identified by IP address, is not resolving any machine names, both NTP servers and the Shake Data server. Without this, no data will be transmitted off the unit.

please confirm which DNS server this unit should be using and that it is able to resolve server machine names correctly. there is no problem having more than one unit connected to a LAN.

you can have a look in the log file myshake.out to see the DNS server being used for each of your units. see if they are different, because it certainly would not make sense that if they are both using the same DNS server, that one would be working while the other didn’t.

cheers, hope this helps,


1 Like


Here’s what I see under Network Info in the two log files. Any suggestions for what I should do next to resolve this?

R65FC (Not Connected):
Network Info

Stand-Alone Mode : OFF
Ethernet UP : YES
WiFi UP : NO
DNS Available : NO
Network Accessible : NO
Nameservers :

R974C (Connected):
Network Info

Stand-Alone Mode : OFF
Ethernet UP : YES
WiFi UP : NO
DNS Available : YES
Network Accessible : YES
Nameservers :

Can anybody explain to me why there are two Nameserver IP addresses associated with the one that’s connected, but one associated with the one that’s not connected?

And, any suggestions RE how to fix this so that the new one gets connected?

Hello kafka,

this seems quite convoluted, since the two Shakes have the same IP address, but only the first one successfully connects to the network.

Could you please send the complete logs of the connected one? I want to do a complete comparison before thinking of a solution. Thank you.

The reason for the two servers addresses is in the concept of DNS Failover:

DNS failover helps websites or network services remain accessible in the event of outage. The Domain Name System (DNS) is the protocol used to translate human readable hostnames into IP addresses. By providing two or more IP address in a DNS record, each IP representing an identical server, you can move traffic from a failing server to a live, redundant server.


These are the log files for both.

This one is connected:
RSH.R974C.2020-12-16T12_08_41.logs.tar (3.1 MB)

This one is not connected:
RSH.R65FC.2020-12-16T12_07_39.logs.tar (1.5 MB)

Hello kafka,

thank you for both the logs. Unfortunately, they didn’t confirm my first thoughts about your issue, and generated a very strange conundrum.

Your modem/router is correctly assigning good IP addresses to both your Shakes, and the DNS address (which, again, should be automatically assigned) works for the first one (which is also connected via WiFi) but not with the second (which is connected by cable).

This is illustrated in the postboot.log file of the second Shake, these lines explain the issue as a DNS problem, as if only with the LAN cable the Shake cannot reach the online servers:

2020 350 18:42:31: Unable to resolve hostname '', most likely no DNS server available
2020 350 18:42:31: No internet connection found
2020 350 18:42:41: Unable to resolve hostname '', most likely no DNS server available

The first thing you can try, if you haven’t already, is simply to shut down your modem/router, wait a couple of minutes, and then turn it on again, to see if it was a simple issue with the modem/router itself.

The second, is to change the LAN cable with one that you are sure it works. Or, to check if this one works properly by connecting something like a laptop to the modem/router via the same cable that you are using with the Shake.

If the connection still doesn’t work, then you can also try to manually change the DNS on the Shake, as explained in this page on our manual,, to see if this solves the issue. I’ll add some more info below.

There are two possible ways: setting a manual IP and DNS in the http://rs.local web config, or adding a line to /etc/dhcpcd.conf in the Shake filesystem.

  1. The first doesn’t require logging into the Shake. Navigate to rs.local, make note of the Shake’s IP address, then click on the Settings gear icon (high on the left) to access the configuration menu.

    Click on NETWORK, then under ETHERNET SETTINGS, click on “Enable static IP”.

    Fill out the Static IP field with the address you copied from the front page.

    Fill out the DNS server field with a more reliable DNS service. OpenDNS, which is, is a good choice. You can also use Cloudflare DNS service by entering or Google by entering

This could solve your issue, bypassing the modem/router settings and going straight to the internet.

The second way, a bit more complex, in which you can keep your Shake on a dynamic IP (assigned by your modem/router):

  1. SSH into the Shake (guide here:

    Once you’re in, copy and paste these commands (this example is for Cloudflare DNS):

    sudo echo 'static domain_name_servers=' >> /etc/dhcpcd.conf
    sudo service dhcpcd restart

    Now make sure those changes took hold:

    nano /etc/resolv.conf

    The file should look like the following:

    # Generated by resolvconf

You should not need to restart, these changes will take effect immediately, but if you want, you can still do it.

Thanks for this detailed reply!

As a start: I just restarted the router, and rebooted the Shake, and will wait for a while to see if it connects.

If it doesn’t connect, after a while, I will try the other things you suggest later today.

And, I’m learning a lot about how the Shake (and internet in general) works :slight_smile:

Restarting router, and 1st suggestion didn’t work.

When I tried the 2nd suggestion, it accepted this input:

myshake@raspberryshake:/opt$ sudo echo ‘static domain_name_servers=’ >> /etc/dhcpcd.conf

myshake@raspberryshake:/opt$ sudo service dhcpcd restart

But, then nano produced this:

Generated by resolvconf


OK. Tried again, and got to the point that nano command gives:

Generated by resolvconf


That seems like a good step forward…

Still says “Not Connected”, but rebooted and will wait for a while and see if it connects.

Let me know if you have any other suggestions at this point, other than waiting. (I have at times, with other Shake installations, had to wait for several hours, or more, between getting it set up and having it display “Connected”.)

Log files after these changes:
RSH.R65FC.2020-12-17T00_45_40.logs.tar (1.8 MB)

Still not connected.

Will keep experimenting, but:

I was able to connect via WiFi, so I also ordered a WiFi dongle, and when that arrives I will try to connect via WiFi and that dongle.

Hello kafka,

thank you for the updates, the new logs and your detailed comments on what’s going on.

The situation continues to be strange, from the logs it appears that indeed your modem/router cannot seem to finalize a DNS server (even after you put it there) even if it correctly assigns an IP address to the Shake.

The Shake OS, from its part, is working as expected, so please tell us how the test with the WiFi dongle will go, so that we can see how to proceed forward.

Here’s an update:

I can’t remember now if I explained that the setup is a WiFi extender and an Ethernet cable from the Shake to an Ethernet port on the extender. That’s how I have it set up on the first one (R974C), and it’s been working fine like that for a long time.

I noticed that I had “Connect to WiFi” checked on R974C, but not checked on the new one (R65FC). So, I checked “Connect to WiFi” on R65FC (while also still having the Ethernet cable connected,) and it quicky showed “Connected”, and data is flowing.

It seems to be working correctly now, and I have not (so far…) seen any evidence of the WiFi proximity interference that I have heard about (on either of them), but thinking about that I also want to experiment with the WiFi dongle when I receive it.

Glad to hear that now the system is working as expected!

The ethernet extender is what probably was causing the initial confusion in finding proper DNS servers, but it’s great that now everything performs well!

Enjoy having two Shakes!