Server not connecting using powerline ethernet connection

We are setting up an RS3D and are having some difficulties connecting to the server. We had the system up and running just fine a few days ago next to our router in our house, but we wanted to move the sensor to the garage where there is less ambient noise. I got a TL-PA7017P KIT passthrough powerline starter kit and used that to connect the RS3D to the router - no wifi involved. As far as I can tell the powerline kit is working well. The router sees the RS3D as a Raspberry Pi. We can see the rs.local/ page on our computers, and I have downloaded the log files. RSH.RB438.2022-01-01T20_27_09.logs.tar (993 KB)

I can ssh into the RS3D and ping and, so we clearly are getting out to the internet and getting nameserver service. I cannot ping Oddly, even on my computer I cannot ping that address. Here is the output from traceroute (minus the first line):

2 ( 28.370 ms 26.951 ms 28.279 ms
3 ( 28.234 ms 28.800 ms 28.757 ms
4 ( 36.397 ms 34.269 ms 36.924 ms
5 ( 36.268 ms 36.225 ms 39.761 ms
6 ( 61.382 ms 41.643 ms 41.639 ms
7 ( 47.418 ms 48.332 ms 47.307 ms
8 ( 48.231 ms 54.317 ms *
9 ( 54.878 ms 53.548 ms 58.529 ms
10 ( 58.481 ms 57.085 ms *
11 * * ( 55.273 ms
12 * * *
etc just the same till it times out

A traceroute that works correctly looks quite different (again minus the first line):

2 ( 25.097 ms 25.054 ms 25.010 ms
3 ( 24.961 ms 25.480 ms 26.059 ms
4 ( 30.852 ms 38.664 ms 30.144 ms
5 ( 50.739 ms 50.022 ms ( 45.661 ms
6 ( 45.619 ms ( 28.979 ms ( 38.241 ms
7 * * *
8 ( 39.171 ms ( 37.291 ms 37.246 ms

I am quite puzzled as to why using a powerline ethernet connection should cause such problems. Could there be something going on with our internet service provider? We can move the device back inside if necessary, but this is not an optimal solution.

Thanks for your help!

Hello Mwschaefer,

Thank you for providing the logs and the extensive tests that you have performed. From them, I cannot see any issue during the booting process of the Shake, so the problem is most likely not located there.

Could you please reboot the Shake and then try the following procedure to see if it solves the connectivity issue?

Please access your rs.local/ page, go to Settings (the gear icon high on the left), and then the Data tab. Make sure that the Forward Data box is checked, and then click Save and Restart.

The station should now be able to connect again.

If it does, then this error is caused by a known bug that we are examining and that will (hopefully) be solved in the next Shake OS v0.20 release.

Thank you for your cooperation.

Thank you for your help! I followed your instructions, and clicked the Forward Data box off and on again for good measure, and now the Shake says it is connected. I see that I am not the only person with this same problem - Iā€™m glad there seems to be a workaround to this bug. The Shake is already showing in Data View, waiting on it to show up in StationView still.

Now in StationView too, and all is back to normal, thanks!


That is perfect, thank you for the update!

Happy to hear that the workaround is working, we will definitely release a fix in the coming OS updates, so that this will not happen again.

Enjoy Shaking!