Server disconnected

I have been operated my raspberry shake few days ago.
The operation seems likely ok. However, I have server satatus “disconnected” and I couldn’t see my station on station view.
Data producer : on
Data consumer: on
Data provider :on
RSH.RD5B6.2023-07-05T05_29_44.logs.tar (1.4 MB)

Hello Paiboon, and welcome to our community.

Thank you for contacting us about this issue you are experiencing, and for sending the logs from your Shake.

It appears, from them, that the Shake cannot find a way to communicate with the server, as shown here:

2023 185 09:51:08>>	Connection attempt #1 ( failed with error code: No route to host

On this, I would like to ask you to check if ports 55555 and 55556 are open on your router, and if not, to open them. As there are hundreds of different router models/makers, I cannot offer precise guidance, but you should be able to find how to do so from the router manual and/or from your router admin panel.

Those ports are essential to communicate with our data servers, so it is required for them to be open in TCP if any Shake wants to transmit data to us. You can find a full list of ports that need to be open here on our manual: Firewall issues?

Once you have done so, please reboot both the router first, and then the Shake, to see if it now manages to connect. If not, please download the new logs and send them to me, so that I can make further checks.

Thank you.

Hi Stormchaser

I have tried several ways even change to another ISP. The result are the same, internet connection was not possible. I have also change the new router supplied by the ISP, it doesn’t help. The ISP told that , no any port closed.
I seems likely that the problem not coming from router. It should from the raspberry shake itself.
Please suggest me , how can I go further.

Login to your 'shake using ssh.
On the command line see if you can ping the remote system:

myshake@raspberryshake:/opt $ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=55 time=184 ms
64 bytes from icmp_seq=2 ttl=55 time=190 ms
64 bytes from icmp_seq=3 ttl=55 time=184 ms
64 bytes from icmp_seq=4 ttl=55 time=196 ms
--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 7ms
rtt min/avg/max/mdev = 183.555/188.459/196.401/5.243 mstype or paste code here

If that doesn’t work, see where the failure occurs using traceroute:

myshake@raspberryshake:/opt $ traceroute
traceroute to (, 30 hops max, 60 byte packets
 1 (  2.709 ms  2.919 ms  2.872 ms
 2 (  6.505 ms  6.845 ms  6.811 ms
 3 (  43.951 ms  43.849 ms  43.864 ms
 4 (  43.697 ms  16.092 ms  43.698 ms
 5 (  21.754 ms  43.595 ms  43.576 ms
 6 (  49.747 ms  48.527 ms  20.141 ms
 7 (  29.299 ms  23.838 ms  29.190 ms
 8 (  180.932 ms  180.890 ms  176.271 ms
 9 (  202.877 ms  202.791 ms  202.787 ms
10 (  202.703 ms  202.230 ms  202.551 ms

If those work, they you have network connectivity to the system you are trying to connect to.
Next, try the specific port:

myshake@raspberryshake:/opt $ nc -zvw5 55555
Connection to 55555 port [tcp/*] succeeded!

This should give you a clearer idea of what is going on.
You can also try these commands on another system connected to the same network.
You can at least run the ping and traceroute on a Windows machine (traceroute is called tracert on Windows) - I don’t think Windows has Netcat (nc).

1 Like

Hi Philip

Using ping command it didn’t work.
Trace route is ok.
Assigned port didn’t work. Failed: No route to host. is my ip address that provided by the ISP.


You are not using the correct IP address. It is, not

Dear PhillipPeake

I have used the results are below:


PS: I have tried pinging that connected in the same network with another equipment, it works

1 Like

Thank you Philip for suggesting those checks, and thank you paiboon for executing them.

It definitely appears that there is some kind of communication issue between the Shake and our servers, as no command is answering positively.

At this point, I would say that we can try to reset the Shake with a new re-burn, and then re-start our checks from there. Could you please re-burn your microSD card and see how the Shake behaves with a freshly-installed system? I will leave the burning instructions here for your convenience:

If the Shake connects, then there was something in the software that got fixed by the fresh re-burn. If not, then please send me again the following:

  1. the new logs from the Shake
  2. the output of the command ping
  3. the output of traceroute
  4. the output of nc -zvw5 55555

Thank you for your collaboration!