Server Connection: Not Connected2

Hi Shakers,

I have a raspberry shake I cannot get connected to net work. The time on it was very wrong so I manually reset that using SSH but it still says not connected. I have switched off firewall on 4G router I am using. I am lost for ideas. I have attached the log files.

cheers
JulianRSH.RAEED.2022-03-21T16_28_36.logs.tar (3.9 MB)

Hello Julian, welcome to our community!

Thank you for the logs from your Shake. From them, it appears that the unit cannot find an internet connection, from these lines:

2022 080 16:13:16: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available
2022 080 16:13:16: No internet connection found
2022 080 16:14:20: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

It also shows a Connection refused status when trying to reach our servers via ports 55555 and 55556. Some 4G routers are known to present these issues, and we have a basic page on GPRS/4G modem procedures on our manual here: How to setup USB GPRS — Instructions on Setting Up Your Raspberry Shake

Have you tried to connect the Shake to a modem/router via normal LAN cable and see if it manages to connect? You may have to repeat the procedure that you have already tried since your Shake has yet to update to v0.20 (which will be automatic).

I have tried the turning dataforwarding off for 30 secs and then turning it back on and that does not work.

1 Like

Dear Stormchaser,

The 4G router I am using has a LAN cable connection I am using to connect the PI to the router. Form my Laptop I can get access to the network through the router and through a normal raspberrypi which worked fine. We are using a 4G router as our uni network security would not allow us to use it on the Uni network. A colleague at another University has set up a raspberry shake with exactly the same router and internet service provider and theirs works. Station view does not appear to be working so I cannot give it’s name.

Julian

PS I have tried turning dataforwarding off for 30 secs and turning it back on.

Thanks for the help.

Running the ifconfig via a shell I get:

image

Can I update the raspberry shake manually using SSH?

I took a quick look at your logs. As Stormchaser said, it appears that some ports may be blocked by your router (or ISP). One of the first things that fails is getting an NTP connection up to set the date.

As you mention, it looks like DHCP is working, you are getting an IP assigned and some traffic is flowing on the eth0 interface.

I would try some basic connectivity checks from an ssh connection to your device. My typical sequence is something like this:

Check basic connectivity: Use ping to a well known, stable IP address (e.g. 8.8.8.8)

myshake@raspberryshake:/opt $ ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 bytes from 8.8.8.8: icmp_seq=1 ttl=55 time=21.4 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=55 time=25.6 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=55 time=24.3 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=55 time=21.7 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=55 time=23.5 ms
^C

— 8.8.8.8 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 10ms
rtt min/avg/max/mdev = 21.422/23.305/25.575/1.590 ms

If for some reason that doesn’t work, try traceroute to see where connectivity fails:

myshake@raspberryshake:/opt $ traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
1 10.0.0.1 (10.0.0.1) 1.498 ms 2.582 ms 2.932 ms
2 50-209-43-154-static.hfc.comcastbusiness.net (50.209.43.154) 4.922 ms 5.844 ms 11.731 ms
3 96.120.61.57 (96.120.61.57) 18.434 ms 22.965 ms 22.926 ms
4 ae-251-1204-rur102.salem.or.bverton.comcast.net (162.151.125.125) 29.136 ms 23.302 ms 23.263 ms
5 96.216.60.209 (96.216.60.209) 28.333 ms 28.525 ms 22.304 ms
6 96.216.60.221 (96.216.60.221) 29.972 ms 21.153 ms 16.392 ms
8 be-2212-pe12.seattle.wa.ibone.comcast.net (96.110.34.134) 18.106 ms be-2312-pe12.seattle.wa.ibone.comcast.net (96.110.34.138) 25.009 ms be-2411-pe11.seattle.wa.ibone.comcast.net (96.110.32.238) 25.938 ms
9 50.208.232.242 (50.208.232.242) 26.523 ms 50.242.150.242 (50.242.150.242) 26.871 ms 50.242.148.22 (50.242.148.22) 26.830 ms
10 * * *
11 dns.google (8.8.8.8) 25.890 ms 26.231 ms 25.811 ms

This is working ok, so let’s try to see that DNS is working:

myshake@raspberryshake:/opt $ ping -c 1 google.com
PING google.com (142.250.217.78) 56(84) bytes of data.
64 bytes from sea09s29-in-f14.1e100.net (142.250.217.78): icmp_seq=1 ttl=55 time=20.7 ms
google.com ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 20.681/20.681/20.681/0.000 ms

Ok, that found the IP of google.com and pinged it.

Now let’s try to see if we can get data from the NTP server (Need to be root to do this). Note that the “connected” response may take a few seconds:

myshake@raspberryshake:/opt $ sudo nc -u -v -z 1.debian.pool.ntp.org 123
Connection to 1.debian.pool.ntp.org 123 port [udp/ntp] succeeded!

If that much is working, your NTP should be working. Since it isn’t, one of those steps is going to fail which should help you determine where to start looking.

2 Likes

I saw another post where the problem was latent static IP addresses and DNS servers in the dhcpcd.conf file. I have looked in that file on my shake and indeed the where old static IP addresses and old DNS servers. I deleted those lines in the file and saved file then rebooted the shake. But still not connected. I can ping the shake from my computer I will try the othe commands you suggest and report back.

Julian

all those commands worked once I got rid of all the static references in the dhcpcd.conf file. So hopefully will work now. Thanks for your help.

2 Likes

If you look at rs.local it should look a lot healthier - it may also have updated to 0.20 too, which will fix the problem with having to flip the data on and off, and (I think…) the dhcpd.conf issue.

1 Like