"Server Connection : No connection" issue


I have a rshake 3D deployed on the field that gives me difficulties.
It has been deployed a week ago, and remain with the status “Not connected”.
It is a typical configuration with a 3G modem, validated on my side on several permanent seismic station and other RSHAKEs.

The date of the rshake is in 2019 because it cannot access to the web, while it is accessible remotely. None any firewall is activated on my 3G-modem.

I have tried to switch it in DHCP but the issue remains the same…I am a little bit disappointed.
Of course I have reboot it (from shell)…

Here is attached the log file of this shake.

RSH.R5156.2019-04-09T15_22_16.logs.tar (2.2 MB)

Hello Mickael, and welcome to the community!

Thank you for posting the logs, from them it is clear that, as you surely surmised, the Shake is not connecting to the internet. These two lines in particular show this:

2019 098 17:30:10: No internet connection found
2019 098 17:30:22: Unable to resolve hostname 'raspberryshake.net', most likely no DNS server available

Apr 08 17:29:41 raspberryshake systemd[1]: Failed to start Network Time Service.

The fact that the 3G modem has already been tested gives us good news. From the shell prompt, can you try an iwconfig command, and see what happens?

If the modem does not appear (and it should be so, since we are not getting connected), you can try this, from your prompt:

sudo vim /etc/network/interfaces

and then, at the end, add the following lines:

allow-hotplug usb0
auto usb0
    iface usb0 inet dhcp

allow-hotplug eth1
auto eth1
    iface eth1 inet dhcp

then reboot the Shake with the 3G modem connected to it, and then do another iwconfig.

If you see something similar to this:

eth1     Link encap:Ethernet  HWaddr 00:1e:10:1f:00:00    
     inet addr:  Bcast:  Mask:  
     inet6 addr: fe80::21e:10ff:fe1f:0/64 Scope:Link  
     RX packets:348 errors:0 dropped:0 overruns:0 frame:0  
     TX packets:53 errors:0 dropped:0 overruns:0 carrier:0  
     collisions:0 txqueuelen:1000   
     RX bytes:144890 (141.4 KiB)  TX bytes:5435 (5.3 KiB)

then the dongle should be all right. In practice, the 3G stick has been configured as a fake ethernet port (eth1) and from there you should be able to get internet.

Also, there is a reference in the manual, here, if the above doesn’t work, with a couple of examples that could give you a clue, since the configuration is different for each 3G stick: https://manual.raspberryshake.org/gprs.html?highlight=gprs


The 3G modem I am using is an external one, connected to the eth0
of the shake.

But looking to the file /etc/network/interfaces, I am suprised by
this line : iface eth0 inet manual

while I am using dhcp mode…

may I change it to :

auto eth0

iface eth0 inet dhcp





You can do that, since in the end this will be set-up as a virtual port. Not that something is attached to the actual ethernet port of the Shake, since you are using a 3G dongle.

However, before doing this process, you need to find out from the 3G provider you are using what their DNS server is.

Putting this information in should allow the Shake to resolve hostnames properly then, and thus the timing protocol NTP will start to work, synchronizing the clocks and uploading the Shake data.

I have tried this solution,
The shake now appears in the station vue, but remains grey. Moreover, when I ssh it, it is still not possible to ping google or anyother external web service.
The date has been updated to now.
What is strange is that when I try to ping an external web service, I obtain this :
From icmp_seq=1 Destination Host Unreachable
Why the adress is 169… while the eth0 is in ?

For me things remain not really good.

What can I check ?
How can I control that the ntp is working ?
How can I proceed to the upgrade of the shake (it is still in 0.15) ?


Hello Michael,

please send back the new log files, so we can check how the modifications influenced the whole setup, and proceed from there.

Thank you.


IP addresses in th 169 range are discovery IPs, which implies your unit is also directly connected to a PC. is this the case here?

as long as you cannot ping normal websites, the unit will not properly work to be connected to the internet, nor will it be able to connect to NTP servers, nor the update server, nor the data server. you must solve your DNS issues first.

the problem is your 3G dongle. to demonstrate this, please take your unit and connect directly to a router with an ethernet cable. have you contacted the phone service to ask them about assigned DNS servers?

the problem is that your 3G dongle is not providing DNS services. to demonstrate this, please take your unit and connect directly to a router with an ethernet cable. *have you contacted the phone service to ask them about assigned DNS servers?)



auto eth0

        iface eth0 inet dhcp

` After some other test I succeed to find a configuration that
seems to work…it is quite strange because I have some other
shake, with the same external 3G modem configuration that directly

The solution I used is to add at the end of the
/etc/network/interfaces file those to lines :
The other shakes work perfectly with fixed IP address…but anyway
now this one seems to work.

@richard, it was not a problem of 3G dongle or DNS services
because the 3G configuration used has been validated over dozen of
other seismic sites.

Thanks for your help.




this is strange since when using dhcp services and daemon, the eth0 line of the interfaces file is not used.

and i’m curious to see your log files now that your connection problems have resolved, if you have a moment to forward them. one other thing i see as well was that the unit was unable to upgrade to the latest version because of the connection issues. when possible, the unit should always be running the latest version to ensure no lurking bugs are still present.




The shakes finally upgrade to the 0.18 version.

Here is attached the logs files.



RSH.R5156.2020-08-27T10_21_35.logs.tar (4.64 MB)