Sd card problems

O.K. Thank you, Unfortunately The Sd Card can get a full memory and then it can not load the updates! I have had a problem that the SD card appears to be Read Only and can not be Formatted to clear existing files using Windows 10! Raspberry Shake is the only program that I have that uses RPi and I do not have any experiance working with this OS. I tried with a new card (Sandisk Industrial 8GB) formatting to Fat 32 and then Unzipping the Files from my PC to this Card. It appears to start O.K. then after a short while it says that the Card is Read Only and has a Cyclic Redundancy Error! I then tried Reformatting the new card and get the same Error! I have spent many hours searching Google and I have not been able to resolve this problem. It would be nice if the card did not completely fill and if some space could be reserved for updates, or at least give some notification that the card is near full, or even automatically clear memory when it starts getting full? For now I am just wary of buying a new card and encountering the same problems. This is why my Raspberry Shake is offline! Any help would be appreciated.

Hello Brian,

I’ve moved this answer to a new thread, so we can take care of it here instead of prolonging the other one, even if they are related.

This is a very unusual error since the entire Shake OS is not so extensive to entirely fill up an 8GB microSD card. I have tried to replicate this problem with two of my computers, both with Win10 and using the WinRAR software to extract the files, but I was unable to, unfortunately.

What software are you using to extract the files from the Shake OS zipped archive to the microSD card? Since you have already tried with another card (good thinking) and have obtained the same result, have you tried to extract the files with different software? On a different microSD card adaptor/port? Or with a different computer?

An 8GB microSD card will take usually weeks to become completely full, but even there, there are limits that the user can set so that this never happens, and there is always space for new data. It seems to me that this problem is related more to the extraction process involved in burning the new image.

My Main PC is an Acer Predator:

OS Name Microsoft Windows 10 Home
Version 10.0.19044 Build 19044
OS Manufacturer Microsoft Corporation
System Manufacturer Acer
System Model Predator G3-710
System Type x64-based PC
System SKU 0000000000000000
Processor Intel® Core™ i7-6700K CPU @ 4.00GHz, 4001 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. R01-A4, 5/19/2016
SMBIOS Version 3.0
Embedded Controller Version 255.255
BaseBoard Manufacturer Acer
BaseBoard Product Predator G3-710
BaseBoard Version
Platform Role Desktop
Secure Boot State On
PCR7 Configuration Elevation Required to View
Windows Directory C:\WINDOWS
System Directory C:\WINDOWS\system32
Boot Device \Device\HarddiskVolume2
Locale United States
Hardware Abstraction Layer Version = “10.0.19041.1151”
Time Zone Romance Standard Time
Installed Physical Memory (RAM) 16.0 GB
Total Physical Memory 15.9 GB
Available Physical Memory 7.61 GB
Total Virtual Memory 32.9 GB
Available Virtual Memory 22.3 GB
Page File Space 17.0 GB
Page File F:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled
Device Encryption Support Elevation Required to View
Hyper-V - VM Monitor Mode Extensions Yes
Hyper-V - Second Level Address Translation Extensions Yes
Hyper-V - Virtualization Enabled in Firmware Yes
Hyper-V - Data Execution Protection Yes

I have Tried with the built in Formatter, The SD association Formatter and EaseUS!
I have not been able to reformat these SD cards after trying to unzip the files from the PC to the Card. I have tried both the built in SD card reader and an USB adapter. To Unzip again using the built in windows Program! I am old and not very adventurous computer wise. I only do thing differently if I am forced by circumstances! Regards to the Card memory filling up, I refer to normal usage sometimes I forget to clear the available memory and this is when the card got full, unfortunately the update occurred during this time!
Basically what I want is to be able to reformat these 2 cards, unzip the program to one of them and fire everything up again?

Hello Brian54,

Thanks for the specifics of the pc, I cannot see any faults with those, since the requirements to do this work are indeed minimal.

EaseUS should have done the trick, however, since with that tool it is possible to see the partitions inside any disk and erase them all to restore the disk to its original state. Could you please post a screenshot of what EaseUS is showing when you insert one of the microSD cards that you have tested?

I don’t know why the microSD cards, at a certain point, become read-only. This has never happened to my memory so I am unfortunately unable to provide a reason.

I normally use the command line tool diskpart to format everything if some issues similar to this happen. You can find a step-by-step guide here, How to Format SD Card Using CMD | Terms and Tips, however, it can be a more complex process than the others tried until now.

O.K. I will try and get a Screenshot for you today! I am very busy and I am trying to fit this in between other things!

1 Like

I have Screenshot the whole process! I hope this makes sense. As you can see the original files are still there on the SD Card after all these deletes, cleans, formats, check disk etc? However, they will not start the Raspberry Pi, nor run the Shake program.
Thank you for your time, I am sorry that this is taking so long! (Nearly 4 months now!), but I can only do this when I am not busy with other things!

Screenshot 2022-01-20 082138.png

Screenshot 2022-01-20 085546.png

Screenshot 2022-01-20 083427.png

Hello Brian54,

Thank you for all the screenshots. It definitely seems that there is some corruption in the microSD cards, at least from what I can see by looking online.

I have found these two pages that could provide a solution:

Unfortunately, I am not sure of what is causing this error, so I cannot be more precise. It is not related to our Shake OS, so, if all fails, it could be worth acquiring yet another microSD card, to test if these two were damaged in some way. It has happened in the past on some rare occasions.

You will be pleased to know that I finally got a new SD card and I extracted the files into a new folder in Windows and then copied them to the SD card. Extracting directly to the card seems not to have worked because it put all the files in a folder! Copying from within the folder in windows directly to the SD card solved this. :slight_smile: It is working and I have RS Local on my browser just waiting for a server connection.


Hello Brian54,

That is great to know! And thanks for the feedback about the extraction process, I will know what to tell other users that may find themselves in a similar situation!

Happy to hear that now everything is working properly!

Yes. In the end it turned out to be a very simple problem and chasing things on Google about SD cards was not needed. I spent almost 6 months offline because Windows 10 insists that files things fit in Folders. I also spent a day trying to figure out why it was not connecting to the server, the new download sets up in offline mode and again for a computer dummy like me, this was not obvious. I have set the data reset to 5 days, however, thinking about it maybe, there are files that do not need to be copied to the SD card that would save more available space. Do I really need 3.5 GB to be taken???

The second-to-latest version, v0.19, had this issue that was then fixed on v0.20. Your new Shake image should have updated by itself after connection, so this problem will not appear again for you.

The daily reset is left completely to the choice of the user. We know that the Shake OS takes a good chunk out of the microSD card, but, for example, I have mine running at 15 days archive, and there are no particular issues with that.

You can always retrieve your data from our online servers, so, in the end, it is a reasonable value.