Running Swarm on RPI

Is this supposed to work? I downloaded this on another RPI (i.e. not the one in my RS4D, but a separate desktop system with screen, keyboard, mouse, etc.) It works somewhat but not all controls seems to work and I get error messages.

Help - can someone PLEASE answer this? It is a simple question.
Is Swarm supposed to work with Raspbian? Yes or No?

Hi, sorry for the delay—yes, this should work just fine and has for me in the past. What controls don’t work?

I used your instructions for a manual install - I did not use anybody’s script. It worked quite well up to a point. I was able to unload and unpack the zip file, start up Swarm, etc. I was able to set up my rs.local feed and see helicorder views of my 4 sensors and they seemed correct a s compared to the native helicorder within the unit itself. I got waveform squiggles. When I pushed the buttons for spectrogram displays, nothing happened.

I was using RP 3+b. Should I have used my RP 4b? Also, I got a number of errors in my terminal window, perhaps I should send you a screen grab of these?

I haven’t noticed that problem before, and the Pi 3 should be fine. We also don’t develop Swarm, a USGS scientist does. My suggestion would be to post a bug report (with screen shots) to their bug tracker:

@TCP491016 in my experience, the USGS scientists that maintain Swarm are super responsive to issue reports received on their github account.

Yours, Branden

@iannesbitt OK, I will contact the USGS people, but in the meantime, can you take a quick glance and this and see if anything pops out at you? Thanks. The lines with the dates come out when I start the swarm shell. The warnings come out as soon as I double click a data source.

pi@raspberrypi3:/usr/local/bin/swarm-3.1.0 $ sh
2020-06-23 08:16:21 INFO - Swarm version/date: Version: 3.1.0 Built: 2020-02-18T23:30:21Z
2020-06-23 08:16:21 INFO - current directory: /usr/local/bin/swarm-3.1.0
2020-06-23 08:16:21 INFO - user.home: /home/pi
2020-06-23 08:16:21 INFO - Using configuration file: Swarm.config
2020-06-23 08:16:22 INFO - java.version: 11.0.7
2020-06-23 08:16:22 INFO - maximum heap size: 218.500 MB
2020-06-23 08:16:25 INFO - loading MapPack: mapdata/augustine/MapPack.txt
2020-06-23 08:16:25 INFO - loading MapPack: mapdata/nasa_240m_A1/MapPack.txt
2020-06-23 08:16:25 INFO - loading MapPack: mapdata/nasa_2k/MapPack.txt
2020-06-23 08:16:25 INFO - loading MapPack: mapdata/nasa_240m_D2/MapPack.txt
2020-06-23 08:16:25 INFO - loading MapPack: mapdata/world/MapPack.txt
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by io.netty.util.internal.PlatformDependent0 (file:/usr/local/bin/swarm-3.1.0/lib/swarm.jar) to field java.nio.Buffer.address
WARNING: Please consider reporting this to the maintainers of io.netty.util.internal.PlatformDependent0
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
2020-06-23 08:16:44 INFO - Your platform does not provide complete low-level API for accessing direct buffers reliably. Unless explicitly requested, heap buffer will always be preferred to avoid potential system unstability.

That is definitely something for the developers.

Yours, branden

@brandon @iannesbitt Never got an answer from the Swarm people, but I solved the problem myself. Seems my JAVA was set to the OpenJDK version rather than the Oracle version. Works perfect now.


That makes total sense, and definitely would not be obvious from debugging output. Glad you figured it out, I’ll put a note about this in the manual.